[packages] bash: force linking against internal libreadline.a, fixes Backfire build...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Feb 2012 18:33:26 +0000 (18:33 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Feb 2012 18:33:26 +0000 (18:33 +0000)
SVN-Revision: 30653

utils/bash/Makefile
utils/bash/patches/001-compile-fix.patch
utils/bash/patches/002-force-internal-readline.patch [new file with mode: 0644]

index 0c6f0d9e41da526ad50ff84c05bdf78112fe0369..81162498978f71586dcf91d45305249ec46afb86 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
 PKG_VERSION:=4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/bash
index a0d03825047df15e28baafc877645cfe6d505f42..8f4090b27c0ccea375008253fc36278341421101 100644 (file)
@@ -1,8 +1,6 @@
-Index: bash-4.2/execute_cmd.c
-===================================================================
---- bash-4.2.orig/execute_cmd.c        2011-07-04 11:16:23.000000000 +0200
-+++ bash-4.2/execute_cmd.c     2011-07-04 11:17:33.000000000 +0200
-@@ -2202,7 +2202,11 @@
+--- a/execute_cmd.c
++++ b/execute_cmd.c
+@@ -2202,7 +2202,11 @@ execute_pipeline (command, asynchronous,
    /* If the `lastpipe' option is set with shopt, and job control is not
       enabled, execute the last element of non-async pipelines in the
       current shell environment. */
diff --git a/utils/bash/patches/002-force-internal-readline.patch b/utils/bash/patches/002-force-internal-readline.patch
new file mode 100644 (file)
index 0000000..ecb8375
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/configure
++++ b/configure
+@@ -5748,8 +5748,7 @@ _ACEOF
+               # static version specified as -llibname to override the
+               # dynamic version
+               case "${host_os}" in
+-              darwin[89]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
+-              *)              READLINE_LIB=-lreadline ;;
++              *) READLINE_LIB='${READLINE_LIBRARY}' ;;
+               esac
+       fi
+ else
+--- a/configure.in
++++ b/configure.in
+@@ -540,8 +540,7 @@ if test $opt_readline = yes; then
+               # static version specified as -llibname to override the
+               # dynamic version
+               case "${host_os}" in
+-              darwin[[89]]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
+-              *)              READLINE_LIB=-lreadline ;;
++              *) READLINE_LIB='${READLINE_LIBRARY}' ;;
+               esac
+       fi
+ else