travelmate: update 1.4.9 9423/head
authorDirk Brenken <dev@brenken.org>
Mon, 8 Jul 2019 12:02:47 +0000 (14:02 +0200)
committerDirk Brenken <dev@brenken.org>
Mon, 8 Jul 2019 12:02:47 +0000 (14:02 +0200)
* fix a corner case issue with auto expiry of the
  'Faulty Station' list (the last run information was not updated)

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/travelmate/Makefile
net/travelmate/files/travelmate.sh

index 1ba32dfc6a76d3615c6d61157627609b741e0e87..1cf91999607d3932e3f48afb062da3ad7fd94211 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=travelmate
-PKG_VERSION:=1.4.8
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index ed68c7bb465a5baa7c5b3ef813f41c3b5a6483ac..acb83a0ad981ee2bd033ff016903dffff42f7cd7 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-trm_ver="1.4.8"
+trm_ver="1.4.9"
 trm_sysver="unknown"
 trm_enabled=0
 trm_debug=0
@@ -359,6 +359,7 @@ f_jsnup()
                if [ -z "$(printf "%s" "${faulty_list}" | grep -Fo "${faulty_station}")" ]
                then
                        faulty_list="$(f_trim "${faulty_list} ${faulty_station}")"
+                       last_date="$(/bin/date "+%Y.%m.%d-%H:%M:%S")"
                fi
        fi
        json_add_string "travelmate_status" "${status}"