upgrade ixp4xx to 2.6.26-rc9, resync patches
authorImre Kaloz <kaloz@openwrt.org>
Fri, 11 Jul 2008 15:15:23 +0000 (15:15 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 11 Jul 2008 15:15:23 +0000 (15:15 +0000)
SVN-Revision: 11768

target/linux/generic-2.6/patches-2.6.26/200-sched_esfq.patch
target/linux/generic-2.6/patches-2.6.26/630-phy_packets.patch
target/linux/ixp4xx/Makefile
target/linux/ixp4xx/patches-2.6.26/111-pronghorn_swap_uarts.patch
target/linux/ixp4xx/patches-2.6.26/120-compex_support.patch
target/linux/ixp4xx/patches-2.6.26/130-wrt300nv2_support.patch
target/linux/ixp4xx/patches-2.6.26/140-sidewinder_support.patch
target/linux/ixp4xx/patches-2.6.26/150-lanready_ap1000_support.patch
target/linux/ixp4xx/patches-2.6.26/180-tw5334_support.patch
target/linux/ixp4xx/patches-2.6.26/190-cambria_support.patch
target/linux/ixp4xx/patches-2.6.26/400-dmabounce.patch

index 1dfd95e82b8ee0d241b6852479762611417e5d88..6d97dc356ebc53beba91c3aa74ff5f2487aeebdb 100644 (file)
@@ -40,7 +40,7 @@
  enum
 --- a/net/sched/Kconfig
 +++ b/net/sched/Kconfig
-@@ -139,6 +139,37 @@
+@@ -128,6 +128,37 @@
          To compile this code as a module, choose M here: the
          module will be called sch_sfq.
  
index e52f11a29413df5cc50787c2fd71d86361a38c58..f1c1580e0df92022cf64a0333521e2dce088f580 100644 (file)
@@ -50,7 +50,7 @@
  
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -609,6 +609,7 @@
+@@ -613,6 +613,7 @@
        void                    *ax25_ptr;      /* AX.25 specific data */
        struct wireless_dev     *ieee80211_ptr; /* IEEE 802.11 specific data,
                                                   assign before registering */
index 1e2a52ff07ad6bbe0c34eadef6a150dee3b32ba3..c922ffa61160eb9c2b6a17295b2d857d90fe9dc4 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.26-rc8
+LINUX_VERSION:=2.6.26-rc9
 
 include $(INCLUDE_DIR)/target.mk
 
index 2044a20ac036d3f74d4538c9ef8ab594c10cd58c..c2b684d0560ac3a5fe9341dd0e0c2a93388afa3b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/pronghorn-setup.c
 +++ b/arch/arm/mach-ixp4xx/pronghorn-setup.c
-@@ -50,31 +50,31 @@
+@@ -51,31 +51,31 @@
  
  static struct resource pronghorn_uart_resources [] = {
        {
index 9f309a6fa6be91d54ab4dbdcb3a5afb448f958b4..76111fd53b45bbf4864dd9ed4a4285a88411ac6a 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -83,6 +83,14 @@
-       depends on MACH_PRONGHORN
-       default y
+@@ -81,6 +81,14 @@
+ config MACH_PRONGHORNMETRO
+       def_bool MACH_PRONGHORN
  
 +config MACH_COMPEX
 +      bool "Compex WP18 / NP18A"
index 29c86390e815b88360063f2bba7e98195d20e743..edd68ecd68dc0e6648bfc1016bc656c3f8139708 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -91,6 +91,14 @@
+@@ -89,6 +89,14 @@
          WP18 or NP18A boards. For more information on this
          platform, see http://openwrt.org
  
index e3f450fdbdce1372a671b016efe0fab9d1532389..fcd9d67b67d5fc6f5ab2e24b516b90b12658db54 100644 (file)
@@ -1,8 +1,8 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -83,6 +83,14 @@
-       depends on MACH_PRONGHORN
-       default y
+@@ -81,6 +81,14 @@
+ config MACH_PRONGHORNMETRO
+       def_bool MACH_PRONGHORN
  
 +config MACH_SIDEWINDER
 +      bool "Sidewinder"
@@ -15,7 +15,7 @@
  config MACH_COMPEX
        bool "Compex WP18 / NP18A"
        select PCI
-@@ -181,7 +189,7 @@
+@@ -179,7 +187,7 @@
  #
  config CPU_IXP46X
        bool
index fd1567bcac2472a01d6c89e7a81c2aa3aa86c35d..9a00273551d2aee069f36329b9ce19ee2a584ac9 100644 (file)
  }
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -107,6 +107,14 @@
+@@ -105,6 +105,14 @@
          WRT300N v2 router. For more information on this
          platform, see http://openwrt.org
  
index 2632f80e1702acd7e2b4d9d1cbca8b4bb3a7812c..40724203c12b681c25cb74337beb01b2a4a9804a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -160,6 +160,14 @@
+@@ -158,6 +158,14 @@
          PrPCM1100 Processor Mezanine Module. For more information on
          this platform, see <file:Documentation/arm/IXP4xx>.
  
index b63cb17aaf39f97339b9a10973d34435ef6568f6..14555b48527c9c5810284d4f81205678f384d440 100644 (file)
@@ -15,7 +15,7 @@
  config MACH_LOFT
      bool "Loft"
      depends on MACH_AVILA
-@@ -210,7 +218,7 @@
+@@ -208,7 +216,7 @@
  
  config CPU_IXP43X
        bool
index 28230272eaad53ea5208b346990a188d34f5be18..8d2b4c7a73dbb6103779bdfea01171683d23aff2 100644 (file)
@@ -13,7 +13,7 @@
  
 --- a/arch/arm/mach-ixp4xx/Kconfig
 +++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -246,6 +246,11 @@
+@@ -244,6 +244,11 @@
        default y
        depends on PCI