modemmanager: bump to 1.22.0 22427/head
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>
Tue, 17 Oct 2023 12:22:14 +0000 (15:22 +0300)
committerMaxim Anisimov <maxim.anisimov.ua@gmail.com>
Wed, 18 Oct 2023 04:35:44 +0000 (07:35 +0300)
- switch to builtin plugins
- import upstream patch for fixing support of ublox LARA-R6001 / LARA-R6001D modules
  (see: https://gitlab.freedesktop.org/mobile-broadband/ModemManager/-/issues/779)

Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
net/modemmanager/Makefile
net/modemmanager/patches/100-ublox-remove-ID_MM_PROCESS-tags.patch [new file with mode: 0644]

index 864127a3d72c666a881423478b6fbd999756190f..fa6f1ea60f9285e50a39164828dd70976ec05ac3 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=modemmanager
-PKG_SOURCE_VERSION:=1.20.6
-PKG_RELEASE:=14
+PKG_SOURCE_VERSION:=1.22.0
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://gitlab.freedesktop.org/mobile-broadband/ModemManager.git
-PKG_MIRROR_HASH:=e90103e2e42bb826bbbac83937a9a69f50348cd6ce0d8da655a12b65494ce7c9
+PKG_MIRROR_HASH:=98daa1a15075c88afb3ed0de20dc83fe51d2ba3c66318ce3f731da4616a2e192
 
 PKG_MAINTAINER:=Nicholas Smith <nicholas@nbembedded.com>
 PKG_LICENSE:=GPL-2.0-or-later
@@ -64,6 +64,7 @@ MESON_ARGS += \
        -Dintrospection=false \
        -Dman=false \
        -Dbash_completion=false \
+       -Dbuiltin_plugins=true \
        -Db_lto=true \
        -Dmbim=$(if $(CONFIG_MODEMMANAGER_WITH_MBIM),true,false) \
        -Dqmi=$(if $(CONFIG_MODEMMANAGER_WITH_QMI),true,false) \
@@ -98,10 +99,6 @@ define Package/modemmanager/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmm-glib.so.* $(1)/usr/lib
 
-       $(INSTALL_DIR) $(1)/usr/lib/ModemManager
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/ModemManager/libmm-shared-*.so* $(1)/usr/lib/ModemManager
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/ModemManager/libmm-plugin-*.so* $(1)/usr/lib/ModemManager
-
        $(INSTALL_DIR) $(1)/usr/lib/ModemManager/connection.d
        $(INSTALL_BIN) ./files/10-report-down $(1)/usr/lib/ModemManager/connection.d
 
diff --git a/net/modemmanager/patches/100-ublox-remove-ID_MM_PROCESS-tags.patch b/net/modemmanager/patches/100-ublox-remove-ID_MM_PROCESS-tags.patch
new file mode 100644 (file)
index 0000000..d1f6753
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/src/plugins/ublox/77-mm-ublox-port-types.rules
++++ b/src/plugins/ublox/77-mm-ublox-port-types.rules
+@@ -88,8 +88,8 @@ SUBSYSTEMS=="usb", ATTRS{bInterfaceNumbe
+ #  ttyUSB2 (if #2): secondary
+ #  ttyUSB3 (if #3): unused (ignore)
+ ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="00", ENV{ID_MM_PORT_IGNORE}="1"
+-ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_PORT_TYPE_AT_PRIMARY}="1", ENV{ID_MM_DEVICE_PROCESS}="1"
+-ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="02", ENV{ID_MM_PORT_TYPE_AT_SECONDARY}="1", ENV{ID_MM_DEVICE_PROCESS}="1"
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="01", ENV{ID_MM_PORT_TYPE_AT_PRIMARY}="1"
++ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="02", ENV{ID_MM_PORT_TYPE_AT_SECONDARY}="1"
+ ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="908b", ENV{.MM_USBIFNUM}=="03", ENV{ID_MM_PORT_IGNORE}="1"
+ LABEL="mm_ublox_port_types_end"