bwm-ng: fix building with gcc-security enabled
authorJulen Landa Alustiza <julen@zokormazo.info>
Thu, 18 Jun 2015 16:45:04 +0000 (18:45 +0200)
committerJulen Landa Alustiza <julen@zokormazo.info>
Thu, 18 Jun 2015 16:45:04 +0000 (18:45 +0200)
Signed-off-by: Julen Landa Alustiza <julen@zokormazo.info>
net/bwm-ng/Makefile
net/bwm-ng/patches/0001-fix-gcc-security-build.patch [new file with mode: 0644]

index be017cc05a8f51b7c23047123b7a0ed6b205dc6b..f2084bec9d91df9974181111fc1e14212021c306 100644 (file)
@@ -1,12 +1,12 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
 #
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bwm-ng
 PKG_VERSION:=0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.gropp.org/bwm-ng
diff --git a/net/bwm-ng/patches/0001-fix-gcc-security-build.patch b/net/bwm-ng/patches/0001-fix-gcc-security-build.patch
new file mode 100644 (file)
index 0000000..742e45d
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/output.c
++++ b/src/output.c
+@@ -234,7 +234,7 @@ int print_header(int option) {
+                       if (output_method==PLAIN_OUT && ansi_output) printf("\033[1;2H");
+               printf("bwm-ng v" VERSION " (delay %2.3fs); ",(float)delay/1000);
+                       if (output_method==PLAIN_OUT) printf("press 'ctrl-c' to end this%s",(ansi_output ? "\033[2;2H" : "")); else printf("input: ");
+-            printf(input2str());
++            printf("%s\n",input2str());
+             printf("%s\n",show_all_if2str());
+                       if (output_method==PLAIN_OUT) {
+                               if (ansi_output)