python3-networkx: new package
authorW. Michael Petullo <mike@flyn.org>
Sat, 5 Sep 2020 00:04:21 +0000 (19:04 -0500)
committerPaul Spooren <mail@aparcar.org>
Sat, 12 Sep 2020 00:50:24 +0000 (14:50 -1000)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
lang/python/python3-networkx/Makefile [new file with mode: 0644]

diff --git a/lang/python/python3-networkx/Makefile b/lang/python/python3-networkx/Makefile
new file mode 100644 (file)
index 0000000..7e0b005
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python3-networkx
+PKG_VERSION:=2.5
+PKG_RELEASE:=1
+
+PYPI_NAME:=networkx
+PKG_HASH:=7978955423fbc9639c10498878be59caf99b44dc304c2286162fd24b458c1602
+
+PKG_LICENSE:=BSD-3-clause
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-networkx
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Creating and manipulating graphs and networks
+  URL:=https://networkx.github.io/
+  DEPENDS:=+python3-light +python3-decorator
+endef
+
+define Package/python3-networkx/description
+NetworkX is a Python package for the creation, manipulation, and study
+of the structure, dynamics, and functions of complex networks.
+endef
+
+$(eval $(call Py3Package,python3-networkx))
+$(eval $(call BuildPackage,python3-networkx))
+$(eval $(call BuildPackage,python3-networkx-src))