Merge pull request #1510 from jow-/ctorrent-svn-musl-compat
authortripolar <tripolar@users.noreply.github.com>
Tue, 30 Jun 2015 18:54:22 +0000 (20:54 +0200)
committertripolar <tripolar@users.noreply.github.com>
Tue, 30 Jun 2015 18:54:22 +0000 (20:54 +0200)
ctorrent-svn: fix musl compatibility

Signed-off-by: Jo-Philipp Wich jow@openwrt.org
Signed-off-by: tripolar@gmx.at
net/ctorrent-svn/Makefile
net/ctorrent-svn/patches/400-musl-compat.patch [new file with mode: 0644]

index 609206324ddb1cb470306565e6f38fe7216ccf56..0725f5934cf9705af24aceda10ed21b44f0974b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=ctorrent-svn
 PKG_REV:=322
 PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://svn.code.sf.net/p/dtorrent/code/dtorrent/trunk
diff --git a/net/ctorrent-svn/patches/400-musl-compat.patch b/net/ctorrent-svn/patches/400-musl-compat.patch
new file mode 100644 (file)
index 0000000..e17c147
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/compat.c
++++ b/compat.c
+@@ -51,6 +51,7 @@ int snprintf(char *str, size_t size, con
+ #ifndef HAVE_STRNSTR
+ #include <string.h>
++#include <sys/types.h>
+ /* FUNCTION PROGRAMER: Siberiaic Sang */
+ char *strnstr(const char *haystack, const char *needle, size_t haystacklen)
+ {