Add input-utils (#4009)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 18 Sep 2008 18:22:21 +0000 (18:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 18 Sep 2008 18:22:21 +0000 (18:22 +0000)
SVN-Revision: 12629

utils/input-utils/Makefile [new file with mode: 0644]

diff --git a/utils/input-utils/Makefile b/utils/input-utils/Makefile
new file mode 100644 (file)
index 0000000..c7b20bf
--- /dev/null
@@ -0,0 +1,47 @@
+# 
+# Copyright (C) 2007,2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=input-utils
+PKG_VERSION:=20051128-143821
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/input/
+PKG_SOURCE:=input-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://dl.bytesex.org/cvs-snapshots/
+PKG_MD5SUM:=3f8504c769c41de0456baaaca1484fa6
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/input-utils
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=Utilities for the input layer of the Linux kernel
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C "$(PKG_BUILD_DIR)" \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               STRIP="true" \
+               build
+endef
+
+define Package/input-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/input-events $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/input-kbd $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lsinput $(1)/usr/bin/
+
+endef
+
+$(eval $(call BuildPackage,input-utils))