python3: Update to 3.10.2, refresh patches 17624/head
authorJeffery To <jeffery.to@gmail.com>
Sun, 16 Jan 2022 20:29:10 +0000 (04:29 +0800)
committerJeffery To <jeffery.to@gmail.com>
Sun, 16 Jan 2022 20:32:42 +0000 (04:32 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python3-version.mk
lang/python/python3/Makefile
lang/python/python3/patches/014-remove-platform-so-suffix.patch
lang/python/python3/patches/016-adjust-config-paths.patch
lang/python/python3/patches/026-openssl-feature-flags.patch

index d85154de5751e230ceecbfa58c0e8322c373ae25..412ec34e117a3f5b1c59e4405b6e0b6597bc5854 100644 (file)
@@ -8,7 +8,7 @@
 # Note: keep in sync with setuptools & pip
 PYTHON3_VERSION_MAJOR:=3
 PYTHON3_VERSION_MINOR:=10
-PYTHON3_VERSION_MICRO:=1
+PYTHON3_VERSION_MICRO:=2
 
 PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)
 
index 1d6c021db8406ddaafa0f86a5598dda09659fdc3..50b84b10e3ecd2e801a473f2ccdcc3d3390ddc9f 100644 (file)
@@ -16,8 +16,7 @@ PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
-# FIXME: if updating, get rid of [1] & [2] asap
-PKG_HASH:=a7f1265b6e1a5de1ec5c3ec7019ab53413469934758311e9d240c46e5ae6e177
+PKG_HASH:=17de3ac7da9f2519aa9d64378c603a73a0e9ad58dffa8812e45160c086de64c7
 
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=PSF-2.0
@@ -206,14 +205,6 @@ define Build/Compile/python3-pip
                --root=$(PKG_BUILD_DIR)/install-pip \
                --prefix=/usr \
                $(PKG_BUILD_DIR)/Lib/ensurepip/_bundled/pip-$(PYTHON3_PIP_VERSION)-py3-none-any.whl
-       # FIXME: [1] get rid of this asap; 'patch' doesn't like Windows endings, and this file is full of them...
-       #        I actually tried this in a number of ways and the only way to fix this is to implement
-       #        a poor-man's dos2unix using sed.
-       #        The issue is with the pip package; it seems that it throws in some Windows line-endings
-       #        and 'patch' won't handle them. So, we do a "dos2unix" and then patch.
-       #        We can get rid of this once this is solved upstream and in pip:
-       #            https://github.com/pypa/pep517/pull/130
-       sed 's/\r//' -i $(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages/pip/_vendor/pep517/in_process/__init__.py
        $(call PatchDir,$(PKG_BUILD_DIR)/install-pip/usr/lib/python$(PYTHON3_VERSION)/site-packages,./patches-pip,)
 endef
 else
@@ -382,8 +373,6 @@ define Host/Install
                touch $(HOST_PYTHON3_PKG_DIR)/.setuptools_installed_$(PYTHON3_SETUPTOOLS_VERSION)-$(PYTHON3_SETUPTOOLS_PKG_RELEASE)
        )
        $(if $(wildcard $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)),,
-               # FIXME: [2] get rid of this asap; same as [1]
-               sed 's/\r//' -i $(HOST_PYTHON3_PKG_DIR)/pip/_vendor/pep517/in_process/__init__.py
                $(call HostPatchDir,$(HOST_PYTHON3_PKG_DIR),./patches-pip,)
                touch $(HOST_PYTHON3_PKG_DIR)/.pip_installed_$(PYTHON3_PIP_VERSION)-$(PYTHON3_PIP_PKG_RELEASE)
        )
index f56711115de285eba704948d14df9cf2149ce1c4..8b2b74a8e9093ee6c322b2dc8949556114d90014 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -15638,7 +15638,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
+@@ -15649,7 +15649,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
  $as_echo "$ABIFLAGS" >&6; }
  { $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
  $as_echo_n "checking SOABI... " >&6; }
@@ -11,7 +11,7 @@
  
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4820,7 +4820,7 @@ AC_SUBST(SOABI)
+@@ -4825,7 +4825,7 @@ AC_SUBST(SOABI)
  AC_MSG_CHECKING(ABIFLAGS)
  AC_MSG_RESULT($ABIFLAGS)
  AC_MSG_CHECKING(SOABI)
index c16229e51839b7b89208f6e1c7df24bebf89eba9..2c96998443e664c28357fb6555f568cc9c4fed9a 100644 (file)
@@ -39,7 +39,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      as_fn_error $? "Cross compiling required --host=HOST-TUPLE and --build=ARCH" "$LINENO" 5
-@@ -15708,7 +15708,7 @@ fi
+@@ -15719,7 +15719,7 @@ fi
  
  
  
@@ -59,7 +59,7 @@
      fi
  elif test "$cross_compiling" = maybe; then
      AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
-@@ -4878,7 +4878,7 @@ fi],
+@@ -4883,7 +4883,7 @@ fi],
  
  dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
  AC_SUBST(PY_ENABLE_SHARED)
index 398012ae4097cf5bf6620f9ff7c57813be1addca..9272f36a450e1c50a0c8597599372005be7948fc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Modules/_hashopenssl.c
 +++ b/Modules/_hashopenssl.c
-@@ -43,7 +43,9 @@
+@@ -48,7 +48,9 @@
  #define PY_OPENSSL_HAS_SCRYPT 1
  #define PY_OPENSSL_HAS_SHA3 1
  #define PY_OPENSSL_HAS_SHAKE 1
@@ -8,5 +8,5 @@
  #define PY_OPENSSL_HAS_BLAKE2 1
 +#endif
  
- static PyModuleDef _hashlibmodule;
+ #if OPENSSL_VERSION_NUMBER >= 0x30000000L
+ #define PY_EVP_MD EVP_MD