boost: Add ignore-site-config option to bjam 1917/head
authorTed Hess <thess@kitschensync.net>
Wed, 4 Nov 2015 20:33:10 +0000 (15:33 -0500)
committerTed Hess <thess@kitschensync.net>
Wed, 4 Nov 2015 20:33:10 +0000 (15:33 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/boost/Makefile

index 92fb68b1bba5202c9b6a1d69a7e891057136b6d0..23e91ad3e64dd2746203060e705c91deacdbd12d 100644 (file)
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=boost
 PKG_VERSION:=1_59_0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/boost
@@ -203,6 +203,7 @@ define Build/Compile
                ) \
                bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
+                       --ignore-site-config \
                        --toolset=gcc-$(ARCH) --build-type=minimal --layout=system abi=$(BOOST_ABI) \
                        --disable-long-double \
                        $(CONFIGURE_ARGS) \