Copy libgcrypt package from old repository
authorW. Michael Petullo <mike@flyn.org>
Thu, 17 Jul 2014 02:13:02 +0000 (22:13 -0400)
committerSteven Barth <steven@midlink.org>
Sat, 19 Jul 2014 12:08:11 +0000 (14:08 +0200)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/libgcrypt/Makefile [new file with mode: 0644]
libs/libgcrypt/patches/001-no_docs_tests.patch [new file with mode: 0644]

diff --git a/libs/libgcrypt/Makefile b/libs/libgcrypt/Makefile
new file mode 100644 (file)
index 0000000..e2b8b5e
--- /dev/null
@@ -0,0 +1,71 @@
+#
+# Copyright (C) 2005-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libgcrypt
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt
+PKG_MD5SUM:=693f9c64d50c908bc4d6e01da3ff76d8
+
+PKG_FIXUP:=patch-libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libgcrypt
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libgpg-error
+  TITLE:=GNU crypto library
+  URL:=http://directory.fsf.org/security/libgcrypt.html
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+endef
+
+define Package/libgcrypt/description
+ This is a general purpose cryptographic library based on the code from
+ GnuPG. It provides functions for all cryptograhic building blocks:
+ symmetric ciphers (AES, DES, Arcfour, CAST5), hash algorithms (MD5, SHA-1,
+ RIPE-MD160, SHA-224/256, SHA-384/512), MACs (HMAC for all hash
+ algorithms), public key algorithms (RSA, DSA), large integer functions,
+ random numbers and a lot of supporting functions. Some algorithms have
+ been disabled to reduce size (Blowfish, Twofish, Serpent,
+ RC2, SEED, Camellia, CRC, MD4, TIGER-192, Whirlpool, ElGamal, ECC).
+endef
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-asm \
+       --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
+       --enable-digests="md5 rmd160 sha1 sha256 sha512" \
+       --enable-ciphers="arcfour des aes cast5" \
+       --enable-pubkey-ciphers="rsa dsa"
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{la,a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(1)/usr/share/aclocal/
+       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/libgcrypt-config
+       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/libgcrypt-config
+       ln -sf $(STAGING_DIR)/usr/bin/libgcrypt-config $(2)/bin/
+endef
+
+define Package/libgcrypt/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgcrypt))
diff --git a/libs/libgcrypt/patches/001-no_docs_tests.patch b/libs/libgcrypt/patches/001-no_docs_tests.patch
new file mode 100644 (file)
index 0000000..cc184e4
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -22,8 +22,8 @@ AUTOMAKE_OPTIONS = dist-bzip2
+ DISTCHECK_CONFIGURE_FLAGS = --enable-random-daemon \
+   --enable-ciphers=arcfour:blowfish:cast5:des:aes:twofish:serpent:rfc2268:seed:camellia
+-DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
+-SUBDIRS =         compat mpi cipher random src doc tests
++DIST_SUBDIRS = m4 compat mpi cipher random src
++SUBDIRS =         compat mpi cipher random src
+ EXTRA_DIST = autogen.sh README.SVN
+ DISTCLEANFILES =
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -281,8 +281,8 @@ AUTOMAKE_OPTIONS = dist-bzip2
+ DISTCHECK_CONFIGURE_FLAGS = --enable-random-daemon \
+   --enable-ciphers=arcfour:blowfish:cast5:des:aes:twofish:serpent:rfc2268:seed:camellia
+-DIST_SUBDIRS = m4 compat mpi cipher random src doc tests
+-SUBDIRS = compat mpi cipher random src doc tests
++DIST_SUBDIRS = m4 compat mpi cipher random src
++SUBDIRS = compat mpi cipher random src
+ EXTRA_DIST = autogen.sh README.SVN
+ DISTCLEANFILES = 
+ all: config.h