dnsmasq: allow dnsmasq variants to be included in image
authorHenrique de Moraes Holschuh <henrique@nic.br>
Mon, 27 Aug 2018 11:31:29 +0000 (08:31 -0300)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 6 Sep 2018 19:34:34 +0000 (21:34 +0200)
The dnsmasq variants should provide dnsmasq, otherwise it is impossible
to include them in the image.

This change allows one to have CONFIG_PACKAGE_dnsmasq=m and
CONFIG_PACKAGE_dnsmasq-full=y, e.g. because you want DNSSEC support, or
IPSETs suport on your 3000-devices fleet ;-)

Signed-off-by: Henrique de Moraes Holschuh <henrique@nic.br>
package/network/services/dnsmasq/Makefile

index 57d1af62916caf46371d811bc6be4db4abff3312..7b95d5dccff46d3a2bd0ebecddfdaef015f387f5 100644 (file)
@@ -53,6 +53,7 @@ $(call Package/dnsmasq/Default)
   TITLE += (with DHCPv6 support)
   DEPENDS+=@IPV6
   VARIANT:=dhcpv6
+  PROVIDES:=dnsmasq
 endef
 
 define Package/dnsmasq-full
@@ -62,6 +63,7 @@ $(call Package/dnsmasq/Default)
        +PACKAGE_dnsmasq_full_ipset:kmod-ipt-ipset \
        +PACKAGE_dnsmasq_full_conntrack:libnetfilter-conntrack
   VARIANT:=full
+  PROVIDES:=dnsmasq
 endef
 
 define Package/dnsmasq/description