add --without-nmapfe to nmap configure and add mostlyclean target for rebuild
authorFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2005 20:16:28 +0000 (20:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 12 Jun 2005 20:16:28 +0000 (20:16 +0000)
SVN-Revision: 1221

openwrt/package/nmap/Makefile

index 6e685b4ea6ee5599334fc1f4698ec671fc0d46fe..8c010840bdcf5fa353d1be49bec014e1b7df86da 100644 (file)
@@ -48,6 +48,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_LARGEFILE) \
                  $(DISABLE_NLS) \
                  --without-openssl \
+                 --without-nmapfe \
                  --with-libpcap="$(STAGING_DIR)/usr" \
                  --with-libpcre="$(STAGING_DIR)/usr" \
        );
@@ -71,3 +72,7 @@ $(IPKG_NMAP):
        cp -fpR $(PKG_INSTALL_DIR)/usr/bin/nmap $(IDIR_NMAP)/usr/bin/
        $(RSTRIP) $(IDIR_NMAP)
        $(IPKG_BUILD) $(IDIR_NMAP) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built