python-pytest: add new package 11744/head
authorJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 27 Mar 2020 09:10:34 +0000 (10:10 +0100)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Tue, 7 Apr 2020 09:13:37 +0000 (11:13 +0200)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
lang/python/python-pytest/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-pytest/Makefile b/lang/python/python-pytest/Makefile
new file mode 100644 (file)
index 0000000..2a7003b
--- /dev/null
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-pytest
+PKG_VERSION:=5.4.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=pytest
+PKG_HASH:=84dde37075b8805f3d1f392cc47e38a0e59518fb46a431cfdaf7cf1ce805f970
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+HOST_PYTHON3_PACKAGE_BUILD_DEPENDS:=setuptools-scm
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-pytest
+  SUBMENU:=Python
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=Python testing framework
+  URL:=https://docs.pytest.org/en/latest/
+  DEPENDS:= \
+       +python3-light \
+       +python3-more-itertools \
+       +python3-py \
+       +python3-attrs \
+       +python3-pluggy \
+       +python3-packaging \
+       +python3-wcwidth \
+       +python3-decimal \
+       +python3-logging \
+       +python3-urllib
+
+  VARIANT:=python3
+endef
+
+define Package/python3-pytest/description
+  The pytest framework makes it easy to write small tests, yet scales to support
+  complex functional testing for applications and libraries.
+endef
+
+$(eval $(call Py3Package,python3-pytest))
+$(eval $(call BuildPackage,python3-pytest))
+$(eval $(call BuildPackage,python3-pytest-src))