Adding specific OLPC xorg.conf
authorJens Muecke <jens@nons.de>
Thu, 24 Jan 2008 20:00:45 +0000 (20:00 +0000)
committerJens Muecke <jens@nons.de>
Thu, 24 Jan 2008 20:00:45 +0000 (20:00 +0000)
SVN-Revision: 10237

XOrg/server/xorg-server-X11R7.2/Makefile
XOrg/server/xorg-server-X11R7.2/files/xorg-olpc.conf [new file with mode: 0644]

index 115aa754f7e7ad8395bb352a0ebbec0951dc12f8..ddc0e3eed758aee2fb9d4ba66debb87447330469 100644 (file)
@@ -94,6 +94,13 @@ DEPENDS_KDRIVE:=+calibrateproto \
                +libX11 \
                @DISPLAY_SUPPORT 
 
+
+ifneq ($(CONFIG_TARGET_olpc),)
+  XORG_CONFIG_FILE=xorg-olpc.conf
+else
+  XORG_CONFIG_FILE=xorg.conf
+endif
+
 define Package/xorg-server/config
        config XORG_BUILD_KDRIVE
                bool "Build kdrive instead of xserver"
@@ -152,7 +159,7 @@ define Package/xorg-server/install
        rm -rf $(1)/usr/share/X11 $(1)/usr/lib/X11/xserver      
        $(INSTALL_DIR) $(1)/var/log/
        $(INSTALL_DIR) $(1)/etc/X11/
-       $(CP) files/xorg.conf $(1)/etc/X11/
+       $(CP) files/$(XORG_CONFIG_FILE) $(1)/etc/X11/
 endef
 
 define Packages/xorg-server-config/install
diff --git a/XOrg/server/xorg-server-X11R7.2/files/xorg-olpc.conf b/XOrg/server/xorg-server-X11R7.2/files/xorg-olpc.conf
new file mode 100644 (file)
index 0000000..0a312cf
--- /dev/null
@@ -0,0 +1,73 @@
+# xorg configuration
+
+Section "ServerLayout"
+       Identifier     "Default Layout"
+       Screen      0  "Screen0" 0 0
+       InputDevice    "Mouse0" "CorePointer"
+       InputDevice    "Keyboard0" "CoreKeyboard"
+EndSection
+
+Section "Files"
+       FontPath     "/usr/lib/X11/fonts/misc"
+EndSection
+
+Section "Module"
+       Load  "dbe"
+       Load  "extmod"
+       Load  "fbdevhw"
+#      Load  "glx"
+       Load  "record"
+       Load  "freetype"
+       Load  "type1"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Keyboard0"
+       Driver      "keyboard"
+       Option      "XkbModel" "pc105"
+       Option      "XkbLayout" "us"
+EndSection
+
+Section "InputDevice"
+       Identifier  "Mouse0"
+       Driver      "mouse"
+       Option      "Protocol" "PS/2"
+#      Option      "Protocol" "IMPS/2"
+       Option      "Device" "/dev/psaux"
+#      Option      "Device" "/dev/input/mice"
+       Option      "ZAxisMapping" "4 5"
+       Option      "Emulate3Buttons" "yes"
+EndSection
+
+Section "Monitor"
+       Identifier   "Monitor0"
+       VendorName   "Monitor Vendor"
+       ModelName    "OWRT"
+       Option       "dpms"
+EndSection
+
+Section "Device"
+       Identifier  "FBDev"
+       Driver      "fbdev"
+       #Option     "shadowfb" "off"
+       VideoRam    4096
+EndSection
+
+Section "Screen"
+    Identifier "Screen0"
+    Device     "FBDev"
+    Monitor    "Monitor0"
+    DefaultDepth 16
+
+    SubSection "Display"
+        Depth          16
+        Modes          "1200x900"
+    EndSubsection
+
+EndSection
+
+Section "DRI"
+       Group        0
+       Mode         0666
+EndSection
+