podman: update to v3.4.4
authorOskari Rauta <oskari.rauta@gmail.com>
Thu, 16 Dec 2021 00:25:58 +0000 (02:25 +0200)
committerNick Hainke <vincent@systemli.org>
Thu, 16 Dec 2021 09:15:51 +0000 (10:15 +0100)
list of changes: https://github.com/containers/podman/releases

Added patch for compiling with musl. Patch can be removed on next
release as it is already merged to podman git but not on this release.
Patch moves definition in source so definition is available before it
is being used.

Patch source: https://github.com/containers/podman/pull/12564

Patch re-created with quilt.

Signed-off-by: Oskari Rauta <oskari.rauta@gmail.com>
utils/podman/Makefile
utils/podman/patches/010-declare-temp-failure-retry-before-usage.patch [new file with mode: 0644]

index afa5e12e92919af9e24933a7474e58fe3df4389e..a9f0c783166afe7a125b69b3b1b559d67e500771 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=podman
-PKG_VERSION:=3.4.2
+PKG_VERSION:=3.4.4
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/containers/podman/archive/v$(PKG_VERSION)
-PKG_HASH:=b0c4f9a11eb500b1d440d5e51a6c0c632aa4ac458e2dc0362f50f999eb7fbf31
+PKG_HASH:=718c9e1e734c2d374fcf3c59e4cc7c1755acb954fc7565093e1d636c04b72e3a
 
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
diff --git a/utils/podman/patches/010-declare-temp-failure-retry-before-usage.patch b/utils/podman/patches/010-declare-temp-failure-retry-before-usage.patch
new file mode 100644 (file)
index 0000000..a111da4
--- /dev/null
@@ -0,0 +1,34 @@
+--- a/pkg/rootless/rootless_linux.c
++++ b/pkg/rootless/rootless_linux.c
+@@ -19,6 +19,15 @@
+ #include <sys/select.h>
+ #include <stdio.h>
++#ifndef TEMP_FAILURE_RETRY
++#define TEMP_FAILURE_RETRY(expression) \
++  (__extension__                                                              \
++    ({ long int __result;                                                     \
++       do __result = (long int) (expression);                                 \
++       while (__result == -1L && errno == EINTR);                             \
++       __result; }))
++#endif
++
+ #define cleanup_free __attribute__ ((cleanup (cleanup_freep)))
+ #define cleanup_close __attribute__ ((cleanup (cleanup_closep)))
+ #define cleanup_dir __attribute__ ((cleanup (cleanup_dirp)))
+@@ -72,15 +81,6 @@ int rename_noreplace (int olddirfd, cons
+   return rename (oldpath, newpath);
+ }
+-#ifndef TEMP_FAILURE_RETRY
+-#define TEMP_FAILURE_RETRY(expression) \
+-  (__extension__                                                              \
+-    ({ long int __result;                                                     \
+-       do __result = (long int) (expression);                                 \
+-       while (__result == -1L && errno == EINTR);                             \
+-       __result; }))
+-#endif
+-
+ static const char *_max_user_namespaces = "/proc/sys/user/max_user_namespaces";
+ static const char *_unprivileged_user_namespaces = "/proc/sys/kernel/unprivileged_userns_clone";