packages/oidentd: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:26 +0000 (23:43 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:43:26 +0000 (23:43 +0000)
SVN-Revision: 28913

net/oidentd/Makefile
net/oidentd/files/oidentd.init

index ef604315bdff7e9af553ffe2acf2db1307702afe..9959c5f7e20412891025b545392f1ff723c8bd76 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oidentd
 PKG_VERSION:=2.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ojnk
index 2bdc34df69bd684952ffd20cdc840afde9a371cf..4b4f309edba4d61cd2c34fe5c579fcf55fefaa35 100644 (file)
@@ -1,11 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=85
+
 start() {
-       /usr/sbin/oidentd -m -f 113
+       service_start /usr/sbin/oidentd -m -f 113
 }
 
 stop() {
-       killall oidentd
+       service_stop /usr/sbin/oidentd
 }