libs/elfutils: update to version 0.150
authorAlexandros C. Couloumbis <alex@ozo.com>
Fri, 3 Dec 2010 08:07:53 +0000 (08:07 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Fri, 3 Dec 2010 08:07:53 +0000 (08:07 +0000)
SVN-Revision: 24222

libs/elfutils/Makefile
libs/elfutils/patches/001-elfutils-portability.patch
libs/elfutils/patches/002-no_tests.patch
libs/elfutils/patches/003-no_warnings_as_errors.patch

index 2582982f6bf5b08380da95e7021792e6dd341c59..a12b94a5c9ce206fe08f4a15f83b9db529f88e55 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elfutils
-PKG_VERSION:=0.147
+PKG_VERSION:=0.150
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/elfutils/
-PKG_MD5SUM:=ccb6bba1d96c096f1b5dbd34444554a3
+PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
+PKG_MD5SUM:=3dcfb28fa339090a1d29a9e148cce469
 
 PKG_INSTALL:=1
 
index f9e3f329c883247d87a366913ae3a18495b50582..be1015443ba0cf2e08da81c66b331c3039d24717 100644 (file)
@@ -1,6 +1,6 @@
 --- a/backends/ChangeLog
 +++ b/backends/ChangeLog
-@@ -106,6 +106,10 @@
+@@ -111,6 +111,10 @@
        * ppc_attrs.c (ppc_check_object_attribute): Handle tag
        GNU_Power_ABI_Struct_Return.
  
@@ -11,7 +11,7 @@
  2008-10-04  Ulrich Drepper  <drepper@redhat.com>
  
        * i386_reloc.def: Fix entries for TLS_GOTDESC, TLS_DESC_CALL, and
-@@ -433,6 +437,11 @@
+@@ -438,6 +442,11 @@
        * sparc_init.c: Likewise.
        * x86_64_init.c: Likewise.
  
@@ -23,7 +23,7 @@
  2005-11-19  Roland McGrath  <roland@redhat.com>
  
        * ppc64_reloc.def: REL30 -> ADDR30.
-@@ -455,6 +464,9 @@
+@@ -460,6 +469,9 @@
        * Makefile.am (uninstall): Don't try to remove $(pkgincludedir).
        (CLEANFILES): Add libebl_$(m).so.
  
@@ -54,7 +54,7 @@
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -193,6 +194,7 @@ SHELL = @SHELL@
+@@ -194,6 +195,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
@@ -62,7 +62,7 @@
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -256,7 +258,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -257,7 +259,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(top_srcdir)/libelf -I$(top_srcdir)/libdw
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
@@ -71,7 +71,7 @@
        $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
        $(am__append_1)
  @MUDFLAP_FALSE@libmudflap = 
-@@ -697,7 +699,7 @@ libebl_%.so libebl_%.map: libebl_%_pic.a
+@@ -698,7 +700,7 @@ libebl_%.so libebl_%.map: libebl_%_pic.a
        $(LINK) -shared -o $(@:.map=.so) \
                -Wl,--whole-archive $< $(cpu_$*) -Wl,--no-whole-archive \
                -Wl,--version-script,$(@:.so=.map) \
@@ -82,7 +82,7 @@
  libebl_i386.so: $(cpu_i386)
 --- a/ChangeLog
 +++ b/ChangeLog
-@@ -2,6 +2,10 @@
+@@ -7,6 +7,10 @@
  
        * configure.ac (LOCALEDIR, DATADIRNAME): Removed.
  
@@ -93,7 +93,7 @@
  2009-09-21  Ulrich Drepper  <drepper@redhat.com>
  
        * configure.ac: Update for more modern autoconf.
-@@ -10,6 +14,10 @@
+@@ -15,6 +19,10 @@
  
        * configure.ac (zip_LIBS): Check for liblzma too.
  
  2009-04-19  Roland McGrath  <roland@redhat.com>
  
        * configure.ac (eu_version): Round down here, not in version.h macros.
-@@ -21,6 +29,8 @@
+@@ -26,6 +34,8 @@
  
  2009-01-23  Roland McGrath  <roland@redhat.com>
  
        * configure.ac (zlib check): Check for gzdirect, need zlib >= 1.2.2.3.
  
        * configure.ac (__thread check): Use AC_LINK_IFELSE, in case of
-@@ -101,6 +111,10 @@
+@@ -106,6 +116,10 @@
        * configure.ac: Add dummy automake conditional to get dependencies
        for non-generic linker right.  See src/Makefile.am.
  
  2005-11-18  Roland McGrath  <roland@redhat.com>
  
        * Makefile.am (DISTCHECK_CONFIGURE_FLAGS): New variable.
-@@ -148,6 +162,17 @@
+@@ -153,6 +167,17 @@
        * Makefile.am (all_SUBDIRS): Add libdwfl.
        * configure.ac: Write libdwfl/Makefile.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -104,6 +105,7 @@ SHELL = @SHELL@
+@@ -105,6 +106,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  /* $libdir subdirectory containing libebl modules. */
  #undef LIBEBL_SUBDIR
  
-@@ -52,4 +55,7 @@
+@@ -55,4 +58,7 @@
  /* Define for large files, on AIX-style hosts. */
  #undef _LARGE_FILES
  
  #include <eu-config.h>
 --- a/configure
 +++ b/configure
-@@ -646,6 +646,8 @@ NEVER_TRUE
+@@ -602,6 +602,8 @@ NEVER_TRUE
  base_cpu
  NATIVE_LD_FALSE
  NATIVE_LD_TRUE
  LEXLIB
  LEX_OUTPUT_ROOT
  LEX
-@@ -4098,6 +4100,205 @@ $as_echo "$as_me: error: gcc with C99 su
+@@ -3858,6 +3860,130 @@ if test "x$ac_cv_c99" != xyes; then :
+   as_fn_error $? "gcc with C99 support required" "$LINENO" 5
  fi
  
-+{ $as_echo "$as_me:$LINENO: checking for -Wextra option to $CC" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -Wextra option to $CC" >&5
 +$as_echo_n "checking for -Wextra option to $CC... " >&6; }
-+if test "${ac_cv_cc_wextra+set}" = set; then
++if test "${ac_cv_cc_wextra+set}" = set; then :
 +  $as_echo_n "(cached) " >&6
 +else
 +  old_CFLAGS="$CFLAGS"
 +CFLAGS="$CFLAGS -Wextra"
-+cat >conftest.$ac_ext <<_ACEOF
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h.  */
 +void foo (void) { }
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (ac_try="$ac_compile"
-+case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-+$as_echo "$ac_try_echo") >&5
-+  (eval "$ac_compile") 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } && {
-+       test -z "$ac_c_werror_flag" ||
-+       test ! -s conftest.err
-+       } && test -s conftest.$ac_objext; then
++if ac_fn_c_try_compile "$LINENO"; then :
 +  ac_cv_cc_wextra=yes
 +else
-+  $as_echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+      ac_cv_cc_wextra=no
++  ac_cv_cc_wextra=no
 +fi
-+
 +rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
 +CFLAGS="$old_CFLAGS"
 +fi
-+{ $as_echo "$as_me:$LINENO: result: $ac_cv_cc_wextra" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_cc_wextra" >&5
 +$as_echo "$ac_cv_cc_wextra" >&6; }
 +
-+if test "x$ac_cv_cc_wextra" = xyes; then
++if test "x$ac_cv_cc_wextra" = xyes; then :
 +  WEXTRA=-Wextra
 +else
 +  WEXTRA=-W
 +fi
 +
-+
-+{ $as_echo "$as_me:$LINENO: checking for -fgnu89-inline option to $CC" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -fgnu89-inline option to $CC" >&5
 +$as_echo_n "checking for -fgnu89-inline option to $CC... " >&6; }
-+if test "${ac_cv_cc_gnu89_inline+set}" = set; then
++if test "${ac_cv_cc_gnu89_inline+set}" = set; then :
 +  $as_echo_n "(cached) " >&6
 +else
 +  old_CFLAGS="$CFLAGS"
 +CFLAGS="$CFLAGS -fgnu89-inline -Werror"
-+cat >conftest.$ac_ext <<_ACEOF
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h.  */
 +
 +void foo (void)
 +{
 +extern inline void baz (void) {}
 +
 +_ACEOF
-+rm -f conftest.$ac_objext
-+if { (ac_try="$ac_compile"
-+case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-+$as_echo "$ac_try_echo") >&5
-+  (eval "$ac_compile") 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } && {
-+       test -z "$ac_c_werror_flag" ||
-+       test ! -s conftest.err
-+       } && test -s conftest.$ac_objext; then
++if ac_fn_c_try_compile "$LINENO"; then :
 +  ac_cv_cc_gnu89_inline=yes
 +else
-+  $as_echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+      ac_cv_cc_gnu89_inline=no
++  ac_cv_cc_gnu89_inline=no
 +fi
-+
 +rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
 +CFLAGS="$old_CFLAGS"
 +fi
-+{ $as_echo "$as_me:$LINENO: result: $ac_cv_cc_gnu89_inline" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_cc_gnu89_inline" >&5
 +$as_echo "$ac_cv_cc_gnu89_inline" >&6; }
-+if test "x$ac_cv_cc_gnu89_inline" = xyes; then
++if test "x$ac_cv_cc_gnu89_inline" = xyes; then :
 +  WEXTRA="${WEXTRA:+$WEXTRA }-fgnu89-inline"
 +fi
 +
-+
-+{ $as_echo "$as_me:$LINENO: checking for --as-needed linker option" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for --as-needed linker option" >&5
 +$as_echo_n "checking for --as-needed linker option... " >&6; }
-+if test "${ac_cv_as_needed+set}" = set; then
++if test "${ac_cv_as_needed+set}" = set; then :
 +  $as_echo_n "(cached) " >&6
 +else
 +  cat > conftest.c <<EOF
 +if { ac_try='${CC-cc} $CFLAGS $CPPFLAGS $LDFLAGS
 +                          -fPIC -shared -o conftest.so conftest.c
 +                          -Wl,--as-needed 1>&5'
-+  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++  { { eval echo "\"\$as_me\":${as_lineno-$LINENO}: \"$ac_try\""; } >&5
 +  (eval $ac_try) 2>&5
 +  ac_status=$?
-+  $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); }; }
++  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
++  test $ac_status = 0; }; }
 +then
 +  ac_cv_as_needed=yes
 +else
 +fi
 +rm -f conftest*
 +fi
-+{ $as_echo "$as_me:$LINENO: result: $ac_cv_as_needed" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_as_needed" >&5
 +$as_echo "$ac_cv_as_needed" >&6; }
-+if test "x$ac_cv_as_needed" = xyes; then
++if test "x$ac_cv_as_needed" = xyes; then :
 +  LD_AS_NEEDED=-Wl,--as-needed
 +else
 +  LD_AS_NEEDED=
 +fi
 +
 +
-+
-+{ $as_echo "$as_me:$LINENO: checking for __builtin_popcount" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for __builtin_popcount" >&5
 +$as_echo_n "checking for __builtin_popcount... " >&6; }
-+if test "${ac_cv_popcount+set}" = set; then
++if test "${ac_cv_popcount+set}" = set; then :
 +  $as_echo_n "(cached) " >&6
 +else
-+  cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h.  */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
++  cat confdefs.h - <<_ACEOF >conftest.$ac_ext
 +/* end confdefs.h.  */
 +
 +int
 +  return 0;
 +}
 +_ACEOF
-+rm -f conftest.$ac_objext conftest$ac_exeext
-+if { (ac_try="$ac_link"
-+case "(($ac_try" in
-+  *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
-+  *) ac_try_echo=$ac_try;;
-+esac
-+eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
-+$as_echo "$ac_try_echo") >&5
-+  (eval "$ac_link") 2>conftest.er1
-+  ac_status=$?
-+  grep -v '^ *+' conftest.er1 >conftest.err
-+  rm -f conftest.er1
-+  cat conftest.err >&5
-+  $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+  (exit $ac_status); } && {
-+       test -z "$ac_c_werror_flag" ||
-+       test ! -s conftest.err
-+       } && test -s conftest$ac_exeext && {
-+       test "$cross_compiling" = yes ||
-+       $as_test_x conftest$ac_exeext
-+       }; then
++if ac_fn_c_try_link "$LINENO"; then :
 +  ac_cv_popcount=yes
 +else
-+  $as_echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+      ac_cv_popcount=no
++  ac_cv_popcount=no
 +fi
-+
-+rm -rf conftest.dSYM
-+rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
-+      conftest$ac_exeext conftest.$ac_ext
++rm -f core conftest.err conftest.$ac_objext \
++    conftest$ac_exeext conftest.$ac_ext
 +fi
-+{ $as_echo "$as_me:$LINENO: result: $ac_cv_popcount" >&5
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_popcount" >&5
 +$as_echo "$ac_cv_popcount" >&6; }
-+if test "x$ac_cv_popcount" = xyes; then
++if test "x$ac_cv_popcount" = xyes; then :
 +
-+cat >>confdefs.h <<\_ACEOF
-+#define HAVE_BUILTIN_POPCOUNT 1
-+_ACEOF
++$as_echo "#define HAVE_BUILTIN_POPCOUNT 1" >>confdefs.h
 +
 +fi
 +
-+
- { $as_echo "$as_me:$LINENO: checking for __thread support" >&5
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for __thread support" >&5
  $as_echo_n "checking for __thread support... " >&6; }
- if test "${ac_cv_tls+set}" = set; then
-@@ -4163,9 +4364,18 @@ fi
- { $as_echo "$as_me:$LINENO: result: $ac_cv_tls" >&5
+ if test "${ac_cv_tls+set}" = set; then :
+@@ -3894,7 +4020,11 @@ fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_tls" >&5
  $as_echo "$ac_cv_tls" >&6; }
- if test "x$ac_cv_tls" != xyes; then
--  { { $as_echo "$as_me:$LINENO: error: __thread support required" >&5
--$as_echo "$as_me: error: __thread support required" >&2;}
-+  if test "$use_locks" = yes; then
-+  { { $as_echo "$as_me:$LINENO: error: --enable-thread-safety requires __thread support" >&5
-+$as_echo "$as_me: error: --enable-thread-safety requires __thread support" >&2;}
-    { (exit 1); exit 1; }; }
-+else
-+
-+cat >>confdefs.h <<\_ACEOF
-+#define __thread /* empty: no multi-thread support */
-+_ACEOF
-+
-+fi
-+
+ if test "x$ac_cv_tls" != xyes; then :
+-  as_fn_error $? "__thread support required" "$LINENO" 5
++  if test "$use_locks" = yes; then :
++    as_fn_error "--enable-thread-safety requires __thread support" "$LINENO" 5
++  else
++    as_echo "#define __thread /* empty: no multi-thread support */" >>confdefs.h
++  fi
  fi
  
-@@ -5454,7 +5664,7 @@ ac_config_files="$ac_config_files versio
+ # Check whether --enable-largefile was given.
+@@ -4880,7 +5010,7 @@ ac_config_files="$ac_config_files versio
  
  # 1.234<whatever> -> 1234<whatever>
  case "$PACKAGE_VERSION" in
 -[0-9].*) eu_version="${PACKAGE_VERSION/./}" ;;
 +[0-9].*) eu_version=`echo "$PACKAGE_VERSION" | sed 's@\.@@'` ;;
- *)               { { $as_echo "$as_me:$LINENO: error: confused by version number '$PACKAGE_VERSION'" >&5
- $as_echo "$as_me: error: confused by version number '$PACKAGE_VERSION'" >&2;}
-    { (exit 1); exit 1; }; } ;;
-@@ -5489,7 +5699,7 @@ $as_echo "$as_me: error: confused by ver
+ *)               as_fn_error $? "confused by version number '$PACKAGE_VERSION'" "$LINENO" 5 ;;
+ esac
+ case "$eu_version" in
+@@ -4909,7 +5039,7 @@ case "$eu_version" in
  esac
  
  # Round up to the next release API (x.y) version.
  AC_OUTPUT
 --- a/lib/ChangeLog
 +++ b/lib/ChangeLog
-@@ -8,6 +8,9 @@
+@@ -14,6 +14,9 @@
  
  2009-01-23  Roland McGrath  <roland@redhat.com>
  
        * eu-config.h: Add multiple inclusion protection.
  
  2009-01-17  Ulrich Drepper  <drepper@redhat.com>
-@@ -64,6 +67,11 @@
+@@ -70,6 +73,11 @@
        * Makefile.am (libeu_a_SOURCES): Add it.
        * system.h: Declare crc32_file.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -127,6 +128,7 @@ SHELL = @SHELL@
+@@ -128,6 +129,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -189,7 +191,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -190,7 +192,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libelf
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -175,6 +176,7 @@ SHELL = @SHELL@
+@@ -176,6 +177,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = 1
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -238,7 +240,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -239,7 +241,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(top_srcdir)/libdw
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libcpu/ChangeLog
 +++ b/libcpu/ChangeLog
-@@ -9,6 +9,9 @@
+@@ -15,6 +15,9 @@
  
  2009-01-23  Roland McGrath  <roland@redhat.com>
  
        * Makefile.am (i386_parse_CFLAGS): Use quotes around command
        substitution that can produce leading whitespace.
  
-@@ -338,6 +341,11 @@
+@@ -344,6 +347,11 @@
        * defs/i386.doc: New file.
        * defs/x86_64: New file.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = lex.$(<F:lex.l=)
-@@ -144,6 +145,7 @@ SHELL = @SHELL@
+@@ -145,6 +146,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -207,7 +209,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -208,7 +210,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libdw -I$(srcdir)/../libasm
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libdw/ChangeLog
 +++ b/libdw/ChangeLog
-@@ -82,6 +82,10 @@
+@@ -308,6 +308,10 @@
  
        * dwarf_hasattr_integrate.c: Integrate DW_AT_specification too.
  
  2009-08-10  Roland McGrath  <roland@redhat.com>
  
        * dwarf_getscopevar.c: Use dwarf_diename.
-@@ -850,6 +854,11 @@
+@@ -1076,6 +1080,11 @@
  
  2005-05-31  Roland McGrath  <roland@redhat.com>
  
  
 --- a/libdw/libdw.h
 +++ b/libdw/libdw.h
-@@ -814,7 +814,7 @@ extern Dwarf_OOM dwarf_new_oom_handler (
+@@ -852,7 +852,7 @@ extern Dwarf_OOM dwarf_new_oom_handler (
  
  
  /* Inline optimizations.  */
  dwarf_whatattr (Dwarf_Attribute *attr)
 --- a/libdw/Makefile.in
 +++ b/libdw/Makefile.in
-@@ -189,6 +189,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -192,6 +192,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
  INSTALL_SCRIPT = @INSTALL_SCRIPT@
  INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
  LDFLAGS = @LDFLAGS@
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -217,6 +218,7 @@ SHELL = @SHELL@
+@@ -221,6 +222,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = 1
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -279,7 +281,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -283,7 +285,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libelf
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libdwfl/ChangeLog
 +++ b/libdwfl/ChangeLog
-@@ -1207,6 +1207,11 @@
+@@ -1331,6 +1331,11 @@
  
  2005-07-21  Roland McGrath  <roland@redhat.com>
  
        * test2.c (main): Check sscanf result to quiet warning.
 --- a/libdwfl/Makefile.in
 +++ b/libdwfl/Makefile.in
-@@ -181,6 +181,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -182,6 +182,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
  INSTALL_SCRIPT = @INSTALL_SCRIPT@
  INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
  LDFLAGS = @LDFLAGS@
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -209,6 +210,7 @@ SHELL = @SHELL@
+@@ -211,6 +212,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = 1
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -272,7 +274,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -274,7 +276,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libdw
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libebl/ChangeLog
 +++ b/libebl/ChangeLog
-@@ -624,6 +624,11 @@
+@@ -628,6 +628,11 @@
        * Makefile.am (libebl_*_so_SOURCES): Set to $(*_SRCS) so dependency
        tracking works right.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -171,6 +172,7 @@ SHELL = @SHELL@
+@@ -172,6 +173,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = 1
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -234,7 +236,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -235,7 +237,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libasm
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  @MUDFLAP_FALSE@libmudflap = 
 --- a/libelf/ChangeLog
 +++ b/libelf/ChangeLog
-@@ -651,6 +651,11 @@
+@@ -666,6 +666,11 @@
  
        * elf.h: Update from glibc.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -217,6 +218,7 @@ SHELL = @SHELL@
+@@ -218,6 +219,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = 1
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -278,7 +280,7 @@ zip_LIBS = @zip_LIBS@
+@@ -279,7 +281,7 @@ zip_LIBS = @zip_LIBS@
  INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -103,6 +104,7 @@ SHELL = @SHELL@
+@@ -104,6 +105,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -183,6 +184,7 @@ SHELL = @SHELL@
+@@ -184,6 +185,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
 --- a/src/addr2line.c
 +++ b/src/addr2line.c
-@@ -447,10 +447,10 @@ handle_address (const char *string, Dwfl
+@@ -455,10 +455,10 @@ handle_address (const char *string, Dwfl
        bool parsed = false;
-       int n;
+       int i, j;
        char *name = NULL;
--      if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
-+      if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
-         && string[n] == '\0')
+-      if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &i) == 2
++      if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &i) == 2
+         && string[i] == '\0')
        parsed = adjust_to_section (name, &addr, dwfl);
--      else if (sscanf (string, "%m[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
-+      else if (sscanf (string, "%a[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
-              && string[n] == '\0')
+-      switch (sscanf (string, "%m[^-+]%n%" PRIiMAX "%n", &name, &i, &addr, &j))
++      switch (sscanf (string, "%a[^-+]%n%" PRIiMAX "%n", &name, &i, &addr, &j))
        {
-         /* It was symbol+offset.  */
+       default:
+         break;
 --- a/src/ChangeLog
 +++ b/src/ChangeLog
-@@ -98,8 +98,16 @@
+@@ -225,8 +225,16 @@
        * readelf.c (attr_callback): Use print_block only when we don't use
        print_ops.
  
        * ar.c (do_oper_extract): Use pathconf instead of statfs.
  
  2009-08-01  Ulrich Drepper  <drepper@redhat.com>
-@@ -263,6 +271,8 @@
+@@ -390,6 +398,8 @@
        * readelf.c (print_debug_frame_section): Use t instead of j formats
        for ptrdiff_t OFFSET.
  
  2009-01-21  Ulrich Drepper  <drepper@redhat.com>
  
        * elflint.c (check_program_header): Fix typo in .eh_frame_hdr section
-@@ -446,6 +456,11 @@
+@@ -573,6 +583,11 @@
        that matches its PT_LOAD's p_flags &~ PF_W.  On sparc, PF_X really
        is valid in RELRO.
  
  2008-02-29  Roland McGrath  <roland@redhat.com>
  
        * readelf.c (print_attributes): Add a cast.
-@@ -697,6 +712,8 @@
+@@ -824,6 +839,8 @@
  
        * readelf.c (hex_dump): Fix rounding error in whitespace calculation.
  
  2007-10-15  Roland McGrath  <roland@redhat.com>
  
        * make-debug-archive.in: New file.
-@@ -1136,6 +1153,10 @@
+@@ -1263,6 +1280,10 @@
        * elflint.c (valid_e_machine): Add EM_ALPHA.
        Reported by Christian Aichinger <Greek0@gmx.net>.
  
  2006-08-08  Ulrich Drepper  <drepper@redhat.com>
  
        * elflint.c (check_dynamic): Don't require DT_HASH for DT_SYMTAB.
-@@ -1212,6 +1233,10 @@
+@@ -1339,6 +1360,10 @@
        * Makefile.am: Add hacks to create dependency files for non-generic
        linker.
  
  2006-06-12  Ulrich Drepper  <drepper@redhat.com>
  
        * ldgeneric.c (ld_generic_generate_sections): Don't create .interp
-@@ -1560,6 +1585,11 @@
+@@ -1687,6 +1712,11 @@
        * readelf.c (print_debug_loc_section): Fix indentation for larger
        address size.
  
        * readelf.c (print_debug_line_section): Print section offset of each
 --- a/src/findtextrel.c
 +++ b/src/findtextrel.c
-@@ -490,7 +490,11 @@ ptrcompare (const void *p1, const void *
+@@ -504,7 +504,11 @@ ptrcompare (const void *p1, const void *
  
  
  static void
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -256,6 +257,7 @@ SHELL = @SHELL@
+@@ -257,6 +258,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -320,7 +322,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -321,7 +323,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libasm
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
        $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
        $(am__append_1)
  @MUDFLAP_FALSE@libmudflap = 
-@@ -367,6 +369,9 @@ strings_no_Wformat = yes
+@@ -368,6 +370,9 @@ strings_no_Wformat = yes
  addr2line_no_Wformat = yes
  # XXX While the file is not finished, don't warn about this
  ldgeneric_no_Wunused = yes
  size_LDADD = $(libelf) $(libeu) $(libmudflap)
 --- a/src/readelf.c
 +++ b/src/readelf.c
-@@ -7655,7 +7655,7 @@ dump_archive_index (Elf *elf, const char
+@@ -4274,10 +4274,11 @@ struct listptr
+ #define listptr_offset_size(p)        ((p)->dwarf64 ? 8 : 4)
+ #define listptr_address_size(p)       ((p)->addr64 ? 8 : 4)
++static const char *listptr_name;
+ static int
+-compare_listptr (const void *a, const void *b, void *arg)
++compare_listptr (const void *a, const void *b)
+ {
+-  const char *name = arg;
++  const char *const name = listptr_name;
+   struct listptr *p1 = (void *) a;
+   struct listptr *p2 = (void *) b;
+@@ -4357,8 +4358,11 @@ static void
+ sort_listptr (struct listptr_table *table, const char *name)
+ {
+   if (table->n > 0)
+-    qsort_r (table->table, table->n, sizeof table->table[0],
+-           &compare_listptr, (void *) name);
++    {
++      listptr_name = name;
++      qsort (table->table, table->n, sizeof table->table[0],
++           &compare_listptr);
++    }
+ }
+ static bool
+@@ -8098,7 +8102,7 @@ dump_archive_index (Elf *elf, const char
          if (unlikely (elf_rand (elf, as_off) == 0)
              || unlikely ((subelf = elf_begin (-1, ELF_C_READ_MMAP, elf))
                           == NULL))
          break;
        }
        if (errno != EINVAL && errno != ENOMEM)
-@@ -586,9 +595,11 @@ read_block (int fd, const char *fname, o
+@@ -584,9 +593,11 @@ read_block (int fd, const char *fname, o
        elfmap_off = from & ~(ps - 1);
        elfmap_base = elfmap = map_file (fd, elfmap_off, fdlen, &elfmap_size);
  
        {
          error (0, errno, gettext ("\
  cannot set access and modification date of '%s'"),
-@@ -1804,7 +1820,7 @@ handle_ar (int fd, Elf *elf, const char 
+@@ -1804,7 +1820,7 @@ handle_ar (int fd, Elf *elf, const char
  
    if (tvp != NULL)
      {
  cannot set access and modification date of '%s'"), fname);
 --- a/tests/ChangeLog
 +++ b/tests/ChangeLog
-@@ -150,6 +150,8 @@
+@@ -154,6 +154,8 @@
  
  2008-01-21  Roland McGrath  <roland@redhat.com>
  
        * testfile45.S.bz2: Add tests for cltq, cqto.
        * testfile45.expect.bz2: Adjust.
  
-@@ -858,6 +860,11 @@
+@@ -862,6 +864,11 @@
        * Makefile.am (TESTS): Add run-elflint-test.sh.
        (EXTRA_DIST): Add run-elflint-test.sh and testfile18.bz2.
  
  LEX = @LEX@
  LEXLIB = @LEXLIB@
  LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
-@@ -400,6 +401,7 @@ SHELL = @SHELL@
+@@ -401,6 +402,7 @@ SHELL = @SHELL@
  STRIP = @STRIP@
  USE_NLS = @USE_NLS@
  VERSION = @VERSION@
  XGETTEXT = @XGETTEXT@
  XGETTEXT_015 = @XGETTEXT_015@
  XGETTEXT_EXTRA_OPTIONS = @XGETTEXT_EXTRA_OPTIONS@
-@@ -461,7 +463,7 @@ zip_LIBS = @zip_LIBS@
+@@ -462,7 +464,7 @@ zip_LIBS = @zip_LIBS@
  INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. $(am__append_2)
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
        $($(*F)_no_Werror),,-Werror) $(if \
index f02b7e1da737cdc4ad2be5083a80b8af804ea7f4..2c7a02a7d38fb9f3d1306926a9b9f078f9f0b0f2 100644 (file)
@@ -11,7 +11,7 @@
  
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -248,7 +248,7 @@ pkginclude_HEADERS = version.h
+@@ -249,7 +249,7 @@ pkginclude_HEADERS = version.h
  
  # Add doc back when we have some real content.
  SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
index 189a5e0aeb00b25ca1a85f488f8ed5de029b2731..2f3aa1a0c5a6f074b74c5f9552284d42caf5b16d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/Makefile.in
 +++ b/src/Makefile.in
-@@ -321,7 +321,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
+@@ -322,7 +322,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
        -I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
        -I$(srcdir)/../libasm
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
@@ -11,7 +11,7 @@
        $(am__append_1)
 --- a/libelf/Makefile.in
 +++ b/libelf/Makefile.in
-@@ -279,7 +279,7 @@ top_srcdir = @top_srcdir@
+@@ -280,7 +280,7 @@ top_srcdir = @top_srcdir@
  zip_LIBS = @zip_LIBS@
  INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
  AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \