travelmate: update 0.9.0 4605/head
authorDirk Brenken <dev@brenken.org>
Wed, 19 Jul 2017 20:34:18 +0000 (22:34 +0200)
committerDirk Brenken <dev@brenken.org>
Wed, 19 Jul 2017 20:34:18 +0000 (22:34 +0200)
backend:
* handle errors due to misconfigured uplinks
* various bugfixes

luci frontend:
* add a powerful wireless station manager to edit and delete existing
  interfaces or scan for new uplinks

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/travelmate/Makefile
net/travelmate/files/README.md
net/travelmate/files/travelmate.sh

index 424ebbeaf277acb335a898f39778f1d3e5ed5e06..58855e5205eacc3037dccf2e457cc3ceb27a3ab0 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=travelmate
-PKG_VERSION:=0.8.2
+PKG_VERSION:=0.9.0
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index 5a21d4a44c0641fefba73234e55a09de333dbbfc..65e3a5de155382255f126a109d12425511e85a09 100644 (file)
@@ -8,7 +8,7 @@ To avoid these kind of deadlocks, travelmate set all station interfaces in an "a
 ## Main Features
 * STA interfaces operating in an "always off" mode, to make sure that the AP is always accessible
 * easy setup within normal OpenWrt/LEDE environment
-* strong LuCI-Support to simplify the interface setup
+* strong LuCI-Support with builtin interface wizard and wireless interface manager
 * fast uplink connections
 * manual / automatic mode support, the latter one checks the existing uplink connection regardless of ifdown event trigger actions every n seconds
 * support of devices with multiple radios
@@ -24,7 +24,7 @@ To avoid these kind of deadlocks, travelmate set all station interfaces in an "a
 * download the package [here](https://downloads.lede-project.org/snapshots/packages/x86_64/packages)
 * install 'travelmate' (_opkg install travelmate_)
 * configure your network:
-    * automatic: use the LuCI frontend with automatic STA interface setup, that's the recommended way
+    * recommended: use the LuCI frontend with automatic STA interface setup and connection manager
     * manual: see detailed configure steps below
     * at least you need one configured AP and one STA interface
 
@@ -123,7 +123,7 @@ config wifi-iface
 </code></pre>
 
 ## Support
-Please join the travelmate discussion in this [forum thread](https://forum.openwrt.org/viewtopic.php?id=67697) or contact me by [mail](mailto:dev@brenken.org)  
+Please join the travelmate discussion in this [forum thread](https://forum.lede-project.org/t/travelmate-support-thread/5155) or contact me by [mail](mailto:dev@brenken.org)  
 
 ## Removal
 * stop the travelmate daemon with _/etc/init.d/travelmate stop_
index c591020177a2ded4568fc0da6a60c9fef44ad3b0..d1343dcf00047e0dc0ba319fc532850b0b8224bd 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-trm_ver="0.8.2"
+trm_ver="0.9.0"
 trm_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
 trm_enabled=0
 trm_debug=0
@@ -223,11 +223,19 @@ f_main()
                                 f_log "info " "interface '${sta_iface}' on '${sta_radio}' connected to uplink '${sta_ssid}' (${trm_sysver})"
                                 f_jsnupdate "${sta_iface}" "${sta_radio}" "${sta_ssid}"
                                 return 0
+                            elif [ ${cnt} -eq ${trm_maxretry} ]
+                            then
+                                uci -q set wireless."${config}".disabled=1
+                                uci -q set wireless."${config}".ssid="${sta_ssid}_err"
+                                uci -q commit wireless
+                                f_check "dev"
+                                f_log "info " "interface 'can't connect to uplink '${sta_ssid}' (${cnt}/${trm_maxretry}), uplink disabled (${trm_sysver})"
                             else
                                 uci -q revert wireless
-                                f_log "info " "interface '${sta_iface}' on '${sta_radio}' can't connect to uplink '${sta_ssid}' (${trm_sysver})"
-                                f_jsnupdate "${sta_iface}" "${sta_radio}" "${sta_ssid}"
+                                f_check "dev"
+                                f_log "info " "can't connect to uplink '${sta_ssid}' (${cnt}/${trm_maxretry}) (${trm_sysver})"
                             fi
+                            f_jsnupdate "${sta_iface}" "${sta_radio}" "${sta_ssid}"
                         fi
                     done
                 fi