openvpn: add missing script-security
authorErik Conijn <egc112@msn.com>
Wed, 17 Jan 2024 12:31:37 +0000 (13:31 +0100)
committerRosen Penev <rosenp@gmail.com>
Tue, 30 Jan 2024 00:06:13 +0000 (16:06 -0800)
Maintainer: @mkrkn  @neheb

Compile tested: armv7, cortexA15, OpenWRT 23.05
Run tested: Linksys EA8500

Compile tested: armv8, cortexA53, OpenWRT main
Run tested: Dynalink DL-WRX36

Description:
Script-security is always 2 and cannot be changed from the openvpn config file due to a missing rule in openvpn.init.

This is discussed in issue #23014

This patch adds the missing rule in openvpn.init to parse script-security from the openvpn config file.

Signed-off-by: Erik Conijn <egc112@msn.com>
net/openvpn/Makefile
net/openvpn/files/openvpn.init

index af3b7a8be26640cfe08aa448658ce3287d0e26a6..e85b6e75b2209b050127921b09562eaf375a6120 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=openvpn
 
 PKG_VERSION:=2.6.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE_URL:=\
        https://build.openvpn.net/downloads/releases/ \
index 0aee6d418298cb4d0d99cd5abbc4d4895a1d45f0..89d25b59cc9416cdf73379388460270c9a3a3e3c 100644 (file)
@@ -201,6 +201,7 @@ start_uci_instance() {
 
        if [ ! -z "$config" ]; then
                append UCI_STARTED "$config" "$LIST_SEP"
+               [ -n "$script_security" ] || get_openvpn_option "$config" script_security script-security
                [ -n "$up" ] || get_openvpn_option "$config" up up
                [ -n "$down" ] || get_openvpn_option "$config" down down
                [ -n "$route_up" ] || get_openvpn_option "$config" route_up route-up