ath79: mikrotik: use OpenWrt loader for initram image
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Wed, 18 May 2022 23:18:20 +0000 (09:18 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 10 Sep 2022 23:30:11 +0000 (01:30 +0200)
Return to using the OpenWrt kernel loader to decompress and load kernel
initram image.

Continue to use the vmlinuz kernel for squashfs.

Mikrotik's bootloader RouterBOOT on some ath79 devices is
failing to boot the current initram, due to the size of the initram image.

On the ath79 wAP-ac:
a 5.7MiB initram image would fail to boot
After this change:
a 6.6MiB initram image successfully loads

This partially reverts commit e91344776b9ba7c864be88d915c9c0df0eb790dd.

An alternative of using RouterBOOT's capability of loading an initrd ELF
section was investigated, but the OpenWrt kernel loader allows larger image.

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
target/linux/ath79/image/common-mikrotik.mk

index 5f5fa7899a079737444263786a72f9794d9dcc5f..fb3dc7822667a8609c9ae0967e33831e7a5e7cad 100644 (file)
@@ -1,8 +1,10 @@
 define Device/mikrotik
        DEVICE_VENDOR := MikroTik
+       LOADER_TYPE := elf
        KERNEL_NAME := vmlinuz
        KERNEL := kernel-bin | append-dtb-elf
-       KERNEL_INITRAMFS := kernel-bin | append-dtb-elf
+       KERNEL_INITRAMFS_NAME := vmlinux-initramfs
+       KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel
 endef
 
 define Device/mikrotik_nor