Boost: Package Update 2570/head
authorcmf <carlosmf.pt@gmail.com>
Fri, 1 Apr 2016 16:39:57 +0000 (17:39 +0100)
committercmf <carlosmf.pt@gmail.com>
Fri, 1 Apr 2016 16:39:57 +0000 (17:39 +0100)
Boost.Context Fix:
 - The Boost.Coroutine2 lib requires Boost.Context to be compiled using the
   standard C++14. [1]

[1]: https://bugs.archlinux.org/task/48779

Signed-off-by: Carlos M. Ferreira <carlosmf.pt@gmail.com>
libs/boost/Makefile

index 51e7bf49d307844e9bdb005bb73584b311d845b1..c0e90d1e9e86c778aabc19cfc83aac9ee34a1338 100644 (file)
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=boost
 PKG_VERSION:=1_60_0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/boost
@@ -336,7 +336,7 @@ comma := ,
 define Build/Compile
        $(info Selected Boost API $(BOOST_ABI) for architecture $(ARCH) and cpu $(CPU_TYPE) $(CPU_SUBTYPE))
        ( cd $(PKG_BUILD_DIR) ; \
-               echo "using gcc : $(ARCH) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/src/user-config.jam ; \
+               echo "using gcc : $(ARCH) : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS) $(if $(CONFIG_boost-coroutine2),-std=c++14,)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/src/user-config.jam ; \
                $(if $(CONFIG_PACKAGE_boost-python3), \
                        echo "using python : 3.5 : $(STAGING_DIR_ROOT)/usr/bin/python3 : $(STAGING_DIR)/usr/include/python3.5/ ;" >> \
                                tools/build/src/user-config.jam; \