backports: rename .local-symbols to local-symbols
authorJohannes Berg <johannes.berg@intel.com>
Tue, 15 Nov 2016 09:07:31 +0000 (10:07 +0100)
committerJohannes Berg <johannes.berg@intel.com>
Tue, 15 Nov 2016 09:07:31 +0000 (10:07 +0100)
Remove the leading . in the file, which has tripped up people
a few times already because it's hidden, and not always copied.

Change-Id: I48729af712f01b56cf43c4982321b989e33259f3
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Makefile
backport/Makefile.real
devel/doc/kconfig-operation
devel/doc/makefile-operation
gentree.py

index 11678f67adcd5c5741d09162f9ba663331ef3a70..0fd4cdb2f322317b00b24591ca0a82031492a78b 100644 (file)
@@ -37,7 +37,7 @@ mrproper:
        @rm -f backport-include/backport/autoconf.h
 
 .DEFAULT:
-       @set -e ; test -f .local-symbols || (                                           \
+       @set -e ; test -f local-symbols || (                                            \
        echo "/--------------"                                                          ;\
        echo "| You shouldn't run make in the backports tree, but only in"              ;\
        echo "| the generated output. This here is only the skeleton code"              ;\
@@ -63,7 +63,7 @@ mrproper:
        @set -e ; if [ "$$(cat .kernel_config_md5 2>/dev/null)" != "$(CONFIG_MD5)" ]    ;\
        then                                                                            \
                echo -n "Generating local configuration database from kernel ..."       ;\
-               grep -v -f .local-symbols $(KERNEL_CONFIG) | grep = | (                 \
+               grep -v -f local-symbols $(KERNEL_CONFIG) | grep = | (                  \
                        while read l ; do                                               \
                                if [ "$${l:0:7}" != "CONFIG_" ] ; then                  \
                                        continue                                        ;\
index a0f491626f80714e897a64d4ebc517c9fc100e4b..c874d318916cb6b32323f99bb830012f1310c947 100644 (file)
@@ -60,7 +60,7 @@ defconfig-%::
 backport-include/backport/autoconf.h: .config Kconfig.versions Kconfig.kernel
        @$(MAKE) oldconfig
        @echo -n "Building backport-include/backport/autoconf.h ..."
-       @grep -f .local-symbols .config | (                             \
+       @grep -f local-symbols .config | (                              \
                echo "#ifndef COMPAT_AUTOCONF_INCLUDED"                 ;\
                echo "#define COMPAT_AUTOCONF_INCLUDED"                 ;\
                echo "/*"                                               ;\
index 35e198c6ebe30cd7fc5b91659c2e5a8f1cefffb5..fffcc91bfefd58c74332498f10fd44fb307570ca 100644 (file)
@@ -99,7 +99,7 @@ These are the problems and their solutions:
     To achieve this, all Kconfig files are walked during the backporting
     process, starting at the root "Kconfig", and any symbols defined in
     them collected. Later then, only those options are renamed. They are
-    also recorded for the build process in the output file .local-symbols.
+    also recorded for the build process in the output file local-symbols.
 
  2) Kconfig files may reference files that don't exist when they're copied
     but not all the drivers, e.g. drivers/net/wireless/Kconfig is copied
index 38cf4e73eb3c78b43695425ca56d01e1223c2d63..a3eecd6e6f7d2d4ab82a2e325de153f5d91e0d34 100644 (file)
@@ -25,7 +25,7 @@ the tools -- menuconfig, defconfig-*, ...
 When the configuration is complete and exists in .config, the autoconf
 header (backport-include/backport/autoconf.h) must be generated. This step is
 also done in the make system (by a small embedded shell script) and needs
-the .local-symbols so it only includes the symbols from the backport.
+the local-symbols so it only includes the symbols from the backport.
 
 After this exists, all that's left to do is source the .config file and
 export everything in there into the environment for calling the kernel's
index e97ead0790d6122329a065d24ce8bd8b9d4a612a..186a41477b18829db044d872fdb66ec968bbf523 100755 (executable)
@@ -953,7 +953,7 @@ def process(kerneldir, copy_list_file, git_revision=None,
 
     # write local symbol list -- needed during packaging build
     if not bpid.integrate:
-        f = open(os.path.join(bpid.target_dir, '.local-symbols'), 'w')
+        f = open(os.path.join(bpid.target_dir, 'local-symbols'), 'w')
         for sym in symbols:
             f.write('%s=\n' % sym)
         f.close()