luci-nginx: fix nginx dependency 1939/head
authorAnsuel Smith <ansuelsmth@gmail.com>
Fri, 6 Jul 2018 15:29:15 +0000 (17:29 +0200)
committerAnsuel Smith <ansuelsmth@gmail.com>
Fri, 6 Jul 2018 15:34:39 +0000 (17:34 +0200)
As nginx-ssl is now available, we fix luci-ssl-nginx package dep to use the right package. DRop luci-ssl-openssl-nginx as openssl is needed by nginx anyway.

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
collections/luci-ssl-nginx/Makefile
collections/luci-ssl-openssl-nginx/Makefile [deleted file]

index d7ff49a7a33c12deff99af3d68683cf947151a91..549c44af11d2680bd104442ad12823aa4ab6ca5b 100644 (file)
@@ -9,8 +9,14 @@ include $(TOPDIR)/rules.mk
 LUCI_TYPE:=col
 LUCI_BASENAME:=ssl
 
-LUCI_TITLE:=LuCI with HTTPS support (mbedTLS as SSL backend)
-LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-mbedtls +px5g
+LUCI_TITLE:=LuCI with HTTPS support on Nginx (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ OpenSSL cmd tools (openssl-util) are used by nginx for SSL key generation. \
+LUCI_DEPENDS:= \
+       +nginx-ssl +nginx-mod-luci-ssl +luci-mod-admin-full +luci-theme-bootstrap \
+       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +IPV6:luci-proto-ipv6 \
+       +rpcd-mod-rrdns +libustream-openssl +openssl-util
 
 PKG_LICENSE:=Apache-2.0
 
diff --git a/collections/luci-ssl-openssl-nginx/Makefile b/collections/luci-ssl-openssl-nginx/Makefile
deleted file mode 100644 (file)
index 5109647..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Copyright (C) 2016 The LuCI Team
-#
-# This is free software, licensed under the Apache License, Version 2.0 .
-#
-
-include $(TOPDIR)/rules.mk
-
-LUCI_TYPE:=col
-LUCI_BASENAME:=ssl-openssl
-
-LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
-LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
- OpenSSL cmd tools (openssl-util) are used by uhttpd for SSL key generation \
- instead of the default px5g. (If px5g is installed, uhttpd will prefer that.)
-
-LUCI_DEPENDS:=+luci-nginx +nginx-mod-luci-ssl +libustream-openssl +openssl-util
-
-include ../../luci.mk
-
-# call BuildPackage - OpenWrt buildroot signature