AA: uhttpd: fix build error with the new json-c (#13690)
authorFelix Fietkau <nbd@openwrt.org>
Wed, 12 Jun 2013 10:16:47 +0000 (10:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 12 Jun 2013 10:16:47 +0000 (10:16 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36924

package/uhttpd/patches/100-json_c.patch [new file with mode: 0644]

diff --git a/package/uhttpd/patches/100-json_c.patch b/package/uhttpd/patches/100-json_c.patch
new file mode 100644 (file)
index 0000000..06671fc
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,10 +62,11 @@ ELSE()
+       MESSAGE(FATAL_ERROR "Invalid TLS provider option, use none|openssl|cyassl")
+ ENDIF()
++FIND_LIBRARY(json json-c json)
+ IF(UBUS_SUPPORT)
+       ADD_DEFINITIONS(-DHAVE_UBUS)
+       ADD_LIBRARY(uhttpd_ubus MODULE uhttpd-ubus.c)
+-      TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus json blobmsg_json)
++      TARGET_LINK_LIBRARIES(uhttpd_ubus ubox ubus ${json} blobmsg_json)
+       SET(PLUGINS ${PLUGINS} uhttpd_ubus)
+ ENDIF()