treewide: Add PACKAGE_* conds to python packages 9039/head
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Mon, 20 May 2019 16:53:39 +0000 (13:53 -0300)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Mon, 20 May 2019 19:18:06 +0000 (16:18 -0300)
If a package builds python & python3 variants, then the respective
PACKAGE-python* conditional DEPENDS were added, since circular
dependencies should all be resolved now.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
lang/python/python-awscli/Makefile
lang/python/python-botocore/Makefile
lang/python/python-colorama/Makefile
lang/python/python-docutils/Makefile
lang/python/python-jmespath/Makefile
lang/python/python-ply/Makefile
lang/python/python-pyserial/Makefile
lang/python/python-requests/Makefile
lang/python/python-rsa/Makefile
lang/python/python-s3transfer/Makefile
lang/python/python-simplejson/Makefile

index d52faac56e83a5cff8d66a78e63200fae1a2d5e2..c290c6ac4700e938b1d3da9b88cd7659f28867b0 100644 (file)
@@ -28,27 +28,27 @@ endef
 
 define Package/python-awscli
 $(call Package/python-awscli/Default)
-  DEPENDS:=+python \
-       +python-yaml \
-       +python-pyasn1 \
-       +python-botocore \
-       +python-rsa \
-       +python-colorama \
-       +python-docutils \
-       +python-s3transfer
+  DEPENDS:=+PACKAGE_python-awscli:python \
+       +PACKAGE_python-awscli:python-yaml \
+       +PACKAGE_python-awscli:python-pyasn1 \
+       +PACKAGE_python-awscli:python-botocore \
+       +PACKAGE_python-awscli:python-rsa \
+       +PACKAGE_python-awscli:python-colorama \
+       +PACKAGE_python-awscli:python-docutils \
+       +PACKAGE_python-awscli:python-s3transfer
   VARIANT:=python
 endef
 
 define Package/python3-awscli
 $(call Package/python-awscli/Default)
-  DEPENDS:=+python3 \
-       +python3-yaml \
-       +python3-pyasn1 \
-       +python3-botocore \
-       +python3-rsa \
-       +python3-colorama \
-       +python3-docutils \
-       +python3-s3transfer
+  DEPENDS:=+PACKAGE_python3-awscli:python3 \
+       +PACKAGE_python3-awscli:python3-yaml \
+       +PACKAGE_python3-awscli:python3-pyasn1 \
+       +PACKAGE_python3-awscli:python3-botocore \
+       +PACKAGE_python3-awscli:python3-rsa \
+       +PACKAGE_python3-awscli:python3-colorama \
+       +PACKAGE_python3-awscli:python3-docutils \
+       +PACKAGE_python3-awscli:python3-s3transfer
   VARIANT:=python3
 endef
 
index 6ebc616cf2c09ec4ba8a2c09795f8a88e5b41c32..e02c6d61f59613aab4751fd6f8286e138cb2892c 100644 (file)
@@ -28,23 +28,23 @@ endef
 
 define Package/python-botocore
 $(call Package/python-botocore/Default)
-  DEPENDS:=+python \
-       +python-urllib3 \
-       +python-docutils \
-       +python-dateutil \
-       +python-jmespath \
-       +python-requests
+  DEPENDS:=+PACKAGE_python-botocore:python \
+       +PACKAGE_python-botocore:python-urllib3 \
+       +PACKAGE_python-botocore:python-docutils \
+       +PACKAGE_python-botocore:python-dateutil \
+       +PACKAGE_python-botocore:python-jmespath \
+       +PACKAGE_python-botocore:python-requests
   VARIANT:=python
 endef
 
 define Package/python3-botocore
 $(call Package/python-botocore/Default)
-  DEPENDS:=+python3 \
-       +python3-urllib3 \
-       +python3-docutils \
-       +python3-dateutil \
-       +python3-jmespath \
-       +python3-requests
+  DEPENDS:=+PACKAGE_python3-botocore:python3 \
+       +PACKAGE_python3-botocore:python3-urllib3 \
+       +PACKAGE_python3-botocore:python3-docutils \
+       +PACKAGE_python3-botocore:python3-dateutil \
+       +PACKAGE_python3-botocore:python3-jmespath \
+       +PACKAGE_python3-botocore:python3-requests
   VARIANT:=python3
 endef
 
index 815708cfbcad42e487cf301780e49e0ad5f84e1d..c5b8c67f54a1a0ba6b782e1fb4a4db071fbfa083 100644 (file)
@@ -28,13 +28,13 @@ endef
 
 define Package/python-colorama
 $(call Package/python-colorama/Default)
-  DEPENDS:=+python
+  DEPENDS:=+PACKAGE_python-colorama:python
   VARIANT:=python
 endef
 
 define Package/python3-colorama
 $(call Package/python-colorama/Default)
-  DEPENDS:=+python3
+  DEPENDS:=+PACKAGE_python3-colorama:python3
   VARIANT:=python3
 endef
 
index f7bbe3297a14ac2398c7f4b2e2f204dd998c747e..23500a57a7bfb2da6fc6ebfe63a1ba6f1c21c5cd 100644 (file)
@@ -28,13 +28,13 @@ endef
 
 define Package/python-docutils
 $(call Package/python-docutils/Default)
-  DEPENDS:=+python
+  DEPENDS:=+PACKAGE_python-docutils:python
   VARIANT:=python
 endef
 
 define Package/python3-docutils
 $(call Package/python-docutils/Default)
-  DEPENDS:=+python3
+  DEPENDS:=+PACKAGE_python3-docutils:python3
   VARIANT:=python3
 endef
 
index 0e4c3090f226999ea6cd0647ccae1dcf24b2a5b4..ce11ca7b2337824dbc6f60d921b80689f5f17deb 100644 (file)
@@ -28,13 +28,13 @@ endef
 
 define Package/python-jmespath
 $(call Package/python-jmespath/Default)
-  DEPENDS:=+python
+  DEPENDS:=+PACKAGE_python-jmespath:python
   VARIANT:=python
 endef
 
 define Package/python3-jmespath
 $(call Package/python-jmespath/Default)
-  DEPENDS:=+python3
+  DEPENDS:=+PACKAGE_python3-jmespath:python3
   VARIANT:=python3
 endef
 
index aacaf15d5d0aa8ab655b070d2a702aaf2a408012..a728e15c8bf73b6ec893c76ed47523a27e5160fc 100644 (file)
@@ -44,7 +44,7 @@ endef
 
 define Package/python3-ply
 $(call Package/python-ply/Default)
-  DEPENDS:=+python3-light
+  DEPENDS:=+PACKAGE_python3-ply:python3-light
   VARIANT:=python3
 endef
 
index 00b6410f91b0495a553b0d75257b84c79ef4c7e8..8a25c11539846bc124ece56545344b3200cd3ab3 100644 (file)
@@ -36,14 +36,14 @@ endef
 define Package/python-pyserial
 $(call Package/python-pyserial/Default)
   TITLE:=python-pyserial
-  DEPENDS:=+python-light
+  DEPENDS:=+PACKAGE_python-pyserial:python-light
   VARIANT:=python
 endef
 
 define Package/python3-pyserial
 $(call Package/python-pyserial/Default)
   TITLE:=python3-pyserial
-  DEPENDS:=+python3-light
+  DEPENDS:=+PACKAGE_python3-pyserial:python3-light
   VARIANT:=python3
 endef
 
index 3c823893ca9b3311d7bbf02ed4b9722ca9e29059..dd6df4fb1122388f89b3fede7eab79902a08a25d 100644 (file)
@@ -52,11 +52,11 @@ endef
 define Package/python3-requests
 $(call Package/python-requests/Default)
   DEPENDS:= \
-         +python3-light  \
-         +python3-chardet  \
-         +python3-idna  \
-         +python3-urllib3  \
-         +python3-certifi
+         +PACKAGE_python3-requests:python3-light  \
+         +PACKAGE_python3-requests:python3-chardet  \
+         +PACKAGE_python3-requests:python3-idna  \
+         +PACKAGE_python3-requests:python3-urllib3  \
+         +PACKAGE_python3-requests:python3-certifi
   VARIANT:=python3
 endef
 
index cb84dfd022c362835b46b5bd268461680986fb94..5bd94fc7bce855bfc11a970d8236ec78bc38c05d 100644 (file)
@@ -28,13 +28,13 @@ endef
 
 define Package/python-rsa
 $(call Package/python-rsa/Default)
-  DEPENDS:=+python +python-pyasn1
+  DEPENDS:=+PACKAGE_python-rsa:python +PACKAGE_python-rsa:python-pyasn1
   VARIANT:=python
 endef
 
 define Package/python3-rsa
 $(call Package/python-rsa/Default)
-  DEPENDS:=+python3 +python3-pyasn1
+  DEPENDS:=+PACKAGE_python3-rsa:python3 +PACKAGE_python3-rsa:python3-pyasn1
   VARIANT:=python3
 endef
 
index a50f1b41850df3d731cfb47c8bee8a0c6d6d8e8a..255b5b678f79e682dcc98cf5aa9ded68f39e5989 100644 (file)
@@ -28,13 +28,18 @@ endef
 
 define Package/python-s3transfer
 $(call Package/python-s3transfer/Default)
-  DEPENDS:=+python +python-botocore +python-futures
+  DEPENDS:= \
+       +PACKAGE_python-s3transfer:python \
+       +PACKAGE_python-s3transfer:python-botocore \
+       +PACKAGE_python-s3transfer:python-futures
   VARIANT:=python
 endef
 
 define Package/python3-s3transfer
 $(call Package/python-s3transfer/Default)
-  DEPENDS:=+python3 +python3-botocore
+  DEPENDS:= \
+       +PACKAGE_python3-s3transfer:python3 \
+       +PACKAGE_python3-s3transfer:python3-botocore
   VARIANT:=python3
 endef
 
index 11a66a117dd8c0ce12f76eae7e6dc71ffd5c3da4..3ba4a6764cf6fcfac9bbdfd0cd6536764e90be6b 100644 (file)
@@ -34,7 +34,7 @@ endef
 define Package/python-simplejson
 $(call Package/python-simplejson/Default)
   TITLE:=Simple, fast, extensible JSON encoder/decoder for Python 2
-  DEPENDS:=+python-light
+  DEPENDS:=+PACKAGE_python-simplejson:python-light
   VARIANT:=python
 endef