Merge pull request #3009 from dibdot/adblock
authorTed Hess <thess@kitschensync.net>
Sun, 31 Jul 2016 19:10:31 +0000 (15:10 -0400)
committerGitHub <noreply@github.com>
Sun, 31 Jul 2016 19:10:31 +0000 (15:10 -0400)
adblock: update 1.4.3

25 files changed:
lang/python-attrs/Makefile
lang/python-cffi/Makefile
libs/libtorrent/Makefile
libs/neon/Makefile
mail/mutt/Makefile
net/aircrack-ng/Makefile
net/aria2/Makefile
net/aria2/files/aria2.conf
net/aria2/files/aria2.init
net/chaosvpn/Makefile
net/freeradius2/Makefile
net/git/Makefile
net/mini_snmpd/Makefile
net/mini_snmpd/files/mini_snmpd.init
net/radsecproxy/Makefile
net/radsecproxy/files/radsecproxy.conf [new file with mode: 0644]
net/radsecproxy/files/radsecproxy.init
net/stunnel/Makefile
net/tcpreplay/Makefile [new file with mode: 0644]
net/tcpreplay/patches/001-disable-dbus-link.patch [new file with mode: 0644]
net/tinc/Makefile
net/tor/Makefile
net/transmission/Makefile
net/wget/Makefile
utils/coreutils/Makefile

index ec0fadf28f01320d6ce369f77da48cda211a21a7..e330183b0c94d6844b8602386610e2a2d2856e91 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=attrs
-PKG_VERSION:=15.2.0
+PKG_VERSION:=16.0.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/a/attrs
-PKG_MD5SUM:=b3c460eb6482f6e557c0e4025475c007
+PKG_SOURCE_URL:=https://pypi.python.org/packages/89/15/80d388d696c8c8ba14874635207aa698eb30ef1242dbb54d9eccf0e927ff
+PKG_MD5SUM:=5bcdd418f6e83e580434c63067c08a73
 
 PKG_BUILD_DEPENDS:=python python-setuptools
 
index a3269601681bdf7b2034804b589370153a0e9042..a6627a5e446ec74988dc0263395afcbc7f44a491 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cffi
-PKG_VERSION:=1.5.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.7.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/cffi
-PKG_MD5SUM:=fa766133f7299464c8bf857e0c966a82
+PKG_SOURCE_URL:=https://pypi.python.org/packages/83/3c/00b553fd05ae32f27b3637f705c413c4ce71290aa9b4c4764df694e906d9
+PKG_MD5SUM:=34122a545060cee58bab88feab57006d
 
 PKG_BUILD_DEPENDS:=python python-setuptools
 HOST_BUILD_DEPENDS:=libffi/host python/host python-setuptools/host python-pycparser/host
index eb059e0f7bd20fe62fc2c978eb12345b7acf7143..2a85684b6c0026ac2c9beb29d0688f1d27e56435 100644 (file)
@@ -28,7 +28,7 @@ define Package/libtorrent
   CATEGORY:=Libraries
   TITLE:=Rakshasa's BitTorrent library
   URL:=http://libtorrent.rakshasa.no/
-  DEPENDS:=+libopenssl +libsigcxx
+  DEPENDS:=+libopenssl +libsigcxx +zlib
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
 endef
 
index 4d3bf8cf55118f446440ecf8a7290cc195dd1021..325ee55ca51811f93fd6ef5c595df1c69bc4afa3 100644 (file)
@@ -24,7 +24,7 @@ define Package/libneon
   CATEGORY:=Libraries
   TITLE:=HTTP and WebDAV client library
   URL:=http://www.webdav.org/neon/
-  DEPENDS:=+libopenssl +libexpat
+  DEPENDS:=+libopenssl +libexpat +zlib
   MAINTAINER:=Federico Di Marco <fededim@gmail.com>
 endef
 
index ce1def85e71e0bb120ca2fcb6b8170a27cc59cea..02dcc4a6149100ba6a08206f6c2acd6d1e9a61df 100644 (file)
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/mutt
   SECTION:=mail
   CATEGORY:=Mail
-  DEPENDS:=+libopenssl +libncursesw
+  DEPENDS:=+libopenssl +libncursesw +zlib
   TITLE:=Console mail client
   URL:=http://www.mutt.org/
 endef
index 7f62ee7703524d5a16378a02e8a7f616a37b939d..866db9f03f9e699453311bf74a23d21c357bb7d4 100644 (file)
@@ -28,7 +28,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aircrack-ng
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap +libpthread +libopenssl +libnl-core +libnl-genl
+  DEPENDS:=+libpcap +libpthread +libopenssl +libnl-core +libnl-genl +zlib
   TITLE:=WLAN tools (without airmon-ng) for breaking 802.11 WEP/WPA keys
   URL:=http://www.aircrack-ng.org/
   SUBMENU:=wireless
index 1c70510c62dd0a6788830aeb1cf6f8435f0bac0a..b88e26c71f1b003cc4169d24d1205bdb2fd789af 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aria2
 PKG_VERSION:=1.25.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
index 22aca30cacdb4e68e79d93545d1620afe6708f79..e6d76171fc54f0e38fef2a6a7bb466091ccb52c7 100644 (file)
@@ -6,5 +6,5 @@ config aria2 'main'
        option enable_dht 'true'
        option follow_torrent 'true'
        option user 'root'
-       option dir '/mnt/sda1'
+       option dir '/mnt/sda1/aria2'
        option save_session_interval '30'
index ab5a0e6b034ef86c704027ad9902b54470390d46..d6bcda4ab7fc38a89f4645349ea1711821cb0336 100755 (executable)
@@ -37,6 +37,7 @@ start_instance() {
        section_enabled "$s" || return 1
 
        config_get config_dir "$s" 'config_dir' '/var/etc/aria2'
+       config_get dir "$s" 'dir'
        config_get user "$s" 'user'
 
        config_file="$config_dir/aria2.conf"
@@ -47,25 +48,35 @@ start_instance() {
        [ -d "$config_dir" ] || {
                mkdir -m 0755 -p "$config_dir"
                touch "$config_file"
-               [ -z "$user" ] || chown -R $user $config_dir
        }
 
-       touch "$session_file"
+       [ -d "$dir" ] || {
+               mkdir -m 0755 -p "$dir" # create download dir
+               touch "$dir"
+       }
+
+       touch "$session_file" # create session file
 
        echo -e "enable-rpc=true\nrpc-allow-origin-all=true\nrpc-listen-all=true\nquiet=true" > $config_file
        echo -e "continue=true\ninput-file=$session_file\nsave-session=$session_file" >> $config_file
 
        option_disabled "$s" 'enable_dht' || echo "dht-file-path=$dht_file" >> $config_file
        option_disabled "$s" 'enable_log' || {
-                touch "$log_file"
+               [ -f "$log_file" ] && echo > $log_file # if log file exist, clear it
                 echo -e "log=$log_file" >> $config_file
         }
 
+       # if user is set, change dir owner
+       [ -z "$user" ] || {
+               chown -R $user:$user $config_dir
+               chown -R $user:$user $dir
+       }
+
        append_params "$s" \
                file_allocation bt_enable_lpd enable_dht rpc_user rpc_passwd rpc_listen_port dir bt_tracker disk_cache \
                max_overall_download_limit max_overall_upload_limit max_download_limit max_upload_limit max_concurrent_downloads \
                max_connection_per_server min_split_size split save_session_interval follow_torrent listen_port bt_max_peers \
-               peer_id_prefix user_agent rpc_secret
+               peer_id_prefix user_agent rpc_secret log_level
        
        config_list_foreach "$s" extra_settings append_extrasettings
        
index e37b306cf09da0e7a03582d7b5f1ec854b90f2bd..f36c8d5f2c4bdbd143fd372df4493473ab6bdd53 100644 (file)
@@ -29,7 +29,7 @@ define Package/chaosvpn
                CATEGORY:=Network
                URL:=https://wiki.hamburg.ccc.de/index.php/ChaosVPN::DebianHowto
                SUBMENU:=VPN
-               DEPENDS:=+tinc +ip +kmod-tun +libopenssl
+               DEPENDS:=+tinc +ip +kmod-tun +libopenssl +zlib
 endef
 
 define Package/chaosvpn/description
index 2c87dbbfc8f865b4690320930bd2e2740baf490d..b55b9bf2f0d3cbfc144e23fea0e3cea2aaec7c03 100644 (file)
@@ -63,7 +63,7 @@ endef
 define Package/freeradius2-common
   $(call Package/freeradius2/Default)
   TITLE:=common files
-  DEPENDS:=+libpthread +FREERADIUS_OPENSSL:libopenssl
+  DEPENDS:=+libpthread +FREERADIUS_OPENSSL:libopenssl +zlib
 endef
 
 define Package/freeradius2-mod-chap
index 1b9d7729ee99e3b7c193e7895c409e6ba40c0cd1..8f76507bfbdfba33f58f9e2a682eba273db9c626 100644 (file)
@@ -25,7 +25,7 @@ define Package/git/Default
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Version Control Systems
-  DEPENDS:=+libopenssl +libpthread +librt
+  DEPENDS:=+libopenssl +libpthread +librt +zlib
   TITLE:=The fast version control system
   URL:=http://git-scm.com
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
index 9945b8fa013cda26c0513d2d35ea0f2ae636c205..f86539a0ceb5637180a7685776a8d4d1a310f778 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mini_snmpd
 PKG_VERSION:=1.4-rc1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Luke McKee <hojuruku@gmail.com>
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
index 442e350af3abb2e1c61c86103f97484114a6d35a..0fb63d4d8f222b5d4058316a4c7e41d7866969e0 100644 (file)
@@ -71,7 +71,7 @@ append_interface() {
        local name="$1" netdev netdev_count
        [ -z $netdev_count ] && netdev_count=0
        # for the purposes of snmp monitoring it doesn't need to be up, it just needs to exist in /proc/net/dev
-       netdev=$(ubus -S call network.interface dump|jsonfilter -e "@.interface[@.interface=\"$name\"].device")  
+       netdev=$(ubus -S call network.interface dump|jsonfilter -e "@.interface[@.interface=\"$name\"].l3_device")  
        if [ -n "$netdev" ] && grep -qF "$netdev" /proc/net/dev ]; then 
                [ $netdev_count -ge 4 ] && {
                        _err "$cfg: too many network interfaces configured, ignoring $name"
index 52b52e94f7912d3d3ffec13cb8d4c2497eadf648..6faf5e2175c0b37e68845861463450947942aba8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radsecproxy
 PKG_VERSION:=1.6.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
 PKG_MD5SUM:=d76cf4fc68515667b8c67387f5045150
 
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=LICENSE
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -43,14 +46,14 @@ TARGET_CFLAGS += -Wno-long-long
 define Package/radsecproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/
-       $(CP) $(PKG_BUILD_DIR)/radsecproxy.conf-example $(1)/etc/radsecproxy.conf
+       $(INSTALL_DIR) $(1)/etc/config/
+       $(INSTALL_DATA) ./files/radsecproxy.conf $(1)/etc/config/radsecproxy
        $(INSTALL_DIR) $(1)/etc/init.d/
        $(INSTALL_BIN) ./files/radsecproxy.init $(1)/etc/init.d/radsecproxy
 endef
 
 define Package/radsecproxy/conffiles
-/etc/radsecproxy.conf
+/etc/config/radsecproxy
 endef
 
 $(eval $(call BuildPackage,radsecproxy))
diff --git a/net/radsecproxy/files/radsecproxy.conf b/net/radsecproxy/files/radsecproxy.conf
new file mode 100644 (file)
index 0000000..33e7e27
--- /dev/null
@@ -0,0 +1,43 @@
+# Sample radsecproxy configuration
+
+#Basic options
+config options
+       option include '/etc/radsecproxy.conf'
+       #option LogLevel '3'
+       #option LogDestination 'x-syslog:///'
+       #list ListenUDP '127.0.0.1:1812'
+       #list ListenTLS '0.0.0.0:2083'
+       #list ListenTLS '[::]:2083'
+
+#config tls
+#      option name 'default'
+#      option CACertificatePath '/etc/ssl/certs'
+#      option certificateFile '/etc/ssl/certs/host.example.com.pem'
+#      option certificateKeyFile '/etc/ssl/private/host.example.com.key.pem'
+
+#config client
+#      option name 'localhost'
+#      option type 'udp'
+#      option secret 'mysecret'
+
+#config server
+#      option name '[2001:db8::1]'
+#      option type 'tls'
+#      option secret 'radsec'
+#      option statusServer '1'
+
+# Please note that ordering of realm blocks is important
+
+#config realm
+#      option name '/myabc\.com$'
+#      option replyMessage 'Misconfigured client: default realm of Intel PRO/Wireless supplicant!'
+#
+
+#config realm
+#      option name '/^$/'
+#      option replyMessage 'Misconfigured client: empty realm!'
+#
+
+#config realm
+#      option name '*'
+#      list server '[2001:db8::1]'
index 39bdc6e4badc2b2708551b3a6d3c84cff73d7131..7b22396ecf7d3d4703ea389c5faecc4e3d0a0b9e 100644 (file)
@@ -5,12 +5,138 @@ START=70
 
 USE_PROCD=1
 PROG=/usr/sbin/radsecproxy
-CONFFILE=/etc/radsecproxy.conf
+CONFFILE=/var/etc/radsecproxy.conf
+LIST_SEP="
+"
+append_params() {
+       local param
+       local value
+       local section="$1"
+       shift
+       for param in $*; do
+               config_get value "$section" "$param"
+               [ -z "$value" ] && {
+                       param=$(echo $param | tr [A-Z] [a-z])
+                       config_get value "$section" "$param"
+               }
+               IFS="$LIST_SEP"
+               for value in $value; do
+                       [ -n "$value" ] && echo "    $param '$value'" >> "$CONFFILE"
+               done
+               unset IFS
+       done
+}
+
+append_bools() {
+       local param
+       local value
+       local section="$1"
+       shift
+       for param in $*; do
+               config_get_bool value "$section" "$param"
+               [ -z "$value" ] && {
+                       param=$(echo $param | tr [A-Z] [a-z])
+                       config_get_bool value "$section" "$param"
+               }
+               [ -n "$value" ] && {
+                       [ "$value" -eq 0 ] && echo "    $param off" >> "$CONFFILE"
+                       [ "$value" -eq 1 ] && echo "    $param on" >> "$CONFFILE"
+               }
+       done
+}
+
+radsecproxy_options() {
+       local cfg="$1"
+       append_params "$cfg" \
+               Include PidFile LogLevel LogDestination FTicksReporting FTicksMAC FTicksKey \
+               FTicksSyslogFacility ListenUDP ListenTCP ListenTLS ListenDTLS SourceUDP \
+               SourceTCP SourceTLS SourceDTLS TTLAttribute AddTTL
+       append_bools "$cfg" \
+               LoopPrevention IPv4Only IPv6Only
+}
+
+tls_block() {
+       local cfg="$1"
+       local name
+       config_get name "$cfg" name
+       echo "tls '$name' {" >> "$CONFFILE"
+       append_params "$cfg" \
+               Include CACertificateFile CACertificatePath certificateFile certificateKeyFile \
+               certificateKeyPassword cacheExpiry policyOID
+       append_bools "$cfg" \
+               CRLCheck
+       echo "}" >> "$CONFFILE"
+}
+
+rewrite_block() {
+       local cfg="$1"
+       local name
+       config_get name "$cfg" name
+       echo "rewrite '$name' {" >> "$CONFFILE"
+       append_params "$cfg" \
+               Include addAttribute addVendorAttribute removeAttribute removeVendorAttribute \
+               modifyAttribute
+       echo "}" >> "$CONFFILE"
+}
+
+client_block() {
+       local cfg="$1"
+       local name
+       config_get name "$cfg" name
+       echo "client '$name' {" >> "$CONFFILE"
+       append_params "$cfg" \
+               Include host type secret tls matchCertificateAttribute duplicateInterval \
+               AddTTL fticksVISCOUNTRY fticksVISINST rewrite rewriteIn rewriteOut \
+               rewriteAttribute
+       append_bools "$cfg" \
+               IPv4Only IPv6Only certificateNameCheck
+       echo "}" >> "$CONFFILE"
+}
+
+server_block() {
+       local cfg="$1"
+       local name
+       config_get name "$cfg" name
+       echo "server '$name' {" >> "$CONFFILE"
+       append_params "$cfg" \
+               Include host port type secret tls matchCertificateAttribute \
+               AddTTL rewrite rewriteIn rewriteOut retryCount dynamicLookupCommand \
+               retryInterval
+       append_bools "$cfg" \
+               IPv4Only IPv6Only certificateNameCheck statusServer LoopPrevention
+       echo "}" >> "$CONFFILE"
+}
+
+realm_block() {
+       local cfg="$1"
+       local name
+       config_get name "$cfg" name
+       echo "realm '$name' {" >> "$CONFFILE"
+       append_params "$cfg" \
+               Include server accountingServer replyMessage
+       append_bools "$cfg" \
+               accountingResponse
+       echo "}" >> "$CONFFILE"
+}
 
 start_service() {
+       mkdir -p $(dirname $CONFFILE)
+       echo "# auto-generated config file from /etc/config/radsecproxy" > $CONFFILE
+       config_load 'radsecproxy'
+       config_foreach radsecproxy_options options
+       config_foreach tls_block tls
+       config_foreach rewrite_block rewrite
+       config_foreach client_block client
+       config_foreach server_block server
+       config_foreach realm_block realm
+
        procd_open_instance
        procd_set_param command $PROG -f -c $CONFFILE
        procd_set_param file $CONFFILE
        procd_set_param respawn
        procd_close_instance
 }
+
+service_triggers() {
+       procd_add_reload_trigger 'radsecproxy'
+}
index 58a6bbea6f66c71757c47dedfb85936c3e59bc58..671ee511b36b4d28a9a62c8b28338a61b9467448 100644 (file)
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/stunnel
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl
+  DEPENDS:=+libopenssl +zlib
   TITLE:=SSL TCP Wrapper
   URL:=http://www.stunnel.org/
 endef
diff --git a/net/tcpreplay/Makefile b/net/tcpreplay/Makefile
new file mode 100644 (file)
index 0000000..a0c9710
--- /dev/null
@@ -0,0 +1,151 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tcpreplay
+PKG_VERSION:=4.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/appneta/tcpreplay/releases/download/v$(PKG_VERSION)
+PKG_MD5SUM:=80394c33fe697b53b69eac9bb0968ae9
+
+PKG_LICENSE:=GPL-3.0
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+TCPREPLAY_MODULES:= \
+       tcpbridge tcpcapinfo tcpliveplay tcpprep \
+       tcpreplay tcpreplay-edit tcprewrite
+
+define Package/tcpreplay/default
+  SUBMENU:=tcprelay
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://tcpreplay.appneta.com/
+  MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
+  DEPENDS:=+librt +libpcap
+endef
+
+define Package/tcpbridge
+$(call Package/tcpreplay/default)
+  TITLE:=Bridge network traffic across two interfaces
+endef
+
+define Package/tcpcapinfo
+$(call Package/tcpreplay/default)
+  TITLE:=Pcap file dissector for debugging broken pcap files
+endef
+
+define Package/tcpliveplay
+$(call Package/tcpreplay/default)
+  TITLE:=Replays network traffic stored in a pcap file on live networks using new TCP connections
+endef
+
+define Package/tcpprep
+$(call Package/tcpreplay/default)
+  TITLE:=Create a tcpreplay cache file from a pcap file
+endef
+
+define Package/tcpreplay
+$(call Package/tcpreplay/default)
+  TITLE:=Replay network traffic stored in pcap files
+endef
+
+define Package/tcpreplay-edit
+$(call Package/tcpreplay/default)
+  TITLE:=Replay network traffic stored in pcap files
+endef
+
+define Package/tcprewrite
+$(call Package/tcpreplay/default)
+  TITLE:=Rewrite the packets in a pcap file
+endef
+
+define Package/tcpreplay-all
+$(call Package/tcpreplay/default)
+  TITLE:=Pcap editing and replaying utilities
+  DEPENDS:=$(foreach m,$(TCPREPLAY_MODULES),+$(m))
+endef
+
+define Package/tcpbridge/description
+  tcpbridge is a tool for selectively briding network traffic across two
+  interfaces and optionally modifying the packets in between
+endef
+
+define Package/tcpcapinfo/description
+  tcpcapinfo is a tool for decoding the structure of a pcap(3) file with a
+  focus on finding broken pcap files and determining how two related pcap
+  files might differ.
+endef
+
+define Package/tcpliveplay/description
+  This program, 'tcpliveplay' replays a captured set of packets using new TCP
+  connections with the captured TCP payloads against a remote host in order
+  to do comprehensive vulnerability testings.
+endef
+
+define Package/tcpprep/description
+  tcpprep is a ``pcap(3)'' file pre-processor which creates a cache file
+  which provides "rules" for ``tcprewrite(1)'' and ``tcpreplay(1)'' on how to
+  process and send packets.
+endef
+
+define Package/tcpreplay/description
+  tcpreplay is a tool for replaying network traffic from files saved with
+  tcpdump or other tools which write pcap(3) files.
+endef
+
+define Package/tcpreplay-edit/description
+  tcpreplay-edit includes all the functionality of both tcpreplay
+  and tcprewrite.
+endef
+
+define Package/tcprewrite/description
+  Rewrite/edit the packets in a pcap file
+endef
+
+define Package/tcpreplay-all/description
+  Tcpreplay is a suite of free Open Source utilities for
+  editing and replaying previously captured network traffic.
+  Originally designed to replay malicious traffic patterns to
+  Intrusion Detection/Prevention Systems, it has seen many evolutions
+  including capabilities to replay to web servers.
+
+  Version 4.0.0 introduces features and performance enhancements
+  to support switches, routers, and IP Flow/NetFlow appliances. 
+endef
+
+CONFIGURE_ARGS += \
+       --enable-force-pf \
+       --enable-dynamic-link \
+       --prefix="$(PKG_INSTALL_DIR)/usr" \
+       --exec-prefix="$(PKG_INSTALL_DIR)/usr" \
+       --with-libpcap="$(STAGING_DIR)/usr"
+
+define tcpreplayTemplate
+  define Package/$(1)/install
+    $(INSTALL_DIR) $$(1)/usr/bin ; \
+    $(CP) $$(PKG_INSTALL_DIR)/usr/bin/$(1) $$(1)/usr/bin
+  endef
+endef
+
+define Package/tcpreplay-all/install
+       :
+endef
+
+$(foreach m, $(TCPREPLAY_MODULES), \
+       $(eval $(call tcpreplayTemplate,$(m))) \
+       $(eval $(call BuildPackage,$(m))) \
+)
+
+$(eval $(call BuildPackage,tcpreplay-all))
+
diff --git a/net/tcpreplay/patches/001-disable-dbus-link.patch b/net/tcpreplay/patches/001-disable-dbus-link.patch
new file mode 100644 (file)
index 0000000..6f34e9f
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 6c61381..7f72871 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -773,7 +773,6 @@ if ! test $using_pcap_config = yes; then
+     AC_CHECK_LIB(nl, nl_cache_alloc, [nl_found=yes])
+     AC_CHECK_LIB(nl-genl-3, genl_connect, [nl_genl_3_found=yes])
+     AC_CHECK_LIB(nl-3, nl_cache_alloc, [nl_3_found=yes])
+-    AC_CHECK_LIB(dbus-1, dbus_malloc, [dbus_1_found=yes])
+     if test "$nl_found" = "yes"; then
+         LPCAPLIB="$LPCAPLIB -lnl"
+     fi
index 37636132667a1d1c25e8ef046b5e6ca5d6e82d77..738c25f63ae13b41093a63ff5403c6cc3ed7b9f3 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+liblzo +libopenssl +kmod-tun
+  DEPENDS:=+liblzo +libopenssl +kmod-tun +zlib
   TITLE:=VPN tunneling daemon
   URL:=http://www.tinc-vpn.org/
   MAINTAINER:=Saverio Proto <zioproto@gmail.com>
index d77c80fcff4d7907ad992bd28b490ca04c21948d..1c685d3ba41de990b1769c32ef4b447954b1e8f2 100644 (file)
@@ -40,7 +40,7 @@ endef
 define Package/tor
 $(call Package/tor/Default)
   TITLE:=An anonymous Internet communication system
-  DEPENDS:=+libevent2 +libopenssl +libpthread +librt
+  DEPENDS:=+libevent2 +libopenssl +libpthread +librt +zlib
 endef
 
 define Package/tor/description
index 9b2819e02ce52954ca2b78dd20fc9168d7f1a909..17b85b9412a3fdafa2c76fddf97a44c9239227d2 100644 (file)
@@ -34,7 +34,7 @@ endef
 
 define Package/transmission-daemon/Default
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libpthread +libevent2 +librt
+  DEPENDS:=+libcurl +libpthread +libevent2 +librt +zlib
   USERID:=transmission=224:transmission=224
 endef
 
@@ -48,13 +48,13 @@ endef
 define Package/transmission-daemon-polarssl
   $(call Package/transmission-daemon/Default)
   TITLE+= (with PolarSSL)
-  DEPENDS+=+libpolarssl +zlib
+  DEPENDS+=+libpolarssl
   VARIANT:=polarssl
 endef
 
 define Package/transmission-cli/Default
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libpthread +libevent2 +librt
+  DEPENDS:=+libcurl +libpthread +libevent2 +librt +zlib
 endef
 
 define Package/transmission-cli-openssl
@@ -67,13 +67,13 @@ endef
 define Package/transmission-cli-polarssl
   $(call Package/transmission-cli/Default)
   TITLE+= (with PolarSSL)
-  DEPENDS+=+libpolarssl +zlib
+  DEPENDS+=+libpolarssl
   VARIANT:=polarssl
 endef
 
 define Package/transmission-remote/Default
   $(call Package/transmission/template)
-  DEPENDS:=+libcurl +libpthread +libevent2 +librt
+  DEPENDS:=+libcurl +libpthread +libevent2 +librt +zlib
 endef
 
 define Package/transmission-remote-openssl
@@ -86,7 +86,7 @@ endef
 define Package/transmission-remote-polarssl
   $(call Package/transmission-remote/Default)
   TITLE+= (with PolarSSL)
-  DEPENDS+=+libpolarssl +zlib
+  DEPENDS+=+libpolarssl
   VARIANT:=polarssl
 endef
 
index 65a440f3ebde32dde85a653bd6001de815e39e0c..70db34e2e63f5e51ed91333737e20b32aeec4673 100644 (file)
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/wget/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcre
+  DEPENDS:=+libpcre +zlib
   SUBMENU:=File Transfer
   TITLE:=Non-interactive network downloader
   URL:=http://www.gnu.org/software/wget/index.html
@@ -55,7 +55,6 @@ endef
 define Package/wget-nossl
 $(call Package/wget/Default)
   TITLE+= (without SSL support)
-  DEPENDS+= +zlib
   VARIANT:=nossl
 endef
 
index ac4707dcece9d240ba0245126ffb2d9643418f38..73b1a85f7c4e67099222d4a367c0fc5c87771a1d 100644 (file)
@@ -57,9 +57,9 @@ define Package/coreutils
 endef
 
 define Package/coreutils/description
- Full versions of standard GNU utilities. Normally, you would not use this
- package, since the functionality in BusyBox is more than sufficient and
smaller.
+ Full versions of standard GNU utilities. If an equivalent Busybox applet is
+ available, you should consider compiling that instead as Busybox applets are
usually smaller, at the expense of reduced functionality.
 endef
 
 define GenPlugin
@@ -70,8 +70,7 @@ define GenPlugin
  endef
 
  define Package/$(1)/description
-  Full version of standard GNU $(2) utility. Normally, you would not use this
-  package, since the functionality in BusyBox is more than sufficient.
+  Full version of standard GNU $(2) utility.
  endef
 endef