borgbackup: Add missing build dependencies
authorJeffery To <jeffery.to@gmail.com>
Wed, 1 Mar 2023 06:09:43 +0000 (14:09 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 24 Apr 2023 08:18:14 +0000 (16:18 +0800)
setuptools-scm is a declared build dependency[1], and pkgconfig will
allow setup to find the required libraries, replacing the need to set
environment variables.

[1]: https://github.com/borgbackup/borg/blob/1.2.4/setup.py#L313

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/borgbackup/Makefile

index a8629deef13639dbc594e3c38e77292544b2fdce..95fd7eaffd474792e0d02953a9a46255b597b033 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=borgbackup
 PKG_VERSION:=1.2.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PYPI_NAME:=borgbackup
 PKG_HASH:=a4bd54e9469e81b7a30a6711423115abc818d9cd844ecb1ca0e6104bc5374da8
@@ -57,16 +57,7 @@ define Package/borgbackup/description
   The data deduplication technique used makes Borg suitable for daily backups since only changes are stored. The authenticated encryption technique makes it suitable for backups to not fully trusted targets.
 endef
 
-PKG_BUILD_DEPENDS:=python-cython/host
-
-# borg setup.py shall find these via pkg-config, but depends on python pkgconfig PyPi module
-# which quickly becomes a nightmare to build, since it build-depends on poetry which is not
-# available in the python package feed, and has a myriad of deps
-PYTHON3_PKG_SETUP_VARS:= \
-  BORG_OPENSSL_PREFIX="/usr/lib" \
-  BORG_LIBLZ4_PREFIX="/usr/lib" \
-  BORG_LIBZSTD_PREFIX="/usr/lib" \
-  BORG_LIBXXHASH_PREFIX="/usr/lib"
+PKG_BUILD_DEPENDS:=python-cython/host python-pkgconfig/host python-setuptools-scm/host
 
 $(eval $(call Py3Package,borgbackup))
 $(eval $(call BuildPackage,borgbackup))