atftp: fix picking the right argz.h header file on eglibc
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:56:35 +0000 (21:56 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Jun 2012 21:56:35 +0000 (21:56 +0000)
SVN-Revision: 32547

net/atftp/Makefile

index e56a5f646990b9204f08ceca2b129fa3230fa3f1..e15f410d6900eef94bd983f2c584fcf589281032 100644 (file)
@@ -39,7 +39,16 @@ define Package/atftpd
 endef
 
 CONFIGURE_ARGS += \
-       --disable-libwrap 
+       --disable-libwrap
+
+ifdef CONFIG_USE_EGLIBC
+  TARGET_CFLAGS += -DHAVE_ARGZ=1
+
+  define Build/Prepare
+       $(Build/Prepare/Default)
+       echo '#include_next <argz.h>' > $(PKG_BUILD_DIR)/argz.h
+  endef
+endif
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -Wall -D_REENTRANT" \