packages/xinetd: fix initscript (closes: #10342)
authorNicolas Thill <nico@openwrt.org>
Fri, 4 Nov 2011 12:28:17 +0000 (12:28 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 4 Nov 2011 12:28:17 +0000 (12:28 +0000)
Create a pid file by default when starting xinetd (resolves #10342).

Signed-off-by: Stefan Agner <stefan@agner.ch>
SVN-Revision: 28748

net/xinetd/Makefile
net/xinetd/files/xinetd.init

index 9c33cdd0fe892640e0f79952b2758575943d3843..176cfa58791d9ceaadf5ac83f68f591bb3a9e51b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.14
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xinetd.org/
index a1747f061911e6a5193e5392bab8da3a10b0c549..c11994bd475760c824daaf85717c497bb15f6c22 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 START=50
 
 DEFAULT=/etc/default/xinetd
@@ -9,7 +9,7 @@ PID_F=$RUN_D/xinetd.pid
 start() {
        [ -f $DEFAULT ] && . $DEFAULT
        [ -d $RUN_D ] || mkdir -p $RUN_D
-       xinetd $OPTIONS
+       xinetd -pidfile $PID_F $OPTIONS
 }
 
 stop() {