adblock: update 3.8.15 11210/head
authorDirk Brenken <dev@brenken.org>
Sun, 2 Feb 2020 06:49:37 +0000 (07:49 +0100)
committerDirk Brenken <dev@brenken.org>
Sun, 2 Feb 2020 14:12:41 +0000 (15:12 +0100)
* remove 'reg_cz' list (abandoned)
* add 'notracking' list (provided by @rcarmo)

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/adblock.conf
net/adblock/files/adblock.sh

index ec64901968e70174c3b15c8324698ac155c90428..3c55ff9e89248fb2bc288f03b931f91f2acd846f 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=3.8.14
+PKG_VERSION:=3.8.15
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index 478636ff21de23eee3f0001c042d135cae5992f8..084c1acbd3115ea163e194ab83bf1e9a47984d76 100644 (file)
@@ -61,6 +61,12 @@ config source 'malwarelist'
        option adb_src_desc 'focus on malware, daily updates, approx. 1.200 entries'
        option enabled '0'
 
+config source 'notracking'
+       option adb_src 'https://raw.githubusercontent.com/notracking/hosts-blocklists/master/dnscrypt-proxy/dnscrypt-proxy.blacklist.txt'
+       option adb_src_rset '/^([[:alnum:]_-]+\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower(\$1)}'
+       option adb_src_desc 'notrack domains, daily updates, approx. 60.000 entries'
+       option enabled '0'
+
 config source 'openphish'
        option adb_src 'https://openphish.com/feed.txt'
        option adb_src_rset 'BEGIN{FS=\"/\"}/^http[s]?:\/\/([[:alnum:]_-]+\.)+[[:alpha:]]+(\/|$)/{print tolower(\$3)}'
@@ -73,12 +79,6 @@ config source 'reg_cn'
        option adb_src_desc 'focus on chinese ads plus generic easylist additions, daily updates, approx. 11.700 entries'
        option enabled '0'
 
-config source 'reg_cz'
-       option adb_src 'https://raw.githubusercontent.com/qxstyles/turris-hole-czech-block-list/master/turris-hole-czech-block-list'
-       option adb_src_rset '/^([[:alnum:]_-]+\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower(\$1)}'
-       option adb_src_desc 'focus on czech ads maintained by Turris Omnia Users, infrequent updates, approx. 100 entries'
-       option enabled '0'
-
 config source 'reg_de'
        option adb_src 'https://easylist-downloads.adblockplus.org/easylistgermany+easylist.txt'
        option adb_src_rset 'BEGIN{FS=\"[|^]\"}/^\|\|([[:alnum:]_-]+\.)+[[:alpha:]]+\^("\\\$third-party")?$/{print tolower(\$3)}'
index 5da153a9c75dc173e553ffab9de9b291089c9dee..bd53a248c69ec3572ada9fb424dc8ddee1cff5e1 100755 (executable)
@@ -13,7 +13,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="3.8.14"
+adb_ver="3.8.15"
 adb_basever=""
 adb_enabled=0
 adb_debug=0