mwan3: support offload routing modifier 19520/head
authorDenys Yarkovyi <dyarkovoy@gmail.com>
Tue, 4 Oct 2022 07:27:16 +0000 (00:27 -0700)
committerDenys Yarkovyi <dyarkovoy@gmail.com>
Wed, 5 Oct 2022 12:20:05 +0000 (05:20 -0700)
Signed-off-by: Denys Yarkovyi <dyarkovoy@gmail.com>
net/mwan3/Makefile
net/mwan3/files/lib/mwan3/common.sh

index ffffc7fa4460df4f732eb6a1cf40e9594736eab7..4e5c6e48dc46be0b3c1ff2afac88a5a075b6c831 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mwan3
-PKG_VERSION:=2.11.1
+PKG_VERSION:=2.11.2
 PKG_RELEASE:=3
 PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>, \
                Aaron Goodman <aaronjg@alumni.stanford.edu>
index fb951d5a6d6f9b862b32d5cc2d1b44d801a6b621..29ace60506f934e41a538eba211ce16a0129f780 100644 (file)
@@ -140,7 +140,7 @@ mwan3_init()
        # remove "linkdown", expiry and source based routing modifiers from route lines
        config_get_bool source_routing globals source_routing 0
        [ $source_routing -eq 1 ] && unset source_routing
-       MWAN3_ROUTE_LINE_EXP="s/linkdown //; s/expires [0-9]\+sec//; s/error [0-9]\+//; ${source_routing:+s/default\(.*\) from [^ ]*/default\1/;} p"
+       MWAN3_ROUTE_LINE_EXP="s/offload//; s/linkdown //; s/expires [0-9]\+sec//; s/error [0-9]\+//; ${source_routing:+s/default\(.*\) from [^ ]*/default\1/;} p"
 
        # mark mask constants
        bitcnt=$(mwan3_count_one_bits MMX_MASK)