syncthing: fix duplicate command line parameters on service 22767/head
authorEric Fahlgren <ericfahlgren@gmail.com>
Mon, 27 Nov 2023 14:47:33 +0000 (06:47 -0800)
committerEric Fahlgren <ericfahlgren@gmail.com>
Mon, 4 Dec 2023 16:25:20 +0000 (08:25 -0800)
  - This patch fixes 9d17ba1 and #22760

Signed-off-by: Eric Fahlgren <ericfahlgren@gmail.com>
utils/syncthing/Makefile
utils/syncthing/files/syncthing.init

index e8b744a463227240a43e6f601ee1b643c2287186..71d7880c482d77fe4e02f771f14e64746fb03f66 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=syncthing
 PKG_VERSION:=1.24.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=syncthing-source-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/syncthing/syncthing/releases/download/v$(PKG_VERSION)
index 3ec81e593658600c50e6c35c4cc4734883607af3..7bcb90daea5e69e95525d3e2fd24782e400f6c62 100644 (file)
@@ -14,7 +14,7 @@ config_cb() {
                local option="$1"
                local value="$2"
                case $option in
-               enabled|macprocs|nice|user|logfile)
+               enabled|gui_address|home|logfile|macprocs|nice|user)
                        eval $option=$value
                        ;;
                debug)