mtr: update to 0.80
authorStephen Walker <stephendwalker@gmail.com>
Sun, 18 Jul 2010 17:13:32 +0000 (17:13 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 18 Jul 2010 17:13:32 +0000 (17:13 +0000)
SVN-Revision: 22280

net/mtr/Makefile
net/mtr/patches/501-dns.patch
net/mtr/patches/502-fix-res_ninit.patch

index c444a039d4cefe2977473c7abab944ae6e1cedcf..41fb068e8652cb7aaa62999e0345a68fc8214219 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.79
+PKG_VERSION:=0.80
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=f7c1f873e68e7176f60ae9fbb2ca20f4
+PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr
+PKG_MD5SUM:=fa68528eaec1757f52bacf9fea8c68a9
 
 PKG_INSTALL:=1
 
@@ -38,6 +38,12 @@ define Package/mtr/description
        running statistics about each machine.
 endef
 
+CONFIGURE_ARGS += \
+       --without-gtk \
+
+CONFIGURE_VARS += \
+       ac_cv_lib_resolv_res_mkquery=yes \
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -48,11 +54,7 @@ define Build/Configure
                config.h.in \
                configure \
        );
-       $(call Build/Configure/Default, \
-               --without-gtk \
-               , \
-               ac_cv_lib_resolv_res_mkquery=yes \
-       )
+       $(call Build/Configure/Default)
 endef
 
 define Package/mtr/install
index dd6adea400f9db63afad19e007c9f68797e3a8cf..0976cb36adb574d181e38d05b3fb7a6103fcb6eb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/dns.c
 +++ b/dns.c
-@@ -869,6 +869,507 @@ void restell(char *s)
+@@ -880,6 +880,507 @@ void restell(char *s)
    fputs("\r",stderr);
  }
  
index 16e0d70489faaf60df97be2b787d70e973d509c1..8965751204aa29544bd1430a58fb6fabcad9f10c 100644 (file)
@@ -5,18 +5,18 @@
  int use_dns = 1;
  
 -#ifdef res_ninit
--#define RES_INIT() res_ninit(&myres);
+-#define MY_RES_INIT() res_ninit(&myres);
 -#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
 -    res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
 -struct __res_state myres;
 -#else
 +//#ifdef res_ninit
-+//#define RES_INIT() res_ninit(&myres);
++//#define MY_RES_INIT() res_ninit(&myres);
 +//#define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
 +//    res_nmkquery(&myres, a, b, c, d, e, f, g, h, i)
 +//struct __res_state myres;
 +//#else
- #define RES_INIT() res_init();
+ #define MY_RES_INIT() res_init();
  #define RES_MKQUERY(a, b, c, d, e, f, g, h, i) \
      res_mkquery(a, b, c, d, e, f, g, h, i)
  #define myres _res