move hotplug script into an extra package so that it doesn't conflict with nas
authorFelix Fietkau <nbd@openwrt.org>
Sat, 27 Aug 2005 15:40:56 +0000 (15:40 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 27 Aug 2005 15:40:56 +0000 (15:40 +0000)
SVN-Revision: 1772

openwrt/package/base-files/Makefile
openwrt/package/base-files/default/sbin/hotplug [deleted file]
openwrt/package/base-files/files/hotplug [new file with mode: 0755]
openwrt/package/base-files/ipkg/hotplug.control [new file with mode: 0644]

index af60bafacec641f22136b026eb870048d5281ddb..9cca04a7383775004de946dea7a57382cd24efb2 100644 (file)
@@ -11,6 +11,9 @@ include $(TOPDIR)/package/rules.mk
 IDIR_BASE:=$(PKG_BUILD_DIR)/base-files
 IPKG_BASE:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_RELEASE)_$(ARCH).ipk
 
+IDIR_HOTPLUG:=$(PKG_BUILD_DIR)/hotplug
+IPKG_HOTPLUG:=$(PACKAGE_DIR)/hotplug_$(PKG_RELEASE)_$(ARCH).ipk
+
 LIBC_VERSION:=${shell cat $(STAGING_DIR)/uclibc_version}
 IDIR_LIBC:=$(PKG_BUILD_DIR)/uclibc
 IPKG_LIBC:=$(PACKAGE_DIR)/uclibc_$(LIBC_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
@@ -19,7 +22,7 @@ GCC_VERSION:=${shell cat $(STAGING_DIR)/gcc_version}
 IDIR_GCC:=$(PKG_BUILD_DIR)/libgcc
 IPKG_GCC:=$(PACKAGE_DIR)/libgcc_$(GCC_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
 
-PACKAGES:=$(IPKG_BASE) $(IPKG_LIBC) $(IPKG_GCC)
+PACKAGES:=$(IPKG_BASE) $(IPKG_LIBC) $(IPKG_GCC) $(IPKG_HOTPLUG)
 
 $(PKG_BUILD_DIR)/.prepared:
        mkdir -p $(PKG_BUILD_DIR) $(PACKAGE_DIR)
@@ -43,6 +46,7 @@ $(IPKG_BASE):
        ln -sf /tmp $(IDIR_BASE)/var
        -find $(IDIR_BASE) -type d -name CVS | xargs rm -rf
        -find $(IDIR_BASE) -type d -name .svn | xargs rm -rf
+       -find $(IDIR_BASE) -name '.#*' | xargs rm -f
        mkdir -p $(IDIR_BASE)/etc
        -grep \^BR2_SYSCONF $(TOPDIR)/.config > $(IDIR_BASE)/etc/sysconf
        $(IPKG_BUILD) $(IDIR_BASE) $(PACKAGE_DIR)
@@ -64,6 +68,12 @@ $(IPKG_GCC):
        -$(STRIP) $(IDIR_GCC)/lib/*
        $(IPKG_BUILD) $(IDIR_GCC) $(PACKAGE_DIR)
 
+$(IPKG_HOTPLUG):
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_HOTPLUG) ipkg/hotplug.control $(PKG_RELEASE) $(ARCH)
+       mkdir -p $(IDIR_HOTPLUG)/sbin
+       install -m0755 files/hotplug $(IDIR_HOTPLUG)/sbin
+       $(IPKG_BUILD) $(IDIR_HOTPLUG) $(PACKAGE_DIR)
+       
 package-clean:
        rm -f $(PACKAGES)
 clean: package-clean
diff --git a/openwrt/package/base-files/default/sbin/hotplug b/openwrt/package/base-files/default/sbin/hotplug
deleted file mode 100755 (executable)
index 74134e8..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/ash
-# $Id$
-[ "${INTERFACE%%[0-9]*}" = "wds" ] && { 
-       ifconfig $INTERFACE 0.0.0.0 up
-       /usr/sbin/brctl addif br0 $INTERFACE
-}
diff --git a/openwrt/package/base-files/files/hotplug b/openwrt/package/base-files/files/hotplug
new file mode 100755 (executable)
index 0000000..74134e8
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/ash
+# $Id$
+[ "${INTERFACE%%[0-9]*}" = "wds" ] && { 
+       ifconfig $INTERFACE 0.0.0.0 up
+       /usr/sbin/brctl addif br0 $INTERFACE
+}
diff --git a/openwrt/package/base-files/ipkg/hotplug.control b/openwrt/package/base-files/ipkg/hotplug.control
new file mode 100644 (file)
index 0000000..8d6f785
--- /dev/null
@@ -0,0 +1,6 @@
+Package: hotplug
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Hotplug script for WDS