yggdrasil: bump to 0.3.15 13510/head
authorGeorge Iv <zhoreeq@users.noreply.github.com>
Mon, 28 Sep 2020 10:04:14 +0000 (06:04 -0400)
committerGeorge Iv <zhoreeq@users.noreply.github.com>
Mon, 28 Sep 2020 10:04:14 +0000 (06:04 -0400)
Signed-off-by: George Iv <zhoreeq@users.noreply.github.com>
net/yggdrasil/Makefile
net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch [deleted file]

index 8fbf7a845db0d18b6c598b90e5af57f95425036d..14f16e41819f6789c6b083e85b0059e35b6460c8 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=yggdrasil
-PKG_VERSION:=0.3.14
-PKG_RELEASE:=2
+PKG_VERSION:=0.3.15
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=e8579a04bf289434e7b8caaf621e2c0b853e83cc06f136c4f9e4bfc667df5a27
+PKG_HASH:=25ea85399a142aa7a3d6f6886fd4e0d215116c4c8c33453de43999787d735565
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-go-$(PKG_VERSION)
 
 PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
diff --git a/net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch b/net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch
deleted file mode 100644 (file)
index 682e485..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/src/yggdrasil/tcp.go b/src/yggdrasil/tcp.go
-index 9cca419..45f93a5 100644
---- a/src/yggdrasil/tcp.go
-+++ b/src/yggdrasil/tcp.go
-@@ -25,6 +25,7 @@ import (
-       "golang.org/x/net/proxy"
-+      "github.com/yggdrasil-network/yggdrasil-go/src/address"
-       "github.com/yggdrasil-network/yggdrasil-go/src/util"
- )
-@@ -386,6 +387,19 @@ func (t *tcp) handler(sock net.Conn, incoming bool, options interface{}, upgrade
-               local, _, _ = net.SplitHostPort(sock.LocalAddr().String())
-               remote, _, _ = net.SplitHostPort(sock.RemoteAddr().String())
-       }
-+      localIP := net.ParseIP(local)
-+      if localIP = localIP.To16(); localIP != nil {
-+              var laddr address.Address
-+              var lsubnet address.Subnet
-+              copy(laddr[:], localIP)
-+              copy(lsubnet[:], localIP)
-+              if laddr.IsValid() || lsubnet.IsValid() {
-+                      // The local address is with the network address/prefix range
-+                      // This would route ygg over ygg, which we don't want
-+                      t.link.core.log.Debugln("Dropping ygg-tunneled connection", local, remote)
-+                      return
-+              }
-+      }
-       force := net.ParseIP(strings.Split(remote, "%")[0]).IsLinkLocalUnicast()
-       link, err := t.link.core.link.create(&stream, name, proto, local, remote, incoming, force)
-       if err != nil {
-