[packages] php5: Don't fail on non-existing file removal
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 25 Jan 2012 13:09:37 +0000 (13:09 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 25 Jan 2012 13:09:37 +0000 (13:09 +0000)
SVN-Revision: 29907

lang/php5/Makefile

index dde151d35e5a41eff920d9bb4d58cbe74b9e2715..dee858bc866942eb24022bd533027a5fad232343 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=5.3.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.php.net/distributions/
@@ -479,7 +479,7 @@ endef
 
 define Build/InstallDev
        make -C $(PKG_BUILD_DIR) install INSTALL_ROOT=$(PKG_BUILD_DIR)/staging
-       rm $(PKG_BUILD_DIR)/staging/usr/bin/php
+       rm -f $(PKG_BUILD_DIR)/staging/usr/bin/php
        $(CP) $(PKG_BUILD_DIR)/staging/* $(STAGING_DIR_HOST)
        sed -i -e "s#prefix='/usr'#prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize
        sed -i -e "s#exec_prefix=\"\`eval echo /usr\`\"#exec_prefix='$(STAGING_DIR_HOST)/usr'#" $(STAGING_DIR_HOST)/usr/bin/phpize