Merge pull request #743 from HenryGiraldo/master
authorJo-Philipp Wich <jo@mein.io>
Fri, 8 Jul 2016 13:18:21 +0000 (15:18 +0200)
committerGitHub <noreply@github.com>
Fri, 8 Jul 2016 13:18:21 +0000 (15:18 +0200)
Closes #741: Can't delete disabled wireless networks

applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua
applications/luci-app-ddns/po/de/ddns.po
applications/luci-app-ddns/po/pt-br/ddns.po
applications/luci-app-openvpn/luasrc/model/cbi/openvpn-advanced.lua
applications/luci-app-openvpn/luasrc/model/cbi/openvpn-basic.lua
applications/luci-app-openvpn/luasrc/model/cbi/openvpn.lua
contrib/package/community-profiles/files/etc/config/profile_tulumlibre [new file with mode: 0644]
modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/system.lua
protocols/luci-proto-vpnc/luasrc/model/cbi/admin_network/proto_vpnc.lua

index 7a09af07f9046135cae2d7b150d99f743ccdf8d2..c1a22c849e3214df93917268f5280f31c2afdaa1 100644 (file)
@@ -10,11 +10,11 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.4.5
+PKG_VERSION:=2.4.6
 
 # Release == build
 # increase on changes of translation files
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
index d6ccf9cd45f54f602d5b538f9b6da596d0426b53..1f2e6f2b9356b8c2a74782eda13907ac9e91d703 100755 (executable)
@@ -18,11 +18,11 @@ local UTIL = require "luci.util"
 local DDNS = require "luci.tools.ddns"         -- ddns multiused functions
 
 local srv_name    = "ddns-scripts"
-local srv_ver_min = "2.7.1"                    -- minimum version of service required
+local srv_ver_min = "2.7.2"                    -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.4.4-1"
+local app_version = "2.4.6-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
@@ -193,8 +193,8 @@ local function _get_status()
                local is_glue = tonumber(s["is_glue"] or 0)
                local command = [[/usr/lib/ddns/dynamic_dns_lucihelper.sh]]
                command = command .. [[ get_registered_ip ]] .. lookup_host .. [[ ]] .. use_ipv6 ..
-                       [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp .. [[ ]] .. dnsserver ..
-                       [[ ]] .. is_glue
+                       [[ ]] .. force_ipversion .. [[ ]] .. force_dnstcp ..
+                       [[ ]] .. is_glue .. [[ ]] .. dnsserver
                local reg_ip = SYS.exec(command)
                if reg_ip == "" then
                        reg_ip = "_nodata_"
index 2399380ece5c2abe217f77a568dd769c60ea6f54..517fe3634757011c6c4fa30d6fe8d119143cbfb8 100644 (file)
@@ -439,7 +439,7 @@ msgstr ""
 "Aktualisierungen über HTTPS Protokoll zu unterstützen."
 
 msgid "Network"
-msgstr ""
+msgstr "Netzwerk"
 
 msgid "Network on which the ddns-updater scripts will be started"
 msgstr "Netzwerk auf dem Ereignisse die ddns-updater Skripte starten"
index 5e37465516fc2104493452bdf4a280483c2e0ba5..218193ba55766c8b5416e85e076ab108077a4aad 100644 (file)
@@ -2,180 +2,205 @@ msgid ""
 msgstr ""
 "Project-Id-Version: luci-app-ddns 2.4.0-1\n"
 "POT-Creation-Date: 2016-01-30 11:07+0100\n"
-"PO-Revision-Date: 2012-11-03 07:02+0200\n"
-"Last-Translator: Luiz Angelo <luizluca@gmail.com>\n"
+"PO-Revision-Date: 2016-07-01 22:40-0300\n"
+"Last-Translator: Matheus Dal Mago <matheusdalmago10@gmail.com>\n"
 "Language-Team: \n"
 "Language: pt_BR\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
 "Plural-Forms: nplurals=2; plural=(n > 1);\n"
-"X-Generator: Poedit 1.8.4\n"
+"X-Generator: Poedit 1.8.8\n"
 
 msgid "&"
-msgstr ""
+msgstr "&"
 
 msgid "-- custom --"
-msgstr ""
+msgstr "-- personalizado --"
 
 msgid "-- default --"
-msgstr ""
+msgstr "-- padrão --"
 
 msgid "Advanced Settings"
-msgstr ""
+msgstr "Configurações Avançadas"
 
 msgid "Allow non-public IP's"
-msgstr ""
+msgstr "Permitir IPs não-públicos"
 
 msgid "Applying changes"
-msgstr ""
+msgstr "Aplicar mudanças"
 
 msgid "Basic Settings"
-msgstr ""
+msgstr "Configurações Básicas"
 
 msgid ""
 "Below a list of configuration tips for your system to run Dynamic DNS "
 "updates without limitations"
 msgstr ""
+"Abaixo uma lista de dicas de configurações para seu sistema para rodar "
+"atualizações de DNS Dinâmico sem limitações"
 
 msgid ""
 "Below is a list of configured DDNS configurations and their current state."
 msgstr ""
+"Abaixo uma lista de configurações DDNS configuradas e seus estados atuais"
 
 msgid "Bind Network"
-msgstr ""
+msgstr "Limitar Rede"
 
 msgid "Binding to a specific network not supported"
-msgstr ""
+msgstr "Não suportado limitar a uma rede específica"
 
 msgid ""
 "BusyBox's nslookup and Wget do not support to specify the IP version to use "
 "for communication with DDNS Provider!"
 msgstr ""
+"nslookup e Wget do BusyBox não suportam que especifique a versão de IP a ser "
+"usada para comunicação com o provedor DDNS!"
 
 msgid ""
 "BusyBox's nslookup and hostip do not support to specify to use TCP instead "
 "of default UDP when requesting DNS server!"
 msgstr ""
+"nslookup e hostip do BusyBox não suportam que especifique para usar TCP em "
+"vez do padrão UDP quando requisitando servidor DNS!"
 
 msgid ""
 "BusyBox's nslookup in the current compiled version does not handle given DNS "
 "Servers correctly!"
 msgstr ""
+"nslookup do BusyBox na versão compilada atualmente não trabalha corretamente "
+"com servidores DNS dados!"
 
 msgid "Casual users should not change this setting"
-msgstr ""
+msgstr "Usuários iniciantes não devem alterar esta configuração"
 
 msgid "Change provider"
-msgstr ""
+msgstr "Mudando provedor"
 
 msgid "Check Interval"
-msgstr ""
+msgstr "Checar Intervalo"
 
 msgid "Collecting data..."
-msgstr ""
+msgstr "Coletando dados…"
 
 msgid "Config error"
-msgstr ""
+msgstr "Erro de configuração"
 
 msgid "Configuration"
-msgstr ""
+msgstr "Configuração"
 
 msgid ""
 "Configure here the details for all Dynamic DNS services including this LuCI "
 "application."
 msgstr ""
+"Configure aqui os detalhes para todos os serviços DNS Dinâmicos incluindo "
+"esta aplicação LuCI."
 
 msgid "Configure here the details for selected Dynamic DNS service."
-msgstr ""
+msgstr "Configure aqui os detalhes para o serviço DNS Dinâmico selecionado."
 
 msgid "Current setting"
-msgstr ""
+msgstr "Configuração atual"
 
 msgid ""
 "Currently DDNS updates are not started at boot or on interface events.<br /"
 ">This is the default if you run DDNS scripts by yourself (i.e. via cron with "
 "force_interval set to '0')"
 msgstr ""
+"Atualizações DDNS atuais não são iniciadas no boot ou nos eventos da "
+"interface.<br />Isso é o normal se você roda scripts DDNS por conta própria "
+"(ex. via cron com force_interval setado para ‘0’)"
 
 msgid ""
 "Currently DDNS updates are not started at boot or on interface events.<br /"
 ">You can start/stop each configuration here. It will run until next reboot."
 msgstr ""
+"Atualizações DDNS atuais não são iniciadas no boot ou nos eventos da "
+"interface.<br />Você pode iniciar/parar cada configuração aqui. Ela irá "
+"rodar até o próximo reboto."
 
 msgid "Custom update script to be used for updating your DDNS Provider."
 msgstr ""
+"Scripts de atualização personalizados para serem usados para atualizar seu "
+"Provedor DDNS."
 
 msgid "Custom update-URL"
 msgstr "URL para atualização personalizada"
 
 msgid "Custom update-script"
-msgstr ""
+msgstr "Script para atualização personalizado"
 
 msgid "DDNS Autostart disabled"
-msgstr ""
+msgstr "Auto-inicialização de DDNS desabilitada"
 
 msgid "DDNS Client Configuration"
-msgstr ""
+msgstr "Configuração de cliente DDNS"
 
 msgid "DDNS Client Documentation"
-msgstr ""
+msgstr "Documentação de cliente DDNS"
 
 msgid "DDNS Service provider"
-msgstr ""
+msgstr "Provedor de serviço DDNS"
 
 msgid "DNS requests via TCP not supported"
-msgstr ""
+msgstr "Requisição de DNS via TCP não suportada"
 
 msgid "DNS-Server"
-msgstr ""
+msgstr "Servidor DNS"
 
 msgid "Date format"
-msgstr ""
+msgstr "Formato de data"
 
 msgid "Defines the Web page to read systems IPv4-Address from"
-msgstr ""
+msgstr "Define a página Web para ler o endereço IPv4 do sistema"
 
 msgid "Defines the Web page to read systems IPv6-Address from"
-msgstr ""
+msgstr "Define a página Web para ler o endereço IPv6 do sistema"
 
 msgid "Defines the interface to read systems IP-Address from"
-msgstr ""
+msgstr "Define a interface para ler o endereço IP do sistema"
 
 msgid "Defines the network to read systems IPv4-Address from"
-msgstr ""
+msgstr "Define a rede para ler o endereço IPv4 do sistema"
 
 msgid "Defines the network to read systems IPv6-Address from"
-msgstr ""
+msgstr "Define a rede para ler o endereço IPv6 do sistema"
 
 msgid ""
 "Defines the source to read systems IPv4-Address from, that will be send to "
 "the DDNS provider"
 msgstr ""
+"Define a origem para ler o endereço IPv4 do sistema, que será enviado ao "
+"provedor DDNS"
 
 msgid ""
 "Defines the source to read systems IPv6-Address from, that will be send to "
 "the DDNS provider"
 msgstr ""
+"Define a origem para ler o endereço IPv6 do sistema, que será enviado ao "
+"provedor DDNS"
 
 msgid "Defines which IP address 'IPv4/IPv6' is send to the DDNS provider"
-msgstr ""
+msgstr "Define qual endereço IP ‘IPv4/IPv6’ é enviado ao provedor DDNS"
 
 msgid "Details for"
-msgstr ""
+msgstr "Detalhes para"
 
 msgid "Directory contains Log files for each running section"
-msgstr ""
+msgstr "Diretório contendo arquivos de Log para cada sessão em execução"
 
 msgid ""
 "Directory contains PID and other status information for each running section"
 msgstr ""
+"Diretório contendo PID e outras informações de status para cada sessão em "
+"execução"
 
 msgid "Disabled"
-msgstr ""
+msgstr "Desabilitado"
 
 msgid "Domain"
-msgstr ""
+msgstr "Domínio"
 
 msgid "Dynamic DNS"
 msgstr "DNS Dinâmico"
@@ -188,132 +213,150 @@ msgstr ""
 "um nome fixo, mesmo usando um Endereço IP dinâmico."
 
 msgid "Enable secure communication with DDNS provider"
-msgstr ""
+msgstr "Habilitar comunicação segura com o provedor DDNS"
 
 msgid "Enabled"
-msgstr ""
+msgstr "Habilitado"
 
 msgid "Error"
-msgstr ""
+msgstr "Erro"
 
 msgid "Error Retry Counter"
-msgstr ""
+msgstr "Contador de Tentativas em Erro"
 
 msgid "Error Retry Interval"
-msgstr ""
+msgstr "Intervalo de tentativas em Erro"
 
 msgid "Event Network"
 msgstr ""
 
 msgid "File"
-msgstr ""
+msgstr "Arquivo"
 
 msgid "File not found"
-msgstr ""
+msgstr "Arquivo não encontrado"
 
 msgid "File not found or empty"
-msgstr ""
+msgstr "Arquivo não encontrado ou vazio"
 
 msgid ""
 "Follow this link<br />You will find more hints to optimize your system to "
 "run DDNS scripts with all options"
 msgstr ""
+"Siga esse link<br />Você vai encontrar mais dicas para otimizar seu sistema "
+"para rodar scripts DDNS com todas as opções"
 
 msgid "For detailed information about parameter settings look here."
 msgstr ""
+"Olhe aqui para informações mais detalhadas sobre as configurações de "
+"parâmetro"
 
 msgid "For supported codes look here"
-msgstr ""
+msgstr "Olhe aqui para códigos suportados"
 
 msgid "Force IP Version"
-msgstr ""
+msgstr "Forçar versão de IP"
 
 msgid "Force IP Version not supported"
-msgstr ""
+msgstr "Forçar versão de IP não suportado"
 
 msgid "Force Interval"
-msgstr ""
+msgstr "Forçar intervalo"
 
 msgid "Force TCP on DNS"
-msgstr ""
+msgstr "Forçar TCP em DNS"
 
 msgid "Forced IP Version don't matched"
-msgstr ""
+msgstr "Forçar versão de IP não corresponde"
 
 msgid "Format"
-msgstr ""
+msgstr "Formato"
 
 msgid "Format: IP or FQDN"
-msgstr ""
+msgstr "Formato: IP ou FQDN"
 
 msgid ""
 "GNU Wget will use the IP of given network, cURL will use the physical "
 "interface."
-msgstr ""
+msgstr "GNU Wget usará o IP da rede informada, cURL usará a interface física"
 
 msgid "Global Settings"
-msgstr ""
+msgstr "Configurações Globais"
 
 msgid "HTTPS not supported"
-msgstr ""
+msgstr "HTTPS não suportado"
 
 msgid "Hints"
-msgstr ""
+msgstr "Dicas"
 
 msgid "Hostname/FQDN to validate, if IP update happen or necessary"
 msgstr ""
+"Hostname/FQDN a ser validado, se atualização de IP acontecer ou for "
+"necessária"
 
 msgid "IP address source"
-msgstr ""
+msgstr "Fonte do endereço IP"
 
 msgid "IP address version"
-msgstr ""
+msgstr "Versão do endereço IP"
 
 msgid "IPv4-Address"
-msgstr ""
+msgstr "Endereço IPv4"
 
 msgid "IPv6 address must be given in square brackets"
-msgstr ""
+msgstr "Endereço IPv6 deve estar entre colchetes"
 
 msgid ""
 "IPv6 is currently not (fully) supported by this system<br />Please follow "
 "the instructions on OpenWrt's homepage to enable IPv6 support<br />or update "
 "your system to the latest OpenWrt Release"
 msgstr ""
+"IPv6 não é (completamente) suportado por este sistema<br />Por favor siga as "
+"instruções na página inicial do OpenWrt para habilitar o suporte ao IPv6<br /"
+">ou atualize seu sistema para a última distribuição do OpenWrt"
 
 msgid "IPv6 not supported"
-msgstr ""
+msgstr "IPv6 não suportado"
 
 msgid "IPv6-Address"
-msgstr ""
+msgstr "Endereço IPv6"
 
 msgid "If both cURL and GNU Wget are installed, Wget is used by default."
-msgstr ""
+msgstr "Se ambos cURL e GNU Wget estão instalados, Wget é utilizado por padrão"
 
 msgid ""
 "If this service section is disabled it could not be started.<br />Neither "
 "from LuCI interface nor from console"
 msgstr ""
+"Se esta sessão do serviço está desabilidade, ele não pôde ser iniciado.<br /"
+">nem da interface LuCI nem do console"
 
 msgid "If using secure communication you should verify server certificates!"
 msgstr ""
+"Você deve verificar os certificados do servidor caso estiver utilizando "
+"comunicação segura"
 
 msgid ""
 "If you want to send updates for IPv4 and IPv6 you need to define two "
 "separate Configurations i.e. 'myddns_ipv4' and 'myddns_ipv6'"
 msgstr ""
+"Se deseja enviar atualizações para IPv4 e IPv6 você deve definir duas "
+"configurações separadas. Ex.: ‘myddns_ipv4’ e ‘myddns_ipv6’"
 
 msgid ""
 "In some versions cURL/libcurl in OpenWrt is compiled without proxy support."
 msgstr ""
+"Em algumas versões do OpenWrt cURL/libcurl é compilada sem suporte a proxy."
 
 msgid "Info"
-msgstr ""
+msgstr "Informações"
 
 msgid ""
 "Install 'ca-certificates' package or needed certificates by hand into /etc/"
 "ssl/certs default directory"
 msgstr ""
+"Instale manualmente o pacote ’ca-certificates’ ou certificados necessários "
+"no diretório padrão /etc/ssl/certs"
 
 msgid "Interface"
 msgstr "Interface"
@@ -322,67 +365,77 @@ msgid ""
 "Interval to check for changed IP<br />Values below 5 minutes == 300 seconds "
 "are not supported"
 msgstr ""
+"Intervalo para checar mudança no IP<br />Valores abaixo de 5 minutos == 300 "
+"segundos não são suportados"
 
 msgid ""
 "Interval to force updates send to DDNS Provider<br />Setting this parameter "
 "to 0 will force the script to only run once<br />Values lower 'Check "
 "Interval' except '0' are not supported"
 msgstr ""
+"Intervalo para forçar envio de atualizações para o provedor DDNS<br /"
+">Definindo esse parâmetro em 0 irá forçar o script a rodar apenas uma "
+"vez>br />Valores menores que 'Check Interval', exceto '0', não são suportados"
 
 msgid "It is NOT recommended for casual users to change settings on this page."
 msgstr ""
+"Não é recomendado que usuários iniciantes alterem configurações nessa página"
 
 msgid "Last Update"
-msgstr ""
+msgstr "Última atualização"
 
 msgid "Loading"
-msgstr ""
+msgstr "Carregando"
 
 msgid "Log File Viewer"
-msgstr ""
+msgstr "Visualizador de arquivo de log"
 
 msgid "Log directory"
-msgstr ""
+msgstr "Diretório do log"
 
 msgid "Log length"
-msgstr ""
+msgstr "Tamanho do log"
 
 msgid "Log to file"
-msgstr ""
+msgstr "Log para arquivo"
 
 msgid "Log to syslog"
-msgstr ""
+msgstr "Log para log do sistema"
 
 msgid "Lookup Hostname"
-msgstr ""
+msgstr "Verificar nome de host"
 
 msgid "NOT installed"
-msgstr ""
+msgstr "NÃO instalado"
 
 msgid ""
 "Neither GNU Wget with SSL nor cURL installed to select a network to use for "
 "communication."
 msgstr ""
+"Nem GNU Wget com SSL nem cURL instalado para selecionar uma rede para usar "
+"para comunicação"
 
 msgid ""
 "Neither GNU Wget with SSL nor cURL installed to support secure updates via "
 "HTTPS protocol."
 msgstr ""
+"Nem GNU Wget com SSL nem cURL instalado para suportar atualizações seguras "
+"via protocolo HTTPS"
 
 msgid "Network"
 msgstr "Rede"
 
 msgid "Network on which the ddns-updater scripts will be started"
-msgstr ""
+msgstr "Rede na qual os scripts de atualização DDNS serão iniciados"
 
 msgid "Never"
-msgstr ""
+msgstr "Nunca"
 
 msgid "Next Update"
-msgstr ""
+msgstr "Próxima atualização"
 
 msgid "No certificates found"
-msgstr ""
+msgstr "Nenhum certificado encontrado"
 
 msgid "No data"
 msgstr ""
@@ -391,344 +444,366 @@ msgid "No logging"
 msgstr ""
 
 msgid "Non-public and by default blocked IP's"
-msgstr ""
+msgstr "IPs não públicos e bloqueados por padrão"
 
 msgid "Notice"
 msgstr ""
 
 msgid "Number of last lines stored in log files"
-msgstr ""
+msgstr "Número das últimas linhas salvas nos arquivos de log"
 
 msgid "OPTIONAL: Force the usage of pure IPv4/IPv6 only communication."
-msgstr ""
+msgstr "OPCIONAL: Force o uso de apenas comunicação IPv4/IPv6 pura"
 
 msgid "OPTIONAL: Force the use of TCP instead of default UDP on DNS requests."
-msgstr ""
+msgstr "OPCIONAL: Force o uso de TCB em vez do padrão UDP em requisições DNS"
 
 msgid "OPTIONAL: Network to use for communication"
-msgstr ""
+msgstr "OPCIONAL: Rede para usar para comunicação"
 
 msgid "OPTIONAL: Proxy-Server for detection and updates."
-msgstr ""
+msgstr "OPCIONAL: Servidor Proxy para detecção e atualização"
 
 msgid "OPTIONAL: Use non-default DNS-Server to detect 'Registered IP'."
-msgstr ""
+msgstr "OPCIONAL: Use servidor DNS não-padrão para detectar 'Registered IP'"
 
 msgid "On Error the script will retry the failed action after given time"
-msgstr ""
+msgstr "Em Erro, o script irá tentar a ação que falhou após um tempo definido"
 
 msgid "On Error the script will stop execution after given number of retrys"
 msgstr ""
+"Em Erro, o script irá para a execução após um número definido de tentativas"
 
 msgid "OpenWrt Wiki"
 msgstr ""
 
 msgid "Optional Encoded Parameter"
-msgstr ""
+msgstr "Parâmetro Opcionalmente Codificado"
 
 msgid "Optional Parameter"
-msgstr ""
+msgstr "Parâmetro Opcional"
 
 msgid "Optional: Replaces [PARAMENC] in Update-URL (URL-encoded)"
-msgstr ""
+msgstr "Opcional: Substitui [PARAMEND] na URL de atualização"
 
 msgid "Optional: Replaces [PARAMOPT] in Update-URL (NOT URL-encoded)"
-msgstr ""
+msgstr "Opcional: Substitui [PARAMOPT] na URL de atualização"
 
 msgid "Overview"
 msgstr ""
 
 msgid "PROXY-Server"
-msgstr ""
+msgstr "servidor PROXY"
 
 msgid "PROXY-Server not supported"
-msgstr ""
+msgstr "Servidor PROXY não suportado"
 
 msgid "Password"
 msgstr "Senha"
 
 msgid "Path to CA-Certificate"
-msgstr ""
+msgstr "Caminho para os certificados CA"
 
 msgid "Please [Save & Apply] your changes first"
-msgstr ""
+msgstr "Por favor antes [Salve e Aplique] suas alterações"
 
 msgid "Please press [Read] button"
-msgstr ""
+msgstr "Por favor pressione o botão [Ler]"
 
 msgid "Please update to the current version!"
-msgstr ""
+msgstr "Por favor atualize para a versão atual"
 
 msgid "Process ID"
-msgstr ""
+msgstr "ID do processo"
 
 msgid "Read / Reread log file"
-msgstr ""
+msgstr "Ler / Ler novamente o arquivo de log"
 
 msgid "Really change DDNS provider?"
-msgstr ""
+msgstr "Mudar servidor DDNS?"
 
 msgid "Registered IP"
-msgstr ""
+msgstr "IP registrado"
 
 msgid "Replaces [DOMAIN] in Update-URL"
-msgstr ""
+msgstr "Substitui [DOMAIN] na URL de atualização"
 
 msgid "Replaces [PASSWORD] in Update-URL (URL-encoded)"
-msgstr ""
+msgstr "Substitui [PASSWORD] na URL de atualização"
 
 msgid "Replaces [USERNAME] in Update-URL (URL-encoded)"
-msgstr ""
+msgstr "Substitui [USERNAME] na URL de atualização"
 
 msgid "Run once"
-msgstr ""
+msgstr "Rodar apenas uma vez"
 
 msgid "Script"
-msgstr ""
+msgstr "Script"
 
 msgid "Show more"
-msgstr ""
+msgstr "Mostrar mais"
 
 msgid "Software update required"
-msgstr ""
+msgstr "Atualização de software necessária"
 
 msgid "Specifying a DNS-Server is not supported"
-msgstr ""
+msgstr "Não é suportado especificar um servidor DNS"
 
 msgid "Start"
-msgstr ""
+msgstr "Iniciar"
 
 msgid "Start / Stop"
-msgstr ""
+msgstr "Iniciar / Parar"
 
 msgid "Status directory"
-msgstr ""
+msgstr "Diretório de status"
 
 msgid "Stopped"
-msgstr ""
+msgstr "Parado"
 
 msgid ""
 "The currently installed 'ddns-scripts' package did not support all available "
 "settings."
 msgstr ""
+"O pacote 'ddns-scripts' instalado atualmente não suporta todas as "
+"configurações disponíveis"
 
 msgid "The default setting of '0' will retry infinite."
-msgstr ""
+msgstr "A configuração padrão de '0' terá infinitas tentativas"
 
 msgid "There is no service configured."
-msgstr ""
+msgstr "Não há serviço configurado"
 
 msgid "Timer Settings"
 msgstr ""
 
 msgid "To change global settings click here"
-msgstr ""
+msgstr "Clique aqui para mudar configurações globais"
 
 msgid "To use cURL activate this option."
-msgstr ""
+msgstr "Ative essa opção para usar cURL"
 
 msgid "URL"
 msgstr "URL"
 
 msgid "URL to detect"
-msgstr ""
+msgstr "Detectada pela URL"
 
 msgid "Unknown error"
-msgstr ""
+msgstr "Erro desconhecido"
 
 msgid ""
 "Update URL to be used for updating your DDNS Provider.<br />Follow "
 "instructions you will find on their WEB page."
 msgstr ""
+"URL a ser usada para atualizar seu provedor DDNS.<br />Siga as instruções "
+"encontradas na página deles."
 
 msgid "Update error"
-msgstr ""
+msgstr "Erro de atualização"
 
 msgid "Use HTTP Secure"
-msgstr ""
+msgstr "Usar HTTP Seguro"
 
 msgid "Use cURL"
-msgstr ""
+msgstr "Usar cURL"
 
 msgid "User defined script to read systems IP-Address"
-msgstr ""
+msgstr "Script definido pelo usuário para ler endereço IP do sistema"
 
 msgid "Username"
 msgstr "Usuário"
 
 msgid "Using specific DNS Server not supported"
-msgstr ""
+msgstr "Usar servidor DNS específico não é suportado"
 
 msgid "Verify"
-msgstr ""
+msgstr "Verificar"
 
 msgid "Version"
-msgstr ""
+msgstr "Versão"
 
 msgid "Version Information"
-msgstr ""
+msgstr "Informação de Versão"
 
 msgid "Waiting for changes to be applied..."
-msgstr ""
+msgstr "Aguardando as alterações serem aplicadas…"
 
 msgid "Warning"
-msgstr ""
+msgstr "Alerta"
 
 msgid ""
 "Writes detailed messages to log file. File will be truncated automatically."
 msgstr ""
+"Escreve mensagens detalhadas no arquivo de log. Arquivo será automaticamente "
+"truncado."
 
 msgid ""
 "Writes log messages to syslog. Critical Errors will always be written to "
 "syslog."
 msgstr ""
+"Escreve mensagens de log no log do sistema. Erros críticos sempre serão "
+"escritos no log do sistema."
 
 msgid ""
 "You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' package "
 "for DNS requests."
 msgstr ""
+"Você deve instalar o pacote 'bind-host' ou 'knot-host' ou 'drill' ou "
+"'hostip' para requisições DNS."
 
 msgid ""
 "You should install 'bind-host' or 'knot-host' or 'drill' or 'hostip' "
 "package, if you need to specify a DNS server to detect your registered IP."
 msgstr ""
+"Você deve instalar o pacote 'bind-host' ou 'knot-host' ou 'drill' ou "
+"'hostip' caso precise especificar um servidor DNS para detectar seu IP "
+"registrado."
 
 msgid ""
 "You should install 'bind-host' or 'knot-host' or 'drill' package for DNS "
 "requests."
 msgstr ""
+"Você deve instalar o pacote 'bind-host' ou 'knot-host' ou 'drill' para "
+"requisições DNS."
 
 msgid "You should install 'wget' or 'curl' or 'uclient-fetch' package."
-msgstr ""
+msgstr "Você deve instalar o pacote 'wget' ou 'curl' ou 'uclient-fetch'."
 
 msgid ""
 "You should install 'wget' or 'curl' or 'uclient-fetch' with 'libustream-"
 "*ssl' package."
 msgstr ""
+"Você deve instalar o pacote 'wget' ou 'curl' ou 'uclient-fetch' com "
+"'libustream-*ssl'."
 
 msgid "You should install 'wget' or 'curl' package."
-msgstr ""
+msgstr "Você deve instalar o pacote ‘wget’ ou ‘curl’."
 
 msgid ""
 "You should install 'wget' or 'uclient-fetch' package or replace libcurl."
 msgstr ""
+"Você deve instalar o pacote ‘wget’ ou ‘uclient-fetch’ ou substituir libcurl."
 
 msgid "cURL is installed, but libcurl was compiled without proxy support."
-msgstr ""
+msgstr "cURL está instalado, mas libcurl foi compilada sem suporte a proxy"
 
 msgid "cURL without Proxy Support"
-msgstr ""
+msgstr "cURL sem suporte a proxy"
 
 msgid "can not detect local IP. Please select a different Source combination"
 msgstr ""
+"não pôde detectar IP local. Por favor selecione uma combinação de fonte "
+"diferente"
 
 msgid "can not resolve host:"
-msgstr ""
+msgstr "não pôde resolver host:"
 
 msgid "config error"
-msgstr ""
+msgstr "erro de configuração"
 
 msgid "days"
-msgstr ""
+msgstr "dias"
 
 msgid "directory or path/file"
-msgstr ""
+msgstr "diretório ou caminho/arquivo"
 
 msgid "either url or script could be set"
-msgstr ""
+msgstr "url ou script pode ser setado"
 
 msgid "enable here"
-msgstr ""
+msgstr "habilite aqui"
 
 msgid "file or directory not found or not 'IGNORE'"
-msgstr ""
+msgstr "arquivo ou diretório não encontrado ou não ‘IGNORE’"
 
 msgid "help"
-msgstr ""
+msgstr "ajuda"
 
 msgid "hours"
-msgstr ""
+msgstr "horas"
 
 msgid "installed"
-msgstr ""
+msgstr "instalado"
 
 msgid "invalid FQDN / required - Sample"
-msgstr ""
+msgstr "FQDN requerido inválido - Exemplo"
 
 msgid "minimum value '0'"
-msgstr ""
+msgstr "valor mínimo ‘0’"
 
 msgid "minimum value '1'"
-msgstr ""
+msgstr "valor mínimo ‘1’"
 
 msgid "minimum value 5 minutes == 300 seconds"
-msgstr ""
+msgstr "valor mínimo 5 minutos == 300 segundos"
 
 msgid "minutes"
-msgstr ""
+msgstr "minutos"
 
 msgid "missing / required"
-msgstr ""
+msgstr "faltando / necessário"
 
 msgid "must be greater or equal 'Check Interval'"
-msgstr ""
+msgstr "deve ser maior ou igual ‘Check Interval’"
 
 msgid "must start with 'http://'"
-msgstr ""
+msgstr "deve iniciar com ‘http://'"
 
 msgid "nc (netcat) can not connect"
-msgstr ""
+msgstr "nc (netcat) não pôde conectar"
 
 msgid "never"
-msgstr ""
+msgstr "nunca"
 
 msgid "no data"
-msgstr ""
+msgstr "sem dados"
 
 msgid "not found or not executable - Sample: '/path/to/script.sh'"
-msgstr ""
+msgstr "não encontrado ou não executável - Exemplo: ‘/caminho/para/script.sh'"
 
 msgid "nslookup can not resolve host"
-msgstr ""
+msgstr "nslookup não pôde resolver o host"
 
 msgid "or"
-msgstr ""
+msgstr "ou"
 
 msgid "or higher"
-msgstr ""
+msgstr "ou maior"
 
 msgid "please disable"
-msgstr ""
+msgstr "por favor desabilite"
 
 msgid "please remove entry"
-msgstr ""
+msgstr "por favor remova a entrada"
 
 msgid "please select 'IPv4' address version"
-msgstr ""
+msgstr "por favor selecione a versão de endereço ‘IPv4’"
 
 msgid "please select 'IPv4' address version in"
-msgstr ""
+msgstr "por favor selecione a versão de endereço ‘IPv4’ em"
 
 msgid "please set to 'default'"
-msgstr ""
+msgstr "por favor defina como ‘default’"
 
 msgid "proxy port missing"
-msgstr ""
+msgstr "porta de proxy faltando"
 
 msgid "required"
-msgstr ""
+msgstr "necessário"
 
 msgid "seconds"
-msgstr ""
+msgstr "segundos"
 
 msgid "to run HTTPS without verification of server certificates (insecure)"
 msgstr ""
+"para rodar HTTPS sem verificação dos certificados do servidor (não seguro)"
 
 msgid "unknown error"
-msgstr ""
+msgstr "erro desconhecido"
 
 msgid "unspecific error"
-msgstr ""
+msgstr "erro não específico"
 
 msgid "use hostname, FQDN, IPv4- or IPv6-Address"
-msgstr ""
+msgstr "use hostname, FQDN, endereço IPv4 ou IPv6"
index af515fc59a5fa989a3731232dce62dac74e670c8..1bbee83c35d4c195f2fb7fc9bbf944da94da75ff 100644 (file)
@@ -235,7 +235,6 @@ for _, option in ipairs(params) do
                o.value = option[3]
        else
                if option[1] == DynamicList then
-                       o.cast = nil
                        function o.cfgvalue(...)
                                local val = AbstractValue.cfgvalue(...)
                                return ( val and type(val) ~= "table" ) and { val } or val
index 8385839a8f7d89ae4b3e874e4374fa75afed3747..aaa1979c412184c1bdabf5d5f115c5eccf544ba3 100644 (file)
@@ -62,7 +62,6 @@ for _, option in ipairs(basicParams) do
                o.value = option[3]
        else
                if option[1] == DynamicList then
-                       o.cast = nil
                        function o.cfgvalue(...)
                                local val = AbstractValue.cfgvalue(...)
                                return ( val and type(val) ~= "table" ) and { val } or val
index 1a1d33aa25c81b55fd01b2778f1a52e4dc78b6e9..719145b887bd8a1b10f776cae7a54e4175d6ca7c 100644 (file)
@@ -25,8 +25,13 @@ uci:foreach( "openvpn_recipes", "openvpn_recipe",
        end
 )
 
-function s.getPID(section)
-       return sys.exec("%s | grep -w %s | grep openvpn | grep -v grep | awk '{print $1}'" % { psstring,section} )
+function s.getPID(section) -- Universal function which returns valid pid # or nil
+       local pid = sys.exec("%s | grep -w %s | grep openvpn | grep -v grep | awk '{print $1}'" % { psstring,section} )
+       if pid and #pid > 0 and tonumber(pid) ~= nil then
+               return tonumber(pid)
+       else
+               return nil
+       end
 end
 
 function s.parse(self, section)
@@ -73,7 +78,7 @@ s:option( Flag, "enabled", translate("Enabled") )
 local active = s:option( DummyValue, "_active", translate("Started") )
 function active.cfgvalue(self, section)
        local pid = s.getPID(section)
-       if pid and #pid > 0 and tonumber(pid) ~= nil then
+       if pid ~= nil then
                return (sys.process.signal(pid, 0))
                        and translatef("yes (%i)", pid)
                        or  translate("no")
@@ -88,7 +93,7 @@ updown.redirect = luci.dispatcher.build_url(
 )
 function updown.cbid(self, section)
        local pid = s.getPID(section)
-       self._state = pid and #pid > 0 and sys.process.signal(pid, 0)
+       self._state = pid ~= nil and sys.process.signal(pid, 0)
        self.option = self._state and "stop" or "start"
        return AbstractValue.cbid(self, section)
 end
@@ -99,7 +104,9 @@ end
 function updown.write(self, section, value)
        if self.option == "stop" then
                local pid = s.getPID(section)
-               sys.process.signal(pid,15)
+               if pid ~= nil then
+                       sys.process.signal(pid,15)
+               end
        else
                luci.sys.call("/etc/init.d/openvpn start %s" % section)
        end
diff --git a/contrib/package/community-profiles/files/etc/config/profile_tulumlibre b/contrib/package/community-profiles/files/etc/config/profile_tulumlibre
new file mode 100644 (file)
index 0000000..ecc6f9b
--- /dev/null
@@ -0,0 +1,10 @@
+config 'community' 'profile'
+       option 'name' 'tulumlibre'
+       option 'ssid' 'tulumlibre'
+       option 'mesh_network' '10.39.128.0/18'
+       option 'latitude' '20.2106708'
+       option 'longitude' '-87.4629471'
+       option 'splash_prefix' '28'
+
+config 'defaults' 'interface'
+       option 'dns' '213.73.91.35 216.87.84.211'
index 2874b5607e31716051393cc14fc6364f9ff661b5..c7fdfcddba39ddf2523294291aa58e6957d9053f 100644 (file)
@@ -80,6 +80,14 @@ o.optional    = true
 o.placeholder = 514
 o.datatype    = "port"
 
+o = s:taboption("logging", ListValue, "log_proto", translate("External system log server protocol"))
+o:value("udp", "UDP")
+o:value("tcp", "TCP")
+
+o = s:taboption("logging", Value, "log_file", translate("Write system log to file"))
+o.optional    = true
+o.placeholder = "/tmp/system.log"
+
 o = s:taboption("logging", ListValue, "conloglevel", translate("Log output level"))
 o:value(8, translate("Debug"))
 o:value(7, translate("Info"))
index e450470eb3d1aa593112fc3941da1a519a26a670..a47ce1588c0bc247e8b039258cd996132f3c7f41 100644 (file)
@@ -26,21 +26,19 @@ port.datatype    = "port"
 ifname = section:taboption("general", Value, "interface", translate("Output Interface"))
 ifname.template = "cbi/network_netlist"
 
-mtu = section.taboption("general", Value, "mtu", translate("MTU"))
+mtu = section:taboption("general", Value, "mtu", translate("MTU"))
 mtu.datatype = "uinteger"
 
-section:taboption("general", Value, "authgroup", translate("AuthGroup"))
-
 username = section:taboption("general", Value, "username", translate("Username"))
 password = section:taboption("general", Value, "password", translate("Password"))
-hexpassword = section:taboption("general", Value, "hexpassword", translate("Obfuscated Password"))
 password.password = true
+hexpassword = section:taboption("general", Value, "hexpassword", translate("Obfuscated Password"))
 hexpassword.password = true
 authroup = section:taboption("general", Value, "authgroup", translate("Auth Group"))
 passgroup = section:taboption("general", Value, "passgroup", translate("Group Password"))
+passgroup.password = true
 hexpassgroup = section:taboption("general", Value, "hexpassgroup", translate("Obfuscated Group Password"))
-password.passgroup = true
-hexpassword.passgroup= true
+hexpassword.password= true
 
 domain = section:taboption("general", Value, "domain", translate("NT Domain"))
 vendor = section:taboption("general", Value, "vendor", translate("Vendor"))
@@ -50,17 +48,17 @@ dh_group:value("dh1")
 dh_group:value("dh5")
 
 pfs = section:taboption("general", ListValue, "pfs", translate("Perfect Forward Secrecy"))
-dh_group:value("server")
-dh_group:value("nopfs")
-dh_group:value("dh1")
-dh_group:value("dh2")
-dh_group:value("dh5")
+pfs:value("server")
+pfs:value("nopfs")
+pfs:value("dh1")
+pfs:value("dh2")
+pfs:value("dh5")
 
-natt_mode = section:taboption("general", ListValue, "natt_mode", translate("NAT-T Mode")
+natt_mode = section:taboption("general", ListValue, "natt_mode", translate("NAT-T Mode"))
 natt_mode:value("natt", translate("RFC3947 NAT-T mode"))
 natt_mode:value("none", translate("No NAT-T"))
-natt_mode:value("force-natt", translate("Force use of NAT-T")
-natt_mode:value("cisco-udp", translate("Cisco UDP encapsulation")
+natt_mode:value("force-natt", translate("Force use of NAT-T"))
+natt_mode:value("cisco-udp", translate("Cisco UDP encapsulation"))
 
 enable_no_enc = section:taboption("general", Flag, "enable_no_enc",
        translate("Disable Encryption"),
@@ -72,11 +70,10 @@ enable_single_des = section:taboption("general", Flag, "enable_single_des",
        translate("If checked, 1DES is enaled"))
 enable_no_enc.default = enable_single_des.disabled
 
-dpd_idle = section.taboption("general", Value, "dpd_idle", translate("DPD Idle Timeout"))
+dpd_idle = section:taboption("general", Value, "dpd_idle", translate("DPD Idle Timeout"))
 dpd_idle.datatype = "uinteger"
-dpd.placeholder = "600"
+dpd_idle.placeholder = "600"
 
 ifname = section:taboption("general", Value, "target_network", translate("Target network"))
 port.placeholder = "0.0.0.0/0"
 port.datatype    = "network"
-