isc-dhcp: fix typeof regex for IP address pattern 5887/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 8 Apr 2018 22:07:01 +0000 (16:07 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sun, 8 Apr 2018 22:31:28 +0000 (16:31 -0600)
Missing backslash in "\d+" for last digit of dotted quad.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/isc-dhcp/Makefile
net/isc-dhcp/files/dhcpd.init

index 0f8593177c09c5fab583df3f7635534c3ab051e7..f22d743278585e7fe8f0cf041c2ed3e6c8f99af0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=isc-dhcp
 UPSTREAM_NAME:=dhcp
 PKG_VERSION:=4.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
index fdcbe24909f00e709a64eee5401cf64034e6fd1d..8eb20d101db3bb4fad7eed754e82b58b785538f1 100644 (file)
@@ -122,7 +122,7 @@ static_hosts() {
 
 typeof() {
        echo "$1" | awk '
-/^\d+\.\d+\.\d+\.d+$/          { print "ip\n"; next; }
+/^\d+\.\d+\.\d+\.\d+$/         { print "ip\n"; next; }
 /^(true|false)$/               { print "bool\n"; next; }
 /^\d+$/                                { print "integer\n"; next; }
 /^"[^"]*"$/                    { print "string\n"; next; }