python-markdown: add a new package 9224/head
authorKarel Kočí <karel.koci@nic.cz>
Mon, 13 Aug 2018 14:14:40 +0000 (16:14 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 18 Jun 2019 21:19:24 +0000 (23:19 +0200)
Signed-off-by: Karel Kočí <karel.koci@nic.cz>
[Add me as maintainer]
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lang/python/python-markdown/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-markdown/Makefile b/lang/python/python-markdown/Makefile
new file mode 100644 (file)
index 0000000..06baa3a
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-markdown
+PKG_VERSION:=3.1.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=Markdown-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/m/markdown/
+PKG_HASH:=2e50876bcdd74517e7b71f3e7a76102050edec255b3983403f1a63e7c8a41e7a
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/Markdown-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE.md
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-markdown
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Markdown implementation in Python
+  URL:=https://python-markdown.github.io/
+  DEPENDS:= \
+       +python3-light \
+       +python3-setuptools \
+       +python3-logging
+  VARIANT:=python3
+endef
+
+define Package/python3-markdown/description
+  A fast and complete Python implementation of Markdown.
+endef
+
+$(eval $(call Py3Package,python3-markdown))
+$(eval $(call BuildPackage,python3-markdown))
+$(eval $(call BuildPackage,python3-markdown-src))