Merge pull request #2310 from chris5560/master
authorHannu Nyman <hannu.nyman@iki.fi>
Tue, 26 Jan 2016 08:39:03 +0000 (10:39 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Tue, 26 Jan 2016 08:39:03 +0000 (10:39 +0200)
ddns-scripts: Ver.2.6.0 - support hostip and uclient-fetch

20 files changed:
devel/libtool-bin/Makefile [new file with mode: 0644]
lang/python-setuptools/Makefile
lang/python-setuptools/patches/0001-remove-windows-support.patch
lang/python3-setuptools/Makefile
lang/python3-setuptools/patches/0001-remove-windows-support.patch
libs/libwebsockets/Makefile
libs/pcre/Makefile
libs/pcre/patches/100-pcre-cve-2015-3210.patch [deleted file]
libs/unixodbc/Makefile
net/chrony/Makefile
net/haproxy/Makefile
net/haproxy/patches/0011-BUG-MEDIUM-peers-table-entries-learned-from-a-remote.patch [new file with mode: 0644]
net/haproxy/patches/0012-BUG-MEDIUM-peers-old-stick-table-updates-could-be-re.patch [new file with mode: 0644]
net/haproxy/patches/0013-CLEANUP-haproxy-using-_GNU_SOURCE-instead-of-__USE_G.patch [new file with mode: 0644]
net/nginx/Config.in
net/nginx/Makefile
net/ntpd/Makefile
net/prosody/Makefile
net/prosody/patches/010-fix-randomseed.patch [deleted file]
net/u2pnpd/Makefile

diff --git a/devel/libtool-bin/Makefile b/devel/libtool-bin/Makefile
new file mode 100644 (file)
index 0000000..e7922c3
--- /dev/null
@@ -0,0 +1,51 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=2.4.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libtool
+PKG_MD5SUM:=addf44b646ddb4e3919805aa88fa7c5e
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
+PKG_LICENSE:=GPL-2.0+
+PKG_BUILD_DIR = $(BUILD_DIR)/libtool-bin/$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libtool-bin
+  SECTION:=devel
+  CATEGORY:=Development
+  TITLE:=GNU Libtool - libtoolize
+  URL:=https://www.gnu.org/software/libtool/
+endef
+
+define Package/libtool-bin/description
+ GNU libtool is a generic library support script.
+ Libtool hides the complexity of using shared libraries behind a consistent,
+ portable interface. 
+ This package contains the libtoolize executable.
+endef
+
+define Package/libtool-bin/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libtoolize $(1)/usr/bin/
+       $(SED) 's|$(STAGING_DIR_HOST)||g' $(1)/usr/bin/libtoolize
+       $(INSTALL_DIR) $(1)/usr/share/aclocal/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/*.m4 \
+         $(1)/usr/share/aclocal/
+       $(INSTALL_DIR) $(1)/usr/share/libtool/build-aux/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/libtool/build-aux/* \
+         $(1)/usr/share/libtool/build-aux/
+endef
+
+$(eval $(call BuildPackage,libtool-bin))
index b45b408e1ca17da5d4cb8221a8cd10cc6c5da227..880dd0ba8423a9613f4495f63dfdeaedce47aa53 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-setuptools
-PKG_VERSION:=18.7
+PKG_VERSION:=19.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
-PKG_MD5SUM:=295d7aaef2da7d6ff10b522581da0cf9
+PKG_MD5SUM:=c5a7d90c1e0acf8c4ec5c2bf31bc25b5
 
 HOST_BUILD_DEPENDS:=python/host
 
index 0a2d50baf11cbb4b023b9f38f7c899995f15a0b0..f48127fab316e90432822e297e2705bf5b2f6eb0 100644 (file)
@@ -1,16 +1,16 @@
 diff --git a/setuptools/dist.py b/setuptools/dist.py
-index 6b9d350..1350e8a 100644
+index 7785541..23108c7 100644
 --- a/setuptools/dist.py
 +++ b/setuptools/dist.py
-@@ -15,7 +15,6 @@ from distutils.errors import (DistutilsOptionError, DistutilsPlatformError,
+@@ -18,7 +18,6 @@ from setuptools.extern.six.moves import map
+ from pkg_resources.extern import packaging
  
  from setuptools.depends import Require
- from setuptools.compat import basestring, PY2
 -from setuptools import windows_support
  import pkg_resources
  
- def _get_unpatched(cls):
-@@ -310,7 +309,6 @@ class Distribution(_Distribution):
+@@ -335,7 +334,6 @@ class Distribution(_Distribution):
          egg_cache_dir = os.path.join(os.curdir, '.eggs')
          if not os.path.exists(egg_cache_dir):
              os.mkdir(egg_cache_dir)
index 8394ec1ea494d5dc28c94ff810bd831c6fe83129..ea299ea02f34ef7f5e68d1e2384be967f6083ecc 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python3-setuptools
-PKG_VERSION:=18.5
+PKG_VERSION:=19.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=setuptools-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/s/setuptools/
-PKG_MD5SUM:=533c868f01169a3085177dffe5e768bb
+PKG_MD5SUM:=c5a7d90c1e0acf8c4ec5c2bf31bc25b5
 
 PKG_LICENSE:=PSF
 
index 0a2d50baf11cbb4b023b9f38f7c899995f15a0b0..f48127fab316e90432822e297e2705bf5b2f6eb0 100644 (file)
@@ -1,16 +1,16 @@
 diff --git a/setuptools/dist.py b/setuptools/dist.py
-index 6b9d350..1350e8a 100644
+index 7785541..23108c7 100644
 --- a/setuptools/dist.py
 +++ b/setuptools/dist.py
-@@ -15,7 +15,6 @@ from distutils.errors import (DistutilsOptionError, DistutilsPlatformError,
+@@ -18,7 +18,6 @@ from setuptools.extern.six.moves import map
+ from pkg_resources.extern import packaging
  
  from setuptools.depends import Require
- from setuptools.compat import basestring, PY2
 -from setuptools import windows_support
  import pkg_resources
  
- def _get_unpatched(cls):
-@@ -310,7 +309,6 @@ class Distribution(_Distribution):
+@@ -335,7 +334,6 @@ class Distribution(_Distribution):
          egg_cache_dir = os.path.join(os.curdir, '.eggs')
          if not os.path.exists(egg_cache_dir):
              os.mkdir(egg_cache_dir)
index 3e5f00462c1c8db1a6b59cc683daa95ce881240a..71acda3618d1685518aa060d2358db8d6dae0b93 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libwebsockets
-PKG_VERSION:=1.5-chrome47-firefox41
+PKG_VERSION:=1.6.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -27,8 +27,7 @@ CMAKE_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DLWS_IPV6=)
-
+CMAKE_OPTIONS += -DLWS_IPV6=$(if $(CONFIG_IPV6),ON,OFF)
 CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON
 
 # other options worth noting
@@ -74,7 +73,7 @@ ifeq ($(BUILD_VARIANT),cyassl)
 # for cyassl, edit package/libs/cyassl/Makefile to include --enable-opensslextra
 # NOTE: it will compile without it, untested whether it it's needed?!
     CMAKE_OPTIONS += -DLWS_USE_CYASSL=ON
-    CMAKE_OPTIONS += -DLWS_CYASSL_LIB=$(STAGING_DIR)/usr/lib/libcyassl.so
+    CMAKE_OPTIONS += -DLWS_CYASSL_LIBRARIES=$(STAGING_DIR)/usr/lib/libcyassl.so
     CMAKE_OPTIONS += -DLWS_CYASSL_INCLUDE_DIRS=$(STAGING_DIR)/usr/include
 endif
 
index 6a9c4144c361a1749a2c6375335749d7c217ce7f..75fa99299cfcd60381d37a352ca7ec596a474cd0 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcre
-PKG_VERSION:=8.37
-PKG_RELEASE:=2
+PKG_VERSION:=8.38
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/pcre
-PKG_MD5SUM:=ed91be292cb01d21bc7e526816c26981
+PKG_SOURCE_URL:=ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/
+PKG_MD5SUM:=00aabbfe56d5a48b270f999b508c5ad2
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
 
 PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/pcre/patches/100-pcre-cve-2015-3210.patch b/libs/pcre/patches/100-pcre-cve-2015-3210.patch
deleted file mode 100644 (file)
index 276d09e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-Index: pcre-8.37/pcre_compile.c
-===================================================================
---- a/pcre_compile.c
-+++ b/pcre_compile.c
-@@ -7177,14 +7177,26 @@
-           number. If the name is not found, set the value to 0 for a forward
-           reference. */
-+          recno = 0;
-           ng = cd->named_groups;
-           for (i = 0; i < cd->names_found; i++, ng++)
-             {
-             if (namelen == ng->length &&
-                 STRNCMP_UC_UC(name, ng->name, namelen) == 0)
--              break;
-+              {
-+              open_capitem *oc;
-+              recno = ng->number;
-+              if (is_recurse) break;
-+              for (oc = cd->open_caps; oc != NULL; oc = oc->next)         
-+                {          
-+                if (oc->number == recno)                                     
-+                  {               
-+                  oc->flag = TRUE;                                      
-+                  break;
-+                  }                                                         
-+                }                          
-+              }    
-             }
--          recno = (i < cd->names_found)? ng->number : 0;
-           /* Count named back references. */
index 4a94a8986bd68b7fd6354b7af27f05f6e46440c0..d962371baa3470f8bfc1d6453bc5beac8e6d9241 100644 (file)
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=unixodbc
 PKG_VERSION:=2.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@SF/unixodbc
+PKG_SOURCE_URL:=ftp://ftp.unixodbc.org/pub/unixODBC/
 PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=bd25d261ca1808c947cb687e2034be81
 PKG_BUILD_DIR:=$(BUILD_DIR)/unixODBC-$(PKG_VERSION)
index d0bf9ba59ab42347c189da4c0840f6e52c53fdf2..9a2b2df388a46789ecc27e9677a9394582fa6929 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chrony
-PKG_VERSION:=2.2
-PKG_RELEASE:=2
+PKG_VERSION:=2.2.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://download.tuxfamily.org/chrony/
-PKG_MD5SUM:=17bc77d3d2ce942675f9600b60452717
+PKG_MD5SUM:=ce46990540aab3670d093311ee43fe17
 
 PKG_MAINTAINER:=Miroslav Lichvar <mlichvar0@gmail.com>
 PKG_LICENSE:=GPL-2.0
index 5138e7c3da0c87ffefc05f79cdd9c657818f6d68..949cac7b9d841dac21a6bade0292e5f93b28c18a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
 PKG_VERSION:=1.5.15
-PKG_RELEASE:=10
+PKG_RELEASE:=13
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
diff --git a/net/haproxy/patches/0011-BUG-MEDIUM-peers-table-entries-learned-from-a-remote.patch b/net/haproxy/patches/0011-BUG-MEDIUM-peers-table-entries-learned-from-a-remote.patch
new file mode 100644 (file)
index 0000000..ae23e26
--- /dev/null
@@ -0,0 +1,31 @@
+From 96a1b4a969a5f3c9224d786c79e90d15a47094b0 Mon Sep 17 00:00:00 2001
+From: Emeric Brun <ebrun@haproxy.com>
+Date: Wed, 16 Dec 2015 15:16:46 +0100
+Subject: [PATCH 11/13] BUG/MEDIUM: peers: table entries learned from a remote
+ are pushed to others after a random delay.
+
+New sticktable entries learned from a remote peer can be pushed to others after
+a random delay because they are not inserted at the right position in the updates
+tree.
+(cherry picked from commit 234fc3c31e751f8191b9b78fa5fd16663c2627fe)
+(cherry picked from commit 8b1a697362977b8392caca3efaf97a5a8a8c782b)
+---
+ src/peers.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/peers.c b/src/peers.c
+index 0564d3d..92b4df0 100644
+--- a/src/peers.c
++++ b/src/peers.c
+@@ -720,7 +720,7 @@ switchstate:
+                                                       ts = stktable_store(ps->table->table, newts, 0);
+                                                       newts = NULL; /* don't reuse it */
+-                                                      ts->upd.key= (++ps->table->table->update)+(2^31);
++                                                      ts->upd.key= (++ps->table->table->update)+(2147483648U);
+                                                       eb = eb32_insert(&ps->table->table->updates, &ts->upd);
+                                                       if (eb != &ts->upd) {
+                                                               eb32_delete(eb);
+-- 
+2.4.10
+
diff --git a/net/haproxy/patches/0012-BUG-MEDIUM-peers-old-stick-table-updates-could-be-re.patch b/net/haproxy/patches/0012-BUG-MEDIUM-peers-old-stick-table-updates-could-be-re.patch
new file mode 100644 (file)
index 0000000..1bd4653
--- /dev/null
@@ -0,0 +1,28 @@
+From a320fd146f802a851a396b2cde491711a4fb87cf Mon Sep 17 00:00:00 2001
+From: Emeric Brun <ebrun@haproxy.com>
+Date: Wed, 16 Dec 2015 15:28:12 +0100
+Subject: [PATCH 12/13] BUG/MEDIUM: peers: old stick table updates could be
+ repushed.
+
+Because the stick table updates tree was not properly initialized to EB_ROOT_UNIQUE.
+(cherry picked from commit 1c6235dbba0a67bad1d5e57ada88f28e1270a5cb)
+(cherry picked from commit 6e80935a77c8c2c67a982780a0f14c241f02f2aa)
+---
+ src/stick_table.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/stick_table.c b/src/stick_table.c
+index 48d5710..6310690 100644
+--- a/src/stick_table.c
++++ b/src/stick_table.c
+@@ -385,6 +385,7 @@ int stktable_init(struct stktable *t)
+       if (t->size) {
+               memset(&t->keys, 0, sizeof(t->keys));
+               memset(&t->exps, 0, sizeof(t->exps));
++              t->updates = EB_ROOT_UNIQUE;
+               t->pool = create_pool("sticktables", sizeof(struct stksess) + t->data_size + t->key_size, MEM_F_SHARED);
+-- 
+2.4.10
+
diff --git a/net/haproxy/patches/0013-CLEANUP-haproxy-using-_GNU_SOURCE-instead-of-__USE_G.patch b/net/haproxy/patches/0013-CLEANUP-haproxy-using-_GNU_SOURCE-instead-of-__USE_G.patch
new file mode 100644 (file)
index 0000000..88a1157
--- /dev/null
@@ -0,0 +1,43 @@
+From 21fab69d332bfafd0a214ee29d8ad0779a055988 Mon Sep 17 00:00:00 2001
+From: David Carlier <devnexen@gmail.com>
+Date: Tue, 8 Dec 2015 21:43:09 +0000
+Subject: [PATCH 13/13] CLEANUP: haproxy: using _GNU_SOURCE instead of
+ __USE_GNU macro.
+
+In order to properly enable sched_setaffinity, in some versions of Linux,
+it is rather _GNU_SOURCE than __USE_GNU (spotted on Alpine Linux for instance),
+also for the sake of consistency as __USE_GNU seems not used across the code and
+for last, it seems on Linux it is the best way to enable non portable code.
+On Linux glibc's based versions, it seems _GNU_SOURCE defines __USE_GNU
+it should be safe enough.
+(cherry picked from commit 7ece096767d329d0ea04b70a1fb2c8b8a96b47e0)
+(cherry picked from commit 5a0ac35503f88a7bc8ee2c4f865354fa6cc25901)
+---
+ src/haproxy.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/haproxy.c b/src/haproxy.c
+index b94252d..20480a1 100644
+--- a/src/haproxy.c
++++ b/src/haproxy.c
+@@ -25,6 +25,7 @@
+  *
+  */
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
+@@ -47,9 +48,7 @@
+ #include <syslog.h>
+ #include <grp.h>
+ #ifdef USE_CPU_AFFINITY
+-#define __USE_GNU
+ #include <sched.h>
+-#undef __USE_GNU
+ #endif
+ #ifdef DEBUG_FULL
+-- 
+2.4.10
+
index a4cc4c8c8e7af40ebdbbc7544f5ead43f52c7611..6482d9d2846ee14339df9621a6719c0528992c59 100644 (file)
@@ -172,4 +172,9 @@ config NGINX_PCRE
        prompt "Enable PCRE library usage"
        default y
 
+config NGINX_NAXSI
+       bool
+       prompt "Enable NAXSI module"
+       default y
+
 endmenu
index cc597157744cd528e6a049c19cf49afaa7faaf2b..6bce6a2a1d8e58bd4ec90eafd244d911a3a914ce 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nginx
-PKG_VERSION:=1.9.6
-PKG_RELEASE:=1
+PKG_VERSION:=1.9.9
+PKG_RELEASE:=2
 
 PKG_SOURCE:=nginx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://nginx.org/download/
-PKG_MD5SUM:=f6899825e7a8deadba4948ff84515ad6
+PKG_MD5SUM:=50fdfa08e93ead7a111cba5a5f5735af
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
 PKG_LICENSE:=2-clause BSD-like license
 
@@ -83,6 +83,11 @@ define Package/nginx/conffiles
 /etc/nginx/
 endef
 
+ADDITIONAL_MODULES:=
+ifeq ($(CONFIG_NGINX_NAXSI),y)
+  ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/nginx-naxsi/naxsi_src
+endif
+
 ADDITIONAL_MODULES:=
 ifeq ($(CONFIG_IPV6),y)
   ADDITIONAL_MODULES += --with-ipv6
@@ -209,6 +214,31 @@ define Package/nginx/install
        $(INSTALL_DATA) $(addprefix $(PKG_INSTALL_DIR)/etc/nginx/,$(config_files)) $(1)/etc/nginx/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/nginx.init $(1)/etc/init.d/nginx
+ifeq ($(CONFIG_NGINX_NAXSI),y)
+       $(INSTALL_DIR) $(1)/etc/nginx
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nginx-naxsi/naxsi_config/naxsi_core.rules $(1)/etc/nginx
+       chmod 0640 $(1)/etc/nginx/naxsi_core.rules
+endif
+       $(if $(CONFIG_NGINX_NAXSI),$($(INSTALL_BIN) $(PKG_BUILD_DIR)/nginx-naxsi/naxsi_config/naxsi_core.rules $(1)/etc/nginx))
+       $(if $(CONFIG_NGINX_NAXSI),$(chmod 0640 $(1)/etc/nginx/naxsi_core.rules))
+endef
+
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(if $(CONFIG_NGINX_NAXSI),$(call Prepare/nginx-naxsi))
+endef
+
+define Download/nginx-naxsi
+       VERSION:=6358c3d2e68a0c9e3ad11661c2a1f63fadc9b4f2
+       SUBDIR:=nginx-naxsi
+       FILE:=nginx-naxsi-module-$(PKG_VERSION)-$$(VERSION).tar.gz
+       URL:=https://github.com/nbs-system/naxsi.git
+       PROTO:=git
+endef
+
+define  Prepare/nginx-naxsi
+       $(eval $(call Download,nginx-naxsi))
+       gzip -dc $(DL_DIR)/$(FILE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
 endef
 
 $(eval $(call BuildPackage,nginx))
index 06d533f55e291d63aefd803bfae7a00cee5929ca..3b1b6c0fd411bb237a355dc7b272ff67011fb771 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ntp
-PKG_VERSION:=4.2.8p5
+PKG_VERSION:=4.2.8p6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
-PKG_MD5SUM:=9f02b2a0acc1617ce2716d529a58d2d8
+PKG_MD5SUM:=60049f51e9c8305afe30eb22b711c5c6
 
 PKG_LICENSE:=Unique
 PKG_LICENSE_FILES:=COPYRIGHT html/copyright.html
index 4ff6d38adfd7a07f26882e8e24ad72208c8e3d3c..eff3e2efb8c7aadd15c8ab8c701899cac2663cec 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=prosody
-PKG_VERSION:=0.9.8
+PKG_VERSION:=0.9.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://prosody.im/downloads/source
-PKG_MD5SUM:=5144cd832a1860443e21e336dc560ee7
+PKG_MD5SUM:=8f7c529b072e78ab9e82ecbedfee7145
 PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
 PKG_LICENSE:=MIT/X11
 
diff --git a/net/prosody/patches/010-fix-randomseed.patch b/net/prosody/patches/010-fix-randomseed.patch
deleted file mode 100644 (file)
index 05bdffa..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u --recursive prosody-0.9.7-vanilla/net/dns.lua prosody-0.9.7/net/dns.lua
---- prosody-0.9.7-vanilla/net/dns.lua  2015-01-02 00:26:19.981433830 -0500
-+++ prosody-0.9.7/net/dns.lua  2015-01-02 00:33:10.467077715 -0500
-@@ -225,7 +225,7 @@
- function dns.random(...)    -- - - - - - - - - - - - - - - - - - -  dns.random
--      math.randomseed(math.floor(10000*socket.gettime()) % 0x100000000);
-+      math.randomseed(math.floor(10000*socket.gettime()) % 0x80000000);
-       dns.random = math.random;
-       return dns.random(...);
- end
index f859d3b031a9377e4ff7db7579a8e8b161f0fa4c..3f77ba33966e9b11ca104319e0cc39a4c0854cd6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u2pnpd
-PKG_VERSION:=0.1
+PKG_VERSION:=0.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://github.com/mhei/u2pnpd/releases/download/v$(PKG_VERSION)
-PKG_MD5SUM:=a98089923d93803fa90d03a504c98b8e
+PKG_MD5SUM:=ac6f378590d3e4e38b40e4b13f03b369
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING