libtasn1: fix host build under old GCC 12288/head
authorRosen Penev <rosenp@gmail.com>
Sun, 24 May 2020 04:11:46 +0000 (21:11 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 25 May 2020 01:37:39 +0000 (18:37 -0700)
prereq-build.mk says that GCC 4.8 and above is supported. GCC 4.8
defaults to std=gnu89, breaking the build. GCC5 defaults to gnu99.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libtasn1/Makefile

index d471c6ecf6a845c53c53c83c32a805f070195194..e5bf554fe7ef22dbcdc5aef451a2e530fb419099 100644 (file)
@@ -39,6 +39,7 @@ define Package/libtasn1/description
  Distinguish Encoding Rules (DER) manipulation.
 endef
 
+HOST_CFLAGS += -std=gnu99
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections