php7: fix pecl build with QUILT
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 25 Feb 2021 15:58:36 +0000 (12:58 -0300)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 26 Feb 2021 17:07:30 +0000 (18:07 +0100)
Commit d741a64b7 ("lang/php7: Don't run phpize7 with QUILT") changed
pecl.mk to not run phpize7 during Package/prepare if QUILT is set.  The
intention was to allow prepare, refresh and update targets to run
without building dependencies.

As a side-effect, Package/configure and Package/compile fail when QUILT
is defined because they can't find ./configure or a Makefile.  It also
impacts the github tests run with pull requests, because QUILT is
defined there.

To avoid that failure and still keep the prepare, refresh, and update
speedup, call phpize7 before Package/Configure if QUILT is defined.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 3476816cc8f03dcd7d118bb1faf77a9ef224d66f)

lang/php7/pecl.mk

index d85e8d139917195b7be250eb5b2cf4d64a5f1ab5..faa8b090fee94a623820c03254281c33132c0d13 100644 (file)
@@ -16,6 +16,11 @@ define Build/Prepare
        $(if $(QUILT),,( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 ))
 endef
 
+define Build/Configure
+       $(if $(QUILT),( cd $(PKG_BUILD_DIR); $(STAGING_DIR)/usr/bin/phpize7 ))
+       $(Build/Configure/Default)
+endef
+
 CONFIGURE_VARS+= \
        ac_cv_c_bigendian_php=$(if $(CONFIG_BIG_ENDIAN),yes,no)