gammu: Fix lib symlinks 10237/head
authorJeffery To <jeffery.to@gmail.com>
Mon, 14 Oct 2019 09:12:41 +0000 (17:12 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 14 Oct 2019 09:12:41 +0000 (17:12 +0800)
This fixes the symlinks for libGammu.so and libgsmsd.so. Previously, the
symlinks were overwritten by $(INSTALL_BIN) with copies of their
sources.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
utils/gammu/Makefile

index c376bf4ab19fc60af1071c17a58698086a3a2169..1d52dd01a0c29e2f0327391080c792802f532fef 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gammu
 PKG_VERSION:=1.38.4
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE_URL:=http://dl.cihar.com/gammu/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -58,7 +58,7 @@ define Package/gammu/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu-{smsd,smsd-inject,smsd-monitor} $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/gammu $(1)/etc/config/gammu