[packages] perl: COrrect installation of prove binary for test hasrness
authorHamish Guthrie <hcg@openwrt.org>
Thu, 17 Jan 2013 15:20:19 +0000 (15:20 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Thu, 17 Jan 2013 15:20:19 +0000 (15:20 +0000)
SVN-Revision: 35197

lang/perl/perlbase.mk

index 595cb1b8bf0f6f4d15d1da3850703ea1b4239ba1..b6f5f78be0d717b1d56bc759be9f9351b5986b44 100644 (file)
@@ -1466,8 +1466,9 @@ TITLE:=Test perl module
 endef
 
 define Package/perlbase-test/install
+$(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin
        $(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
 endef