Remove svn and cvs directory at creation time, closes #421
authorFlorian Fainelli <florian@openwrt.org>
Tue, 28 Mar 2006 13:39:23 +0000 (13:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 28 Mar 2006 13:39:23 +0000 (13:39 +0000)
SVN-Revision: 3520

openwrt/target/linux/imagebuilder/Makefile

index 0ec71199c7eae3e145997019193c341375b27fb5..12bd6cbbbbff5baf8abefc6741a38c0e1784b69e 100644 (file)
@@ -45,4 +45,5 @@ build:
        if [ -d ./files.$(LIST) ]; then \
                cp -a --remove-destination ./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
        fi
+       find $(LINUX_BUILD_DIR)/root -name '.svn' || 'CVS' | xargs rm -rf
        $(MAKE) -S -C image KERNEL="$(KERNEL)" BOARD="$(BOARD)" BIN_DIR="$(BIN_DIR)/$(LIST)" install