linknx: streamline makefile 1049/head
authorOthmar Truniger <github@truniger.ch>
Tue, 17 Mar 2015 19:41:51 +0000 (20:41 +0100)
committerOthmar Truniger <github@truniger.ch>
Tue, 17 Mar 2015 19:41:51 +0000 (20:41 +0100)
Signed-off-by: Othmar Truniger <github@truniger.ch>
net/linknx/Makefile

index e3aed3b15111edbc3e921928929412de95cddd33..3472e48c7bfcf275363afc94261d7cedd78af255 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2014 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linknx
 PKG_VERSION:=0.0.1.32
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
 
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
@@ -17,7 +17,6 @@ PKG_LICENSE:=GPL-2.0+
 
 PKG_SOURCE_URL:=@SF/linknx
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DEPENDS:=pthsem curl libesmtp
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,26 +25,19 @@ define Package/linknx
   CATEGORY:=Network
   TITLE:=KNX home automation platform
   URL:=http://sourceforge.net/projects/linknx/
-  DEPENDS:=pthsem +lua +luac +libstdcpp +libcurl +libesmtp
+  DEPENDS:=+pthsem +argp-standalone +lua +luac +libstdcpp +libcurl +libesmtp
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch aclocal.m4 Makefile.in config.h.in configure; \
-       $(SED) 's,\"2.0.4\",\"2.0.4\"\n_pth_version=\"2.0.8\",g' $(PKG_BUILD_DIR)/configure )
-       $(call Build/Configure/Default,--verbose --without-pth-test --with-pth=$(STAGING_DIR) --without-log4cpp --with-lua --with-libcurl --without-mysql, \
-       CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -lcrypt" \
-       )
-endef
+CONFIGURE_ARGS+= \
+       --verbose \
+       --without-pth-test \
+       --without-log4cpp \
+       --with-lua \
+       --with-libcurl \
+       --without-mysql
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/ \
-               LIBDIR="$(TARGET_LDFLAGS)" \
-               CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) " \
-               LD="$(TARGET_CROSS)ld -shared" \
-               LUA="$(STAGING_DIR_HOST)/bin/lua" \
-               LUAC="$(STAGING_DIR_HOST)/bin/luac" \
-               CFLAGS="$(TARGET_CFLAGS) -nodefaultlibs" all
-endef
+EXTRA_LDFLAGS+= \
+        -fno-builtin
 
 define Package/linknx/install
        $(INSTALL_DIR) $(1)/usr/bin