[FreeSWITCH]
authorMazi Lo <openwrt.mazilo@recursor.net>
Sun, 6 Sep 2015 04:45:25 +0000 (00:45 -0400)
committerMazi Lo <openwrt.mazilo@recursor.net>
Sun, 6 Sep 2015 04:45:25 +0000 (00:45 -0400)
1. Removed PROCESS_SHARED locks check from libs/apr/configure.ac.
2. Flagged mod_flite as BROKEN due to lack of flite package.
3. Added some additional modules, i.e. mod_av, mod_esl, and flagged as BROKEN for now.
4. Depricated mod_celt.

Signed-off-by: Mazi Lo <openwrt.mazilo@recursor.net>
net/freeswitch/Makefile
net/freeswitch/patches/uClibc/configure_ac.patch
net/freeswitch/patches/uClibc/libs-apr-configure_ac.patch

index c7fe02ff44f0e9b0bae33c5724a8a58a92bcd8a1..1148884d81a81c1643b15fbe3bfccf731755c87a 100644 (file)
@@ -19,7 +19,7 @@ PKG_VERSION:=1.5.final
 # The latest FS git hash in PKG_SOURCE_VERSION can be obtained from
 # http://fisheye.freeswitch.org
 #
-FS_WITH_DEFAULT_HEAD:=bff9aab850a911e27b316b016c62f91f657719cd
+FS_WITH_DEFAULT_HEAD:=16d600c0350a79c2532c739dd1432f7ed318ea09
 PKG_SOURCE_URL:=https://$(PKG_NAME).org/stash/scm/fs/$(PKG_NAME).git
 PKG_SOURCE_VERSION:=$(if $(CONFIG_FS_WITH_LATEST_HEAD),$(shell git ls-remote $(PKG_SOURCE_URL) HEAD|cut -f1),$(FS_WITH_DEFAULT_HEAD))
 FS_WITH_DEFAULT_HEAD_SHORT:=$(shell echo $(FS_WITH_DEFAULT_HEAD)|cut -b -7)
@@ -61,6 +61,7 @@ FS_MOD_AVAILABLE:= \
        alsa \
        amr \
        amrwb \
+       av \
        avmd \
        basic \
        bert \
@@ -71,7 +72,6 @@ FS_MOD_AVAILABLE:= \
        cdr-mongodb \
        cdr-pg-csv \
        cdr-sqlite \
-       celt \
        cepstral \
        cidlookup \
        cluechoo \
@@ -94,6 +94,7 @@ FS_MOD_AVAILABLE:= \
        enum \
        erlang-event \
        esf \
+       esl \
        event-multicast \
        event-socket \
        event-zmq \
@@ -958,6 +959,7 @@ $(eval $(call BuildPlugin,abstraction,An Abstraction To API Call,vanilla,,,,))
 $(eval $(call BuildPlugin,alsa,Alsa Endpoint,vanilla,,,,+FS_WITH_ALSA:alsa-lib @FS_WITH_ALSA))
 $(eval $(call BuildPlugin,amr,Adaptive Multi-Rate On Bandwidth Codec,vanilla,,,,))
 $(eval $(call BuildPlugin,amrwb,Wide Band AMR,vanilla,,,,))
+$(eval $(call BuildPlugin,av,FS Video Codec / File Format,vanilla,,,,@BROKEN))
 $(eval $(call BuildPlugin,avmd,Advanced Voice Mail Detection,vanilla,,,,))
 $(eval $(call BuildPlugin,basic,BASIC,vanilla,,,,))
 $(eval $(call BuildPlugin,bert,Naive Bit Error Rate Tester,vanilla,,,,))
@@ -968,7 +970,6 @@ $(eval $(call BuildPlugin,cdr-csv,CSV-CDR Handler,mod,,,,)) # ~/conf
 $(eval $(call BuildPlugin,cdr-mongodb,MongoDB CDR logger,vanilla,,,,))
 $(eval $(call BuildPlugin,cdr-pg-csv,PostgreSQL CDR Handler,vanilla,,,,+coreutils +FS_WITH_POSTGRESQL:libpq @FS_WITH_POSTGRESQL))
 $(eval $(call BuildPlugin,cdr-sqlite,SQLite3 CDR Handler,vanilla,,,,@FS_WITH_SQLITE3))
-$(eval $(call BuildPlugin,celt,CELT Ultra-Low Delay Codec,vanilla,,,,+libogg))
 $(eval $(call BuildPlugin,cepstral,Cepstral Interface,vanilla,,,,@BROKEN)) # needs <swift.h>
 $(eval $(call BuildPlugin,cidlookup,Data Query For CID->NAME Services,mod,,,,+libcurl)) # ~/conf
 $(eval $(call BuildPlugin,cluechoo,Framework Demo,vanilla,,,,))
@@ -991,13 +992,14 @@ $(eval $(call BuildPlugin,easyroute,Simple DID Routing,vanilla,,,,))
 $(eval $(call BuildPlugin,enum,ENUM Routing,,,,,+libldns))
 $(eval $(call BuildPlugin,erlang-event,Erlang Event Handler,vanilla,,,,+erlang))
 $(eval $(call BuildPlugin,esf,Extra SIP Functionality,vanilla,,,,))
+$(eval $(call BuildPlugin,esl,Allow to generate remote ESL commands,vanilla,,,,@BROKEN))
 $(eval $(call BuildPlugin,event-multicast,Multicast Event Handler,vanilla,,,,))
 $(eval $(call BuildPlugin,event-socket,Socket Event Handler,vanilla,,,,))
 $(eval $(call BuildPlugin,event-zmq,Socket Event Handler By Zero MQ,vanilla,,,,+libuuid))
 $(eval $(call BuildPlugin,expr,Expression Evaluation,vanilla,,,,))
 $(eval $(call BuildPlugin,fifo,FIFO,vanilla,,,,))
 $(eval $(call BuildPlugin,file-string,Streaming Multiple Sound Files Sequentially,vanilla,,,,@OBSOLETE)) # merged into dptools
-$(eval $(call BuildPlugin,flite,Festival TTS,vanilla,,,,+flite @(!(armeb||avr32)||BROKEN))) # flite is from old package repo
+$(eval $(call BuildPlugin,flite,Festival TTS,vanilla,,,,+flite @BROKEN)) # flite is from old package and/or qi repo
 $(eval $(call BuildPlugin,format-cdr,XML CDR Module to files or curl,vanilla,,,,))
 $(eval $(call BuildPlugin,fsk,Bell-202 1200-Baud FSK Decoder,vanilla,,,,))
 $(eval $(call BuildPlugin,fsv,Video Player / Recorder,vanilla,,,,+libyuv @BROKEN)) # Requires unsupported libyuv.
index 85a27880f5f6658316cd46f20d5ddb8b697be9e6..477af6bbc3400673cd1bd7c945e3254854ed37fb 100644 (file)
@@ -14,7 +14,7 @@
                export ac_cv_func_pthread_rwlock_init=yes
                export apr_cv_type_rwlock_t=yes
 -              export apr_cv_process_shared_works=yes
-+              export apr_cv_process_shared_works=no
++              #export apr_cv_process_shared_works=no
                export apr_cv_mutex_robust_shared=yes
         ;;
      esac
index c4667ddaebc03e1c13a730f403a5ea35af14065b..7c0630f9d2974f07a3e018138ae606475254a1f5 100644 (file)
@@ -1,6 +1,46 @@
 --- a/libs/apr/configure.ac
 +++ b/libs/apr/configure.ac
-@@ -1956,7 +1956,11 @@ fi
+@@ -1624,38 +1624,7 @@ if test "$threads" = "1"; then
+     APR_CHECK_DEFINE(PTHREAD_PROCESS_SHARED, pthread.h)
+     AC_CHECK_FUNCS(pthread_mutexattr_setpshared)
+     AC_CHECK_LIB(pthread, pthread_setschedparam, [AC_DEFINE(HAVE_PTHREAD_SETSCHEDPARAM, 1, [Define if you have pthread_setschedparam()])])
+-
+-    # Some systems have setpshared and define PROCESS_SHARED, but don't 
+-    # really support PROCESS_SHARED locks.  So, we must validate that we 
+-    # can go through the steps without receiving some sort of system error.
+-    # Linux and older versions of AIX have this problem.
+-    APR_IFALLYES(header:pthread.h define:PTHREAD_PROCESS_SHARED func:pthread_mutexattr_setpshared, [
+-      AC_CACHE_CHECK([for working PROCESS_SHARED locks], apr_cv_process_shared_works, [
+-      AC_TRY_RUN([
+-#include <sys/types.h>
+-#include <pthread.h>
+-        int main()
+-        {
+-            pthread_mutex_t mutex;
+-            pthread_mutexattr_t attr;
+-            if (pthread_mutexattr_init(&attr))
+-                exit(1);
+-            if (pthread_mutexattr_setpshared(&attr, PTHREAD_PROCESS_SHARED))
+-                exit(2);
+-            if (pthread_mutex_init(&mutex, &attr))
+-                exit(3);
+-            if (pthread_mutexattr_destroy(&attr))
+-                exit(4);
+-            if (pthread_mutex_destroy(&mutex))
+-                exit(5);
+-            exit(0);
+-        }], [apr_cv_process_shared_works=yes], [apr_cv_process_shared_works=no])])
+-      # Override detection of pthread_mutexattr_setpshared
+-      ac_cv_func_pthread_mutexattr_setpshared=$apr_cv_process_shared_works])
+-
+-    if test "$ac_cv_func_pthread_mutexattr_setpshared" = "yes"; then
+-        APR_CHECK_PTHREAD_ROBUST_SHARED_MUTEX
+-    fi
++    APR_CHECK_PTHREAD_ROBUST_SHARED_MUTEX
+ fi
+ # See which lock mechanisms we can support on this system.
+@@ -1956,7 +1925,11 @@ fi
  
  APR_CHECK_TCP_NODELAY_INHERITED
  APR_CHECK_O_NONBLOCK_INHERITED