Merge pull request #22095 from jefferyto/rust-arch-depends
authorTianling Shen <cnsztl@immortalwrt.org>
Thu, 14 Sep 2023 13:28:06 +0000 (21:28 +0800)
committerGitHub <noreply@github.com>
Thu, 14 Sep 2023 13:28:06 +0000 (21:28 +0800)
rust: Move RUST_ARCH_DEPENDS into rust-values.mk

lang/rust/rust-package.mk
lang/rust/rust-values.mk

index 955b37c29e796dfb3bda65468fc9da6e913a74d6..e8cf7d71290f30467f0bd0a180d51fc1d4eac325 100644 (file)
@@ -15,9 +15,6 @@ ifeq ($(origin RUST_INCLUDE_DIR),undefined)
 endif
 include $(RUST_INCLUDE_DIR)/rust-values.mk
 
-# Support only a subset for now.
-RUST_ARCH_DEPENDS:=@(aarch64||arm||i386||i686||mips||mipsel||mips64||mips64el||mipsel||powerpc64||riscv64||x86_64)
-
 # $(1) path to the package (optional)
 # $(2) additional arguments to cargo (optional)
 define Build/Compile/Cargo
index 26935c0f62e0298cf95e6033d5d3996ea182f511..58ce2f16da7bbf821357aebb382abb8b4c22ed2c 100644 (file)
@@ -57,3 +57,6 @@ endif
 ifeq ($(ARCH),aarch64)
     RUST_CFLAGS:=-mno-outline-atomics
 endif
+
+# Support only a subset for now.
+RUST_ARCH_DEPENDS:=@(aarch64||arm||i386||i686||mips||mipsel||mips64||mips64el||mipsel||powerpc64||riscv64||x86_64)