python: add ncurses(w) include folders for host python 896/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Tue, 10 Feb 2015 19:22:20 +0000 (21:22 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 11 Feb 2015 18:20:14 +0000 (20:20 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile

index 0c1be6de8cb0f7056b2970b260b8ebb122d4bbfc..d33ede8920798aced25c5bacf263ab19590ee1e3 100644 (file)
@@ -191,6 +191,10 @@ define PyPackage/python-base/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
 endef
 
+HOST_CFLAGS+= \
+       -I/usr/include/ncursesw \
+       -I/usr/include/ncurses
+
 HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \
@@ -198,7 +202,7 @@ HOST_CONFIGURE_ARGS+= \
        --prefix=$(STAGING_DIR_HOST) \
        --with-ensurepip=upgrade \
        CONFIG_SITE= \
-       OPT="$(HOST_CFLAGS)"
+       CFLAGS="$(HOST_CFLAGS)"
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/